From mboxrd@z Thu Jan 1 00:00:00 1970 Return-Path: Received: (majordomo@vger.kernel.org) by vger.kernel.org via listexpand id S1753416AbdJLIJU (ORCPT ); Thu, 12 Oct 2017 04:09:20 -0400 Received: from mail-wm0-f67.google.com ([74.125.82.67]:47754 "EHLO mail-wm0-f67.google.com" rhost-flags-OK-OK-OK-OK) by vger.kernel.org with ESMTP id S1752153AbdJLIJT (ORCPT ); Thu, 12 Oct 2017 04:09:19 -0400 X-Google-Smtp-Source: AOwi7QAr8GKeXBMrCANWFfMmBRCPSI4IGoW641uXDLTxPKUKVoa4mu4jVr+UsBo24y+qfKHYNLb30Q== Date: Thu, 12 Oct 2017 10:09:14 +0200 From: Ingo Molnar To: Andi Kleen Cc: x86@kernel.org, linux-kernel@vger.kernel.org, Andi Kleen , Thomas Gleixner Subject: Re: [PATCH v9 3/5] x86/cpuid: Make clearcpuid an early param Message-ID: <20171012080913.g2z6uxtoyqvfbdaz@gmail.com> References: <20171007000328.12843-1-andi@firstfloor.org> <20171007000328.12843-4-andi@firstfloor.org> MIME-Version: 1.0 Content-Type: text/plain; charset=us-ascii Content-Disposition: inline In-Reply-To: <20171007000328.12843-4-andi@firstfloor.org> User-Agent: NeoMutt/20170113 (1.7.2) Sender: linux-kernel-owner@vger.kernel.org List-ID: X-Mailing-List: linux-kernel@vger.kernel.org * Andi Kleen wrote: > From: Andi Kleen > > Make clearcpuid= an early param, to make sure it is parsed > before the XSAVE initialization. This allows to modify > XSAVE state by clearing specific CPUID bits. > > Reviewed-by: Thomas Gleixner > Signed-off-by: Andi Kleen > --- > arch/x86/kernel/cpu/common.c | 2 +- > 1 file changed, 1 insertion(+), 1 deletion(-) > > diff --git a/arch/x86/kernel/cpu/common.c b/arch/x86/kernel/cpu/common.c > index fd47692e5ce9..ff51c61d2df0 100644 > --- a/arch/x86/kernel/cpu/common.c > +++ b/arch/x86/kernel/cpu/common.c > @@ -1310,7 +1310,7 @@ static __init int setup_disablecpuid(char *arg) > > return 1; > } > -__setup("clearcpuid=", setup_disablecpuid); > +early_param("clearcpuid", setup_disablecpuid); Yeah, so there's pre-existing bad naming here that should be fixed before we add new complexity to the code: why is the option named 'clearcpuid' while the function name is 'disablecpuid'? Thanks, Ingo