From mboxrd@z Thu Jan 1 00:00:00 1970 Return-Path: Received: (majordomo@vger.kernel.org) by vger.kernel.org via listexpand id S1756683AbdJMJy1 (ORCPT ); Fri, 13 Oct 2017 05:54:27 -0400 Received: from mail-wm0-f51.google.com ([74.125.82.51]:45057 "EHLO mail-wm0-f51.google.com" rhost-flags-OK-OK-OK-OK) by vger.kernel.org with ESMTP id S1751564AbdJMJy0 (ORCPT ); Fri, 13 Oct 2017 05:54:26 -0400 X-Google-Smtp-Source: AOwi7QCd6fPEw1bRqaiIpMUkBuOYaSfx4KoF7xxpIhaa0tub9ZLLs9KuyOH/5sDsL0l6evByIfVFvA== Date: Fri, 13 Oct 2017 10:54:22 +0100 From: Lee Jones To: Greg KH Cc: rui_feng@realsil.com.cn, linux-kernel@vger.kernel.org, devel@driverdev.osuosl.org, ricky_wu@realtek.com Subject: Re: [PATCH] staging: rtsx: Add support for RTS5260 Message-ID: <20171013095422.6mql3mso77duoiko@dell> References: <1507884635-3134-1-git-send-email-rui_feng@realsil.com.cn> <20171013092659.GA28241@kroah.com> MIME-Version: 1.0 Content-Type: text/plain; charset=utf-8 Content-Disposition: inline Content-Transfer-Encoding: 8bit In-Reply-To: <20171013092659.GA28241@kroah.com> User-Agent: NeoMutt/20170113 (1.7.2) Sender: linux-kernel-owner@vger.kernel.org List-ID: X-Mailing-List: linux-kernel@vger.kernel.org On Fri, 13 Oct 2017, Greg KH wrote: > On Fri, Oct 13, 2017 at 04:50:35PM +0800, rui_feng@realsil.com.cn wrote: > > From: rui_feng > > > > Add support for new chip rts5260. > > In order to support rts5260,the definitions of some internal > > registers and workflow have to be modified and are different from its > > predecessors and OCP function is added for RTS5260. > > So we need this patch to ensure RTS5260 can work. > > > > Signed-off-by: Rui Feng > > Your from and signed-off-by name does not match :( > > > --- > > drivers/mfd/Makefile | 4 + > > drivers/mfd/rtsx_pcr.c | 127 ++++++- > > drivers/mfd/rtsx_pcr.h | 12 + > > drivers/staging/Kconfig | 2 + > > drivers/staging/rts5260/Kconfig | 6 + > > drivers/staging/rts5260/rts5260.c | 748 ++++++++++++++++++++++++++++++++++++++ > > drivers/staging/rts5260/rts5260.h | 45 +++ > > include/linux/mfd/rtsx_pci.h | 234 +++++++++++- > > I do not see a reason why this is a staging driver. Where is the TODO > file listing what needs to be done to get it out of staging? Why can it > not just go into the "real" part of the kernel? It's not a staging driver. Rui's focus appears to be to have this driver accepted into Mainline by hook or by crock. He's tried MFD, Misc and now Staging! Background: There are a number of drivers in this family which currently reside in MFD. These were accepted before my time. After a recent review I've made the decision that these aren't MFD drivers at all. MFD drivers are ones which aid in registering and setting up shared resources for sub-devices which reside on the same piece of silicon. This driver does basically none of that. Instead it *is* the (what we describe above as) sub-device. It does everything. In the absence of a subsystem which covers this type of device, I suggested Misk as a good location to place these drivers. -- Lee Jones Linaro STMicroelectronics Landing Team Lead Linaro.org │ Open source software for ARM SoCs Follow Linaro: Facebook | Twitter | Blog