From mboxrd@z Thu Jan 1 00:00:00 1970 Return-Path: Received: (majordomo@vger.kernel.org) by vger.kernel.org via listexpand id S1753232AbdJMRqV (ORCPT ); Fri, 13 Oct 2017 13:46:21 -0400 Received: from mga05.intel.com ([192.55.52.43]:6750 "EHLO mga05.intel.com" rhost-flags-OK-OK-OK-OK) by vger.kernel.org with ESMTP id S1752927AbdJMRqG (ORCPT ); Fri, 13 Oct 2017 13:46:06 -0400 X-ExtLoop1: 1 X-IronPort-AV: E=Sophos;i="5.43,371,1503385200"; d="scan'208";a="162878803" Date: Fri, 13 Oct 2017 10:46:05 -0700 From: Andi Kleen To: Ingo Molnar Cc: Andi Kleen , x86@kernel.org, linux-kernel@vger.kernel.org, Jonathan McDowell , Thomas Gleixner Subject: Re: [PATCH v9 2/5] x86/cpuid: Add generic table for cpuid dependencies Message-ID: <20171013174605.GQ5109@tassilo.jf.intel.com> References: <20171007000328.12843-1-andi@firstfloor.org> <20171007000328.12843-3-andi@firstfloor.org> <20171012080733.4y5wlghjr524cgr3@gmail.com> <20171012081634.5xu2vtmmt3hbqohp@gmail.com> MIME-Version: 1.0 Content-Type: text/plain; charset=us-ascii Content-Disposition: inline In-Reply-To: <20171012081634.5xu2vtmmt3hbqohp@gmail.com> User-Agent: Mutt/1.9.0 (2017-09-02) Sender: linux-kernel-owner@vger.kernel.org List-ID: X-Mailing-List: linux-kernel@vger.kernel.org > So instead of adding helpers the 1<< ops can be written out explicitly - they are > easy to read after all. Can also be: > > var &= ~BIT(bit); > var |= BIT(bit); It's some more complicated because "var" are arrays. Opencoding is fairly ugly. I changed the main bitmap to use DECLARE_BITMAP now, which avoids most of the casts. For accessing c->x86_capability and cpu_caps_cleared it uses helpers now that do implicit casting. -Andi