From mboxrd@z Thu Jan 1 00:00:00 1970 Return-Path: Received: (majordomo@vger.kernel.org) by vger.kernel.org via listexpand id S932181AbdJVTDc (ORCPT ); Sun, 22 Oct 2017 15:03:32 -0400 Received: from mail-wm0-f65.google.com ([74.125.82.65]:54144 "EHLO mail-wm0-f65.google.com" rhost-flags-OK-OK-OK-OK) by vger.kernel.org with ESMTP id S932116AbdJVTDa (ORCPT ); Sun, 22 Oct 2017 15:03:30 -0400 X-Google-Smtp-Source: ABhQp+R67JgSD7o6FZGddO3yVUa09DXrw8YhXhOM4cq6fDSMBuREANHY2GSFTYKKhBl5/8/RKqIGjA== Date: Sun, 22 Oct 2017 21:03:27 +0200 From: Krzysztof Kozlowski To: SF Markus Elfring Cc: linux-crypto@vger.kernel.org, linux-samsung-soc@vger.kernel.org, "David S. Miller" , Herbert Xu , Vladimir Zapolskiy , LKML , kernel-janitors@vger.kernel.org Subject: Re: [PATCH] crypto/s5p-sss: Use common error handling code in s5p_aes_probe() Message-ID: <20171022190327.mfndyyr4b4iinv2d@kozik-lap> References: <791df15e-3a35-d270-0acf-1661bd89adad@users.sourceforge.net> MIME-Version: 1.0 Content-Type: text/plain; charset=utf-8 Content-Disposition: inline In-Reply-To: <791df15e-3a35-d270-0acf-1661bd89adad@users.sourceforge.net> User-Agent: NeoMutt/20170113 (1.7.2) Sender: linux-kernel-owner@vger.kernel.org List-ID: X-Mailing-List: linux-kernel@vger.kernel.org On Sun, Oct 22, 2017 at 03:05:05PM +0200, SF Markus Elfring wrote: > From: Markus Elfring > Date: Sun, 22 Oct 2017 15:00:27 +0200 > > Add a jump target so that a bit of exception handling can be better reused > at the end of this function. > > This issue was detected by using the Coccinelle software. > > Signed-off-by: Markus Elfring > --- > drivers/crypto/s5p-sss.c | 13 +++++++------ > 1 file changed, 7 insertions(+), 6 deletions(-) > > diff --git a/drivers/crypto/s5p-sss.c b/drivers/crypto/s5p-sss.c > index 7ac657f46d15..ea59e184c199 100644 > --- a/drivers/crypto/s5p-sss.c > +++ b/drivers/crypto/s5p-sss.c > @@ -863,16 +863,13 @@ static int s5p_aes_probe(struct platform_device *pdev) > pdata->irq_fc = platform_get_irq(pdev, 0); > if (pdata->irq_fc < 0) { > err = pdata->irq_fc; > - dev_warn(dev, "feed control interrupt is not available.\n"); > - goto err_irq; > + goto report_failure; > } > err = devm_request_threaded_irq(dev, pdata->irq_fc, NULL, > s5p_aes_interrupt, IRQF_ONESHOT, > pdev->name, pdev); > - if (err < 0) { > - dev_warn(dev, "feed control interrupt is not available.\n"); > - goto err_irq; > - } > + if (err < 0) > + goto report_failure; No, one exit path just to report error does not seem to be more readable. Instead, printing error after the code causing it looks to me as common pattern, easy to maintain. This patch does not bring improvement, in my opinion. Best regards, Krzysztof > > pdata->busy = false; > pdata->dev = dev; > @@ -906,6 +903,10 @@ static int s5p_aes_probe(struct platform_device *pdev) > s5p_dev = NULL; > > return err; > + > +report_failure: > + dev_warn(dev, "feed control interrupt is not available.\n"); > + goto err_irq; > } > > static int s5p_aes_remove(struct platform_device *pdev) > -- > 2.14.2 >