From: Ingo Molnar <mingo@kernel.org>
To: Frederic Weisbecker <frederic@kernel.org>
Cc: LKML <linux-kernel@vger.kernel.org>,
Peter Zijlstra <peterz@infradead.org>,
Chris Metcalf <cmetcalf@mellanox.com>,
Thomas Gleixner <tglx@linutronix.de>,
Luiz Capitulino <lcapitulino@redhat.com>,
Christoph Lameter <cl@linux.com>,
"Paul E . McKenney" <paulmck@linux.vnet.ibm.com>,
Mike Galbraith <efault@gmx.de>, Rik van Riel <riel@redhat.com>,
Wanpeng Li <kernellwp@gmail.com>
Subject: Re: [GIT PULL] Introduce housekeeping subsystem v4
Date: Mon, 23 Oct 2017 14:06:31 +0200 [thread overview]
Message-ID: <20171023120631.dkpymlvfavh4zmpn@gmail.com> (raw)
In-Reply-To: <CAFTL4hxPPHqjF-P6e+SZiktHcKjCq0kVhKnMgK=gHnzFigkzbQ@mail.gmail.com>
* Frederic Weisbecker <frederic@kernel.org> wrote:
> In fact, CPU affinity is the only high level concept I found to gather all these
> housekeeping elements.
>
> Perhaps I should use "cpu_isolation" instead of "housekeeping" naming.
The problem with names based on that, like cpu_isolation_map, is that there's
really two concepts here: there's the isolcpus feature where the 'mask' is in fact
the CPUs that are isolated - while the 'housekeeping CPUs' is the mask of CPUs
that _support_ the isolated set of CPUs. The two are different roles but easily
confused if named similarly.
So I guess 'housekeeping CPUs' is as good as it gets for now.
Mind sending a refreshed queue against the latest kernel? There's some new
conflicts in kernel/watchdog.c for example.
Thanks,
Ingo
next prev parent reply other threads:[~2017-10-23 12:06 UTC|newest]
Thread overview: 22+ messages / expand[flat|nested] mbox.gz Atom feed top
2017-09-18 13:53 Frederic Weisbecker
2017-09-18 13:53 ` [PATCH 01/12] housekeeping: Move housekeeping related code to its own file Frederic Weisbecker
2017-09-18 13:53 ` [PATCH 02/12] watchdog: Use housekeeping_cpumask() instead of ad-hoc version Frederic Weisbecker
2017-09-18 13:54 ` [PATCH 03/12] housekeeping: Provide a dynamic off-case to housekeeping_any_cpu() Frederic Weisbecker
2017-09-18 13:54 ` [PATCH 04/12] housekeeping: Make housekeeping cpumask private Frederic Weisbecker
2017-09-18 13:54 ` [PATCH 05/12] housekeeping: Use its own static key Frederic Weisbecker
2017-09-18 13:54 ` [PATCH 06/12] housekeeping: Rename is_housekeeping_cpu to housekeeping_cpu Frederic Weisbecker
2017-09-18 13:54 ` [PATCH 07/12] housekeeping: Move it under its own config, independant from NO_HZ Frederic Weisbecker
2017-09-18 13:54 ` [PATCH 08/12] housekeeping: Introduce housekeeping flags Frederic Weisbecker
2017-09-18 13:54 ` [PATCH 09/12] housekeeping: Handle nohz_full= parameter Frederic Weisbecker
2017-09-18 13:54 ` [PATCH 10/12] housekeeping: Move isolcpus to housekeeping Frederic Weisbecker
2017-09-18 13:54 ` [PATCH 11/12] housekeeping: Add basic isolcpus flags Frederic Weisbecker
2017-09-18 13:54 ` [PATCH 12/12] housekeeping: Document " Frederic Weisbecker
2017-09-28 9:54 ` [GIT PULL] Introduce housekeeping subsystem v4 Ingo Molnar
2017-09-29 13:34 ` Frederic Weisbecker
2017-10-01 6:36 ` Christopher Lameter
2017-10-15 15:53 ` Frederic Weisbecker
2017-10-20 8:17 ` Ingo Molnar
2017-10-20 14:29 ` Frederic Weisbecker
2017-10-21 16:07 ` Chris Metcalf
2017-10-23 12:06 ` Ingo Molnar [this message]
2017-10-24 2:42 ` Frederic Weisbecker
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=20171023120631.dkpymlvfavh4zmpn@gmail.com \
--to=mingo@kernel.org \
--cc=cl@linux.com \
--cc=cmetcalf@mellanox.com \
--cc=efault@gmx.de \
--cc=frederic@kernel.org \
--cc=kernellwp@gmail.com \
--cc=lcapitulino@redhat.com \
--cc=linux-kernel@vger.kernel.org \
--cc=paulmck@linux.vnet.ibm.com \
--cc=peterz@infradead.org \
--cc=riel@redhat.com \
--cc=tglx@linutronix.de \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
Powered by JetHome