From mboxrd@z Thu Jan 1 00:00:00 1970 Return-Path: Received: (majordomo@vger.kernel.org) by vger.kernel.org via listexpand id S932124AbdJXOGV (ORCPT ); Tue, 24 Oct 2017 10:06:21 -0400 Received: from mga05.intel.com ([192.55.52.43]:43148 "EHLO mga05.intel.com" rhost-flags-OK-OK-OK-OK) by vger.kernel.org with ESMTP id S1751630AbdJXOGQ (ORCPT ); Tue, 24 Oct 2017 10:06:16 -0400 X-ExtLoop1: 1 X-IronPort-AV: E=Sophos;i="5.43,428,1503385200"; d="scan'208";a="1209461587" Date: Tue, 24 Oct 2017 16:04:15 +0200 From: Jarkko Sakkinen To: Stefan Berger Cc: linux-integrity@vger.kernel.org, David Howells , Herbert Xu , "open list:INTEGRITY MEASUREMENT ARCHITECTURE IMA" , Dmitry Kasatkin , open list , Jason Gunthorpe , linux-security-module@vger.kernel.org, "moderated list:TPM DEVICE DRIVER" , "open list:KEYS-TRUSTED" , "open list:HARDWARE RANDOM NUMBER GENERATOR CORE" , James Morris , Matt Mackall , "open list:INTEGRITY MEASUREMENT ARCHITECTURE IMA" , David Safford , Mimi Zohar , "Serge E. Hallyn" Subject: Re: [tpmdd-devel] [PATCH] tpm: remove chip_num parameter from in-kernel API Message-ID: <20171024140415.wx6oyqpktbebjt25@linux.intel.com> References: <20171023123817.18559-1-jarkko.sakkinen@linux.intel.com> MIME-Version: 1.0 Content-Type: text/plain; charset=us-ascii Content-Disposition: inline In-Reply-To: Organization: Intel Finland Oy - BIC 0357606-4 - Westendinkatu 7, 02160 Espoo User-Agent: NeoMutt/20170609 (1.8.3) Sender: linux-kernel-owner@vger.kernel.org List-ID: X-Mailing-List: linux-kernel@vger.kernel.org On Mon, Oct 23, 2017 at 10:07:31AM -0400, Stefan Berger wrote: > I think every kernel internal TPM driver API should be called with the > tpm_chip as a parameter. This is in foresight of namespacing of IMA where we > want to provide the flexibility of passing a dedicated vTPM to each > namespace and IMA would use the chip as a parameter to all of these > functions to talk to the right tpm_vtpm_proxy instance. From that > perspective this patch goes into the wrong direction. > > Stefan The goal of this patch is to kernel code that never gets executed. It removes a load of completely dead code. It is the only thing that this commit does. Why do you think this is "going into wrong direction" if it only removes dead code and refines the documentation up to date? After the dead code has been removed it makes sense to propose a better mechanism. Maybe the one that you are speaking about. But you need to remove the cruft first. /Jarkko