From mboxrd@z Thu Jan 1 00:00:00 1970 Return-Path: Received: (majordomo@vger.kernel.org) by vger.kernel.org via listexpand id S932986AbdKAMGI (ORCPT ); Wed, 1 Nov 2017 08:06:08 -0400 Received: from mail-pg0-f54.google.com ([74.125.83.54]:56259 "EHLO mail-pg0-f54.google.com" rhost-flags-OK-OK-OK-OK) by vger.kernel.org with ESMTP id S932356AbdKAMGD (ORCPT ); Wed, 1 Nov 2017 08:06:03 -0400 X-Google-Smtp-Source: ABhQp+T2cHovPl8klBG2xvVyyEQoZUh58i9ENq1dg4cN7UmopzjSOX8YEaX6LiK+h5/DtDXLXsw4pg== Date: Wed, 1 Nov 2017 21:03:36 +0900 From: Namhyung Kim To: "Wangnan (F)" Cc: linux-kernel@vger.kernel.org, kan.liang@intel.com, acme@kernel.org, jolsa@redhat.com, kernel-team@lge.com Subject: Re: [PATCH 2/2] perf record: Replace 'overwrite' by 'flightrecorder' for better naming Message-ID: <20171101120336.GB26623@danjae.aot.lge.com> References: <20171101055327.141281-1-wangnan0@huawei.com> <20171101055327.141281-3-wangnan0@huawei.com> <20171101100347.GC25146@danjae.aot.lge.com> <0bd4363a-12f1-d9e1-12b2-82360d397ccb@huawei.com> MIME-Version: 1.0 Content-Type: text/plain; charset=utf-8 Content-Disposition: inline In-Reply-To: <0bd4363a-12f1-d9e1-12b2-82360d397ccb@huawei.com> User-Agent: Mutt/1.9.1 (2017-09-22) Sender: linux-kernel-owner@vger.kernel.org List-ID: X-Mailing-List: linux-kernel@vger.kernel.org On Wed, Nov 01, 2017 at 06:17:26PM +0800, Wangnan (F) wrote: > > > On 2017/11/1 18:03, Namhyung Kim wrote: > > On Wed, Nov 01, 2017 at 05:53:27AM +0000, Wang Nan wrote: > > > The meaning of perf record's "overwrite" option and many "overwrite" in > > > source code are not clear. In perf's code, the 'overwrite' has 2 meanings: > > > 1. Make ringbuffer readonly (perf_evlist__mmap_ex's argument). > > > 2. Set evsel's "backward" attribute (in apply_config_terms). > > > > > > perf record doesn't use meaning 1 at all, but have a overwrite option, its > > > real meaning is setting backward. > > > > > > This patch separates these two concepts, introduce 'flightrecorder' mode > > > which is what we really want. It combines these 2 concept together, wraps > > > them into a record mode. In flight recorder mode, perf only dumps data before > > > something happen. > > I'm ok with the it but removing old name looks not good. How about > > keeping them for a while (as deprecated)?. > > Is there a way to hide '--overwrite' from 'perf record --help' and print > something > when user really use it? You can set PARSE_OPT_HIDDEN flag to it. Thanks, Namhyung > > > And 'flightrecorder' seems too long. Maybe you can use an acronym > > like FDR or fdr-mode? > > fdr-mode is a good name. > > Thank you. >