mirror of https://lore.kernel.org/lkml/
 help / color / mirror / Atom feed
From: Dan Carpenter <dan.carpenter@oracle.com>
To: Gilad Ben-Yossef <gilad@benyossef.com>
Cc: Greg Kroah-Hartman <gregkh@linuxfoundation.org>,
	devel@driverdev.osuosl.org,
	Linux kernel mailing list <linux-kernel@vger.kernel.org>,
	driverdev-devel@linuxdriverproject.org,
	Linux Crypto Mailing List <linux-crypto@vger.kernel.org>,
	Ofir Drang <ofir.drang@arm.com>
Subject: Re: [PATCH 00/24] staging: ccree: more cleanup patches
Date: Tue, 14 Nov 2017 12:48:18 +0300	[thread overview]
Message-ID: <20171114094818.rlwnetzq5qrgsntj@mwanda> (raw)
In-Reply-To: <CAOtvUMdcFo80GCqQU9q9W7sEGK9fZUEykW59sgJMtFU59=1M_w@mail.gmail.com>

On Tue, Nov 14, 2017 at 11:33:20AM +0200, Gilad Ben-Yossef wrote:
> On Mon, Nov 13, 2017 at 8:33 PM, Dan Carpenter <dan.carpenter@oracle.com> wrote:
> > These cleanups look nice.  Thanks.
> >
> > I hope you do a mass remove of likely/unlikely in a patch soon.
> > Whenever, I see one of those in a + line I always have to remind myself
> > that you're planning to do it in a later patch.
> >
> 
> So, a question about that - there indeed seems to be an inflation of
> likely/unlikely in the ccree driver, but
> what stopped me from removing them was that I found out I don't have a
> clue about when it's a good idea
> to use them and when it isn't (obviously in places where you know the
> probable code flow of course).
> 
> Any hints?

They should only be included if benchmarking shows that it makes a
difference.  I think they need to be about 100 right predictions to 1
wrong prediction on a fast path.  So remove them all and add them back
one at a time.


regards,
dan carpenter

  reply	other threads:[~2017-11-14  9:48 UTC|newest]

Thread overview: 31+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2017-11-13 14:45 Gilad Ben-Yossef
2017-11-13 14:45 ` [PATCH 01/24] staging: ccree: fix typos Gilad Ben-Yossef
2017-11-13 14:45 ` [PATCH 02/24] staging: ccree: alloc by instance not type Gilad Ben-Yossef
2017-11-13 14:45 ` [PATCH 03/24] staging: ccree: remove unnecessary parentheses Gilad Ben-Yossef
2017-11-13 14:45 ` [PATCH 04/24] staging: ccree: remove MIN/MAX macros Gilad Ben-Yossef
2017-11-13 14:45 ` [PATCH 05/24] staging: ccree: move logical cont. to 1st line Gilad Ben-Yossef
2017-11-13 14:45 ` [PATCH 06/24] staging: ccree: remove unneeded empty lines Gilad Ben-Yossef
2017-11-13 14:45 ` [PATCH 07/24] staging: ccree: remove unneeded cast Gilad Ben-Yossef
2017-11-13 15:41   ` Joe Perches
2017-11-14  9:30     ` Gilad Ben-Yossef
2017-11-13 14:45 ` [PATCH 08/24] staging: ccree: make mem barrier per request Gilad Ben-Yossef
2017-11-13 14:45 ` [PATCH 09/24] staging: ccree: replace open coded loop with for Gilad Ben-Yossef
2017-11-13 14:45 ` [PATCH 10/24] staging: ccree: document spinlock usage Gilad Ben-Yossef
2017-11-13 14:45 ` [PATCH 11/24] staging: ccree: constify help string Gilad Ben-Yossef
2017-11-13 14:45 ` [PATCH 12/24] staging: ccree: fix code indent Gilad Ben-Yossef
2017-11-13 14:45 ` [PATCH 13/24] staging: ccree: Replace CONFIG_PM_RUNTIME with CONFIG_PM Gilad Ben-Yossef
2017-11-13 14:45 ` [PATCH 14/24] staging: ccree: replace macro with inline func Gilad Ben-Yossef
2017-11-13 14:45 ` [PATCH 15/24] staging: ccree: trim long lines for readability Gilad Ben-Yossef
2017-11-13 14:45 ` [PATCH 16/24] staging: ccree: remove dead defs and decls Gilad Ben-Yossef
2017-11-13 14:45 ` [PATCH 17/24] staging: ccree: refactor code with local vars Gilad Ben-Yossef
2017-11-13 14:45 ` [PATCH 18/24] staging: ccree: rename func for readability Gilad Ben-Yossef
2017-11-13 14:45 ` [PATCH 19/24] staging: ccree: rename long define " Gilad Ben-Yossef
2017-11-13 14:45 ` [PATCH 20/24] staging: ccree: remove unneeded wrapper function Gilad Ben-Yossef
2017-11-13 14:45 ` [PATCH 21/24] staging: ccree: remove unused field Gilad Ben-Yossef
2017-11-13 14:45 ` [PATCH 22/24] staging: ccree: replace msleep with a completion Gilad Ben-Yossef
2017-11-13 14:45 ` [PATCH 23/24] staging: ccree: use local vars for readability Gilad Ben-Yossef
2017-11-13 14:45 ` [PATCH 24/24] staging: ccree: drop unused macro Gilad Ben-Yossef
2017-11-13 18:33 ` [PATCH 00/24] staging: ccree: more cleanup patches Dan Carpenter
2017-11-14  9:33   ` Gilad Ben-Yossef
2017-11-14  9:48     ` Dan Carpenter [this message]
2017-11-15  6:35       ` Gilad Ben-Yossef

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=20171114094818.rlwnetzq5qrgsntj@mwanda \
    --to=dan.carpenter@oracle.com \
    --cc=devel@driverdev.osuosl.org \
    --cc=driverdev-devel@linuxdriverproject.org \
    --cc=gilad@benyossef.com \
    --cc=gregkh@linuxfoundation.org \
    --cc=linux-crypto@vger.kernel.org \
    --cc=linux-kernel@vger.kernel.org \
    --cc=ofir.drang@arm.com \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox

all inboxes | Powered by JetHome®