From mboxrd@z Thu Jan 1 00:00:00 1970 Return-Path: Received: (majordomo@vger.kernel.org) by vger.kernel.org via listexpand id S1751715AbdK0J1f (ORCPT ); Mon, 27 Nov 2017 04:27:35 -0500 Received: from merlin.infradead.org ([205.233.59.134]:48232 "EHLO merlin.infradead.org" rhost-flags-OK-OK-OK-OK) by vger.kernel.org with ESMTP id S1751309AbdK0J1d (ORCPT ); Mon, 27 Nov 2017 04:27:33 -0500 Date: Mon, 27 Nov 2017 10:27:27 +0100 From: Peter Zijlstra To: Andy Lutomirski Cc: Borislav Petkov , Thomas Gleixner , Ingo Molnar , "linux-kernel@vger.kernel.org" , Dave Hansen , "H . Peter Anvin" , Linus Torvalds Subject: Re: [PATCH 20/43] x86/entry: Clean up SYSENTER_stack code Message-ID: <20171127092727.lktzrtylt2ed5sfz@hirez.programming.kicks-ass.net> References: <20171124172411.19476-1-mingo@kernel.org> <20171124172411.19476-21-mingo@kernel.org> <20171125163956.nrxpobf5xetnavo6@pd.tnic> <20171125171056.gdmnmtpegqq7tqv7@pd.tnic> MIME-Version: 1.0 Content-Type: text/plain; charset=us-ascii Content-Disposition: inline In-Reply-To: User-Agent: NeoMutt/20170609 (1.8.3) Sender: linux-kernel-owner@vger.kernel.org List-ID: X-Mailing-List: linux-kernel@vger.kernel.org On Sat, Nov 25, 2017 at 09:26:38AM -0800, Andy Lutomirski wrote: > On Sat, Nov 25, 2017 at 9:10 AM, Borislav Petkov wrote: > > On Sat, Nov 25, 2017 at 06:03:36PM +0100, Thomas Gleixner wrote: > >> > Maybe I should rename cpu_tss to cpu_tss_rw in that patch. > >> > >> For clarity that would be nice. > > > > + a comment stating the alias mapping. It took tglx and me a while on > > IRC to figure it out. :-) > > I'm adding this comment to the top of cpu_entry_area: > > + * Every field is a virtual alias of some other allocated backing store. > + * There is no direct allocation of a struct cpu_entry_area. Right, thanks! That did take me a few minutes to sort as well :-)