From mboxrd@z Thu Jan 1 00:00:00 1970 Return-Path: Received: (majordomo@vger.kernel.org) by vger.kernel.org via listexpand id S1751810AbdK3ViC (ORCPT ); Thu, 30 Nov 2017 16:38:02 -0500 Received: from mail.kernel.org ([198.145.29.99]:49888 "EHLO mail.kernel.org" rhost-flags-OK-OK-OK-OK) by vger.kernel.org with ESMTP id S1751748AbdK3ViA (ORCPT ); Thu, 30 Nov 2017 16:38:00 -0500 DMARC-Filter: OpenDMARC Filter v1.3.2 mail.kernel.org 2FC27214E3 Authentication-Results: mail.kernel.org; dmarc=none (p=none dis=none) header.from=goodmis.org Authentication-Results: mail.kernel.org; spf=none smtp.mailfrom=rostedt@goodmis.org Date: Thu, 30 Nov 2017 16:37:57 -0500 From: Steven Rostedt To: "Vladislav Valtchev (VMware)" Cc: linux-kernel@vger.kernel.org, y.karadz@gmail.com Subject: Re: [PATCH v2 00/10] trace-cmd: Refactoring trace_record() Message-ID: <20171130163757.6674004d@gandalf.local.home> In-Reply-To: <20171130131957.21617-1-vladislav.valtchev@gmail.com> References: <20171130131957.21617-1-vladislav.valtchev@gmail.com> X-Mailer: Claws Mail 3.14.0 (GTK+ 2.24.31; x86_64-pc-linux-gnu) MIME-Version: 1.0 Content-Type: text/plain; charset=US-ASCII Content-Transfer-Encoding: 7bit Sender: linux-kernel-owner@vger.kernel.org List-ID: X-Mailing-List: linux-kernel@vger.kernel.org On Thu, 30 Nov 2017 15:19:47 +0200 "Vladislav Valtchev (VMware)" wrote: > The following series of patches is a refactoring of trace_record() trying to > reduce as much as possible its complexity but, at the same time, without making > risky changes. All the patches are relatively small and potentially no-brainer > steps towards the final shape of the code. > > The rationale for this effort is to make the code much easier to maintain. > > Vladislav Valtchev (VMware) (10): > trace-cmd: Extract parse_record_options() from trace_record() > trace-cmd: Replacing cmd flags w/ a trace_cmd enum > trace-cmd: Extracting record_trace() > trace-cmd: Rename trace_profile() to do_trace_profile() > trace-cmd: Making start,extract,stream,profile separate funcs > trace-cmd: Extr. profile-specific code from record_trace > trace-cmd: Mov init_common_record_context in parse_record_options > trace-cmd: Introducing get_trace_cmd_type() > trace-cmd: Extract finalize_record_trace() > trace-cmd: Fork record_trace() for the extract case Hi Vlad, I applied and pushed all the patches in this series. Thanks! -- Steve > > trace-cmd.c | 8 +- > trace-local.h | 10 +- > trace-profile.c | 2 +- > trace-read.c | 2 +- > trace-record.c | 640 +++++++++++++++++++++++++++++++++----------------------- > 5 files changed, 390 insertions(+), 272 deletions(-) >