From mboxrd@z Thu Jan 1 00:00:00 1970 Received: (majordomo@vger.kernel.org) by vger.kernel.org via listexpand id S1751934AbeACUMl (ORCPT + 1 other); Wed, 3 Jan 2018 15:12:41 -0500 Received: from mail.kernel.org ([198.145.29.99]:50222 "EHLO mail.kernel.org" rhost-flags-OK-OK-OK-OK) by vger.kernel.org with ESMTP id S1751909AbeACUMj (ORCPT ); Wed, 3 Jan 2018 15:12:39 -0500 DMARC-Filter: OpenDMARC Filter v1.3.2 mail.kernel.org 8CFCC2133D Authentication-Results: mail.kernel.org; dmarc=none (p=none dis=none) header.from=kernel.org Authentication-Results: mail.kernel.org; spf=none smtp.mailfrom=jaegeuk@kernel.org Date: Wed, 3 Jan 2018 12:12:37 -0800 From: Jaegeuk Kim To: Chao Yu Cc: linux-f2fs-devel@lists.sourceforge.net, linux-kernel@vger.kernel.org, chao@kernel.org Subject: Re: [PATCH 1/2] f2fs: use flexible array for f2fs_checkpoint::sit_nat_version_bitmap Message-ID: <20180103201237.GD30014@jaegeuk-macbookpro.roam.corp.google.com> References: <20180103093251.13597-1-yuchao0@huawei.com> MIME-Version: 1.0 Content-Type: text/plain; charset=us-ascii Content-Disposition: inline In-Reply-To: <20180103093251.13597-1-yuchao0@huawei.com> User-Agent: Mutt/1.8.2 (2017-04-18) Sender: linux-kernel-owner@vger.kernel.org List-ID: X-Mailing-List: linux-kernel@vger.kernel.org Return-Path: On 01/03, Chao Yu wrote: > If we need an array with variable size in the end of structure, we > can utilize flexible array feature which is supported in C99, so > let's change sit_nat_version_bitmap[] to flexible array in struct > f2fs_checkpoint for readability. > > Signed-off-by: Chao Yu > --- > fs/f2fs/f2fs.h | 4 ++-- > include/linux/f2fs_fs.h | 2 +- > 2 files changed, 3 insertions(+), 3 deletions(-) > > diff --git a/fs/f2fs/f2fs.h b/fs/f2fs/f2fs.h > index 83d1f697388b..ad19d29688ae 100644 > --- a/fs/f2fs/f2fs.h > +++ b/fs/f2fs/f2fs.h > @@ -1719,13 +1719,13 @@ static inline void *__bitmap_ptr(struct f2fs_sb_info *sbi, int flag) > > if (__cp_payload(sbi) > 0) { > if (flag == NAT_BITMAP) > - return &ckpt->sit_nat_version_bitmap; > + return ckpt->sit_nat_version_bitmap; > else > return (unsigned char *)ckpt + F2FS_BLKSIZE; > } else { > offset = (flag == NAT_BITMAP) ? > le32_to_cpu(ckpt->sit_ver_bitmap_bytesize) : 0; > - return &ckpt->sit_nat_version_bitmap + offset; > + return ckpt->sit_nat_version_bitmap + offset; > } > } > > diff --git a/include/linux/f2fs_fs.h b/include/linux/f2fs_fs.h > index 43e98d30d2df..564f65fc192f 100644 > --- a/include/linux/f2fs_fs.h > +++ b/include/linux/f2fs_fs.h > @@ -157,7 +157,7 @@ struct f2fs_checkpoint { > unsigned char alloc_type[MAX_ACTIVE_LOGS]; > > /* SIT and NAT version bitmap */ > - unsigned char sit_nat_version_bitmap[1]; > + unsigned char sit_nat_version_bitmap[]; I cannot find any benefit to do this. Moreover, it just makes the header structure be different from the one in f2fs-tools. > } __packed; > > /* > -- > 2.15.0.55.gc2ece9dc4de6