From: Jaegeuk Kim <jaegeuk@kernel.org>
To: Chao Yu <yuchao0@huawei.com>
Cc: linux-f2fs-devel@lists.sourceforge.net,
linux-kernel@vger.kernel.org, chao@kernel.org
Subject: Re: [PATCH 1/2] f2fs: use flexible array for f2fs_checkpoint::sit_nat_version_bitmap
Date: Wed, 3 Jan 2018 22:16:58 -0800 [thread overview]
Message-ID: <20180104061658.GA51983@jaegeuk-macbookpro.roam.corp.google.com> (raw)
In-Reply-To: <75170acd-f4e4-dd12-23c6-ab3f27b17fa7@huawei.com>
On 01/04, Chao Yu wrote:
> On 2018/1/4 4:12, Jaegeuk Kim wrote:
> > On 01/03, Chao Yu wrote:
> >> If we need an array with variable size in the end of structure, we
> >> can utilize flexible array feature which is supported in C99, so
> >> let's change sit_nat_version_bitmap[] to flexible array in struct
> >> f2fs_checkpoint for readability.
> >>
> >> Signed-off-by: Chao Yu <yuchao0@huawei.com>
> >> ---
> >> fs/f2fs/f2fs.h | 4 ++--
> >> include/linux/f2fs_fs.h | 2 +-
> >> 2 files changed, 3 insertions(+), 3 deletions(-)
> >>
> >> diff --git a/fs/f2fs/f2fs.h b/fs/f2fs/f2fs.h
> >> index 83d1f697388b..ad19d29688ae 100644
> >> --- a/fs/f2fs/f2fs.h
> >> +++ b/fs/f2fs/f2fs.h
> >> @@ -1719,13 +1719,13 @@ static inline void *__bitmap_ptr(struct f2fs_sb_info *sbi, int flag)
> >>
> >> if (__cp_payload(sbi) > 0) {
> >> if (flag == NAT_BITMAP)
> >> - return &ckpt->sit_nat_version_bitmap;
> >> + return ckpt->sit_nat_version_bitmap;
> >> else
> >> return (unsigned char *)ckpt + F2FS_BLKSIZE;
> >> } else {
> >> offset = (flag == NAT_BITMAP) ?
> >> le32_to_cpu(ckpt->sit_ver_bitmap_bytesize) : 0;
> >> - return &ckpt->sit_nat_version_bitmap + offset;
> >> + return ckpt->sit_nat_version_bitmap + offset;
> >> }
> >> }
> >>
> >> diff --git a/include/linux/f2fs_fs.h b/include/linux/f2fs_fs.h
> >> index 43e98d30d2df..564f65fc192f 100644
> >> --- a/include/linux/f2fs_fs.h
> >> +++ b/include/linux/f2fs_fs.h
> >> @@ -157,7 +157,7 @@ struct f2fs_checkpoint {
> >> unsigned char alloc_type[MAX_ACTIVE_LOGS];
> >>
> >> /* SIT and NAT version bitmap */
> >> - unsigned char sit_nat_version_bitmap[1];
> >> + unsigned char sit_nat_version_bitmap[];
> >
> > I cannot find any benefit to do this. Moreover, it just makes the header
>
> I intend to change both kernel and tools, sorry, I didn't send out the
> patch on tools. Anyway, I think it could be used to avoid checkpoint
> structure size calculation by "sizeof(struct checkpoint) - 1", with the
> patch, readability can be improved. Right?
I don't think so. It's even defined only in f2fs-tools, and well covered by a
macro. There's no reason to spend time to sync it between f2fs and f2fs-tools.
>
> Thanks,
>
> > structure be different from the one in f2fs-tools.
> >
> >> } __packed;
> >>
> >> /*
> >> --
> >> 2.15.0.55.gc2ece9dc4de6
> >
> > .
> >
next prev parent reply other threads:[~2018-01-04 6:17 UTC|newest]
Thread overview: 6+ messages / expand[flat|nested] mbox.gz Atom feed top
2018-01-03 9:32 Chao Yu
2018-01-03 9:32 ` [PATCH 2/2] f2fs: clean up unneeded declaration Chao Yu
2018-01-03 20:12 ` [PATCH 1/2] f2fs: use flexible array for f2fs_checkpoint::sit_nat_version_bitmap Jaegeuk Kim
2018-01-04 1:20 ` Chao Yu
2018-01-04 6:16 ` Jaegeuk Kim [this message]
2018-01-04 6:28 ` Chao Yu
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=20180104061658.GA51983@jaegeuk-macbookpro.roam.corp.google.com \
--to=jaegeuk@kernel.org \
--cc=chao@kernel.org \
--cc=linux-f2fs-devel@lists.sourceforge.net \
--cc=linux-kernel@vger.kernel.org \
--cc=yuchao0@huawei.com \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
all inboxes | Powered by JetHome®