From: Josh Poimboeuf <jpoimboe@redhat.com>
To: David Woodhouse <dwmw2@infradead.org>
Cc: Andi Kleen <ak@linux.intel.com>, Paul Turner <pjt@google.com>,
LKML <linux-kernel@vger.kernel.org>,
Linus Torvalds <torvalds@linux-foundation.org>,
Greg Kroah-Hartman <gregkh@linux-foundation.org>,
Tim Chen <tim.c.chen@linux.intel.com>,
Dave Hansen <dave.hansen@intel.com>,
tglx@linutronix.de, Kees Cook <keescook@google.com>,
Rik van Riel <riel@redhat.com>,
Peter Zijlstra <peterz@infradead.org>,
Andy Lutomirski <luto@amacapital.net>,
Jiri Kosina <jikos@kernel.org>,
gnomes@lxorguk.ukuu.org.uk, x86@kernel.org, bp@alien8.de,
rga@amazon.de, thomas.lendacky@amd.com
Subject: Re: [PATCH v2.1] x86/retpoline: Fill return stack buffer on vmexit
Date: Thu, 11 Jan 2018 08:58:46 -0600 [thread overview]
Message-ID: <20180111145846.lqt7a5oz2w6mpo5p@treble> (raw)
In-Reply-To: <1515680912.22302.351.camel@infradead.org>
On Thu, Jan 11, 2018 at 02:28:32PM +0000, David Woodhouse wrote:
> On Thu, 2018-01-11 at 08:20 -0600, Josh Poimboeuf wrote:
> >
> > This seems weird. I liked v1 a lot better. What's the problem with
> > patching in the whole thing?
> >
> > Also, if you go back to v1, it should be an easy objtool fix, just add
> > ANNOTATE_NOSPEC_ALTERNATIVE in front of it.
>
> The objection was that I was patching in a fairly long set of
> instructions. I confess I don't actually know why that's a problem, but
> once I looked at it I realised the alignment was broken again. Again,
> alignment in the altinstr section doesn't necessarily mean alignment
> when it's copied into place over the oldinstr.
I'd *much* rather have things be consistent, and put all the crap code
behind specific features, like the retpolines already do. It makes the
source code easier to read, object code easier to read, and, ahem, makes
objtool's life a lot easier.
In fact, Boris mentioned on IRC that I could remove the
ANNOTATE_NOSPEC_ALTERNATIVE annotations, and instead have objtool detect
the nospec stuff by looking at the alternative CPU feature bit, which it
already knows how to do. So it would be really helpful to guard all
that nasty stuff behind alternatives.
I may have missed previous discussions about alignment, but if we
*really* needed alignment, maybe that could be accomplished by splitting
the alternative into two alternatives, with an .align directive as the
original instruction for the second one.
But we shouldn't even worry about alignment unless there's a real and
measureable reason to do so.
> exporting it... and defining it to take *one* register rather than
> being a macro... and ditched that approach then ended up with what's in
> v2.
Instead of exporting it you could keep it in the header file and give it
a "noinline" annotation so that it's out-of-line but still static.
--
Josh
prev parent reply other threads:[~2018-01-11 14:59 UTC|newest]
Thread overview: 13+ messages / expand[flat|nested] mbox.gz Atom feed top
2018-01-11 11:37 David Woodhouse
2018-01-11 12:26 ` Peter Zijlstra
2018-01-11 14:20 ` Josh Poimboeuf
2018-01-11 14:28 ` David Woodhouse
2018-01-11 14:32 ` Peter Zijlstra
2018-01-11 14:53 ` David Woodhouse
2018-01-11 15:04 ` Josh Poimboeuf
2018-01-11 16:10 ` David Woodhouse
2018-01-27 4:24 ` Konrad Rzeszutek Wilk
2018-01-11 15:22 ` Brian Gerst
2018-01-11 15:23 ` David Woodhouse
2018-01-11 15:28 ` Brian Gerst
2018-01-11 14:58 ` Josh Poimboeuf [this message]
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=20180111145846.lqt7a5oz2w6mpo5p@treble \
--to=jpoimboe@redhat.com \
--cc=ak@linux.intel.com \
--cc=bp@alien8.de \
--cc=dave.hansen@intel.com \
--cc=dwmw2@infradead.org \
--cc=gnomes@lxorguk.ukuu.org.uk \
--cc=gregkh@linux-foundation.org \
--cc=jikos@kernel.org \
--cc=keescook@google.com \
--cc=linux-kernel@vger.kernel.org \
--cc=luto@amacapital.net \
--cc=peterz@infradead.org \
--cc=pjt@google.com \
--cc=rga@amazon.de \
--cc=riel@redhat.com \
--cc=tglx@linutronix.de \
--cc=thomas.lendacky@amd.com \
--cc=tim.c.chen@linux.intel.com \
--cc=torvalds@linux-foundation.org \
--cc=x86@kernel.org \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
all inboxes | Powered by JetHome®