From mboxrd@z Thu Jan 1 00:00:00 1970 Received: (majordomo@vger.kernel.org) by vger.kernel.org via listexpand id S1751766AbeAOSBF (ORCPT + 1 other); Mon, 15 Jan 2018 13:01:05 -0500 Received: from merlin.infradead.org ([205.233.59.134]:41766 "EHLO merlin.infradead.org" rhost-flags-OK-OK-OK-OK) by vger.kernel.org with ESMTP id S1751733AbeAOSBD (ORCPT ); Mon, 15 Jan 2018 13:01:03 -0500 Date: Mon, 15 Jan 2018 19:00:55 +0100 From: Peter Zijlstra To: Josh Poimboeuf Cc: David Woodhouse , linux-kernel@vger.kernel.org, Dave Hansen , Ashok Raj , Thomas Gleixner , Tim Chen , Andy Lutomirski , Linus Torvalds , Greg KH , Andrea Arcangeli , Andi Kleen , Arjan Van De Ven , Dan Williams , Paolo Bonzini , Jun Nakajima , Asit Mallick , Borislav Petkov Subject: Re: [PATCH 1/4] objtool: Implement base jump_assert support Message-ID: <20180115180055.GB2269@hirez.programming.kicks-ass.net> References: <20180115164428.498966552@infradead.org> <20180115164909.774177737@infradead.org> <20180115173928.7ajrdwah24jwxmku@treble> MIME-Version: 1.0 Content-Type: text/plain; charset=us-ascii Content-Disposition: inline In-Reply-To: <20180115173928.7ajrdwah24jwxmku@treble> User-Agent: Mutt/1.9.2 (2017-12-15) Sender: linux-kernel-owner@vger.kernel.org List-ID: X-Mailing-List: linux-kernel@vger.kernel.org Return-Path: On Mon, Jan 15, 2018 at 11:39:28AM -0600, Josh Poimboeuf wrote: > Big props to you for braving the bowels of the objtool code. > > On Mon, Jan 15, 2018 at 05:44:29PM +0100, Peter Zijlstra wrote: > > +static int read_jump_assertions(struct objtool_file *file) > > This does more than just _read_ the assertions. Can you call it > something like assert_static_jumps() or do_static_jump_assertions() and > then call it from the main check() function? Sure. > > --- a/tools/objtool/check.h > > +++ b/tools/objtool/check.h > > @@ -45,6 +45,7 @@ struct instruction { > > unsigned char type; > > unsigned long immediate; > > bool alt_group, visited, dead_end, ignore, hint, save, restore, ignore_alts; > > + bool br_static; > > s/br_static/static_jump_dest/? fair enough. > Also, fellow objtool expert, you forgot the patch to the MAINTAINERS > file ;-) Well, uhm.. I'll think about it ;-)