From mboxrd@z Thu Jan 1 00:00:00 1970 Return-Path: Received: (majordomo@vger.kernel.org) by vger.kernel.org via listexpand id S1755827AbeASPHh (ORCPT ); Fri, 19 Jan 2018 10:07:37 -0500 Received: from mail.kernel.org ([198.145.29.99]:51800 "EHLO mail.kernel.org" rhost-flags-OK-OK-OK-OK) by vger.kernel.org with ESMTP id S1755641AbeASPHa (ORCPT ); Fri, 19 Jan 2018 10:07:30 -0500 DMARC-Filter: OpenDMARC Filter v1.3.2 mail.kernel.org 9B30121456 Authentication-Results: mail.kernel.org; dmarc=none (p=none dis=none) header.from=goodmis.org Authentication-Results: mail.kernel.org; spf=none smtp.mailfrom=rostedt@goodmis.org Date: Fri, 19 Jan 2018 10:07:28 -0500 From: Steven Rostedt To: Jiri Olsa Cc: Namhyung Kim , Jiri Olsa , Arnaldo Carvalho de Melo , lkml , David Ahern , Ingo Molnar , Peter Zijlstra Subject: Re: [RFC 0/4] tools lib traceevent: Install fixes Message-ID: <20180119100728.78ae773f@gandalf.local.home> In-Reply-To: <20180119103713.GB20115@krava> References: <1470073292-18114-1-git-send-email-jolsa@kernel.org> <20160802031055.GB25068@danjae.aot.lge.com> <20160802093134.GB2036@krava> <20160802094823.4a58b42f@gandalf.local.home> <20180119103713.GB20115@krava> X-Mailer: Claws Mail 3.14.0 (GTK+ 2.24.31; x86_64-pc-linux-gnu) MIME-Version: 1.0 Content-Type: text/plain; charset=US-ASCII Content-Transfer-Encoding: 7bit Sender: linux-kernel-owner@vger.kernel.org List-ID: X-Mailing-List: linux-kernel@vger.kernel.org On Fri, 19 Jan 2018 11:37:13 +0100 Jiri Olsa wrote: > hi, > I checked on this one and was surprised last email is from 2016 ;-) > so we did not move much with this.. is there still will to do that? > > I think we were kind of waiting for the namespace changes in > traceevent library.. like to have some common prefix for public > functions/struct, like 'traceevent_' ? > > thoughts? thanks, Yes, actually this is back on my radar. I now have full time staff working on trace-cmd and kernelshark. One of the up coming changes is to start pushing libtraceevent as a real library which means changing this. Thus, do we think "traceevent_" is the proper naming? Could we shorten it to "tevent_"? Need to get this bike-shedding exercise out of the way first ;-) -- Steve