From: Matthew Wilcox <willy@infradead.org>
To: Goffredo Baroncelli <kreijack@libero.it>
Cc: Jeff Layton <jlayton@kernel.org>,
linux-fsdevel <linux-fsdevel@vger.kernel.org>,
Linux Kernel Mailing List <linux-kernel@vger.kernel.org>,
Goffredo Baroncelli <kreijack@inwind.it>
Subject: Re: [PATCH] Rename make inode_cmp_iversion{+raw} to inode_eq_iversion{+raw}
Date: Wed, 31 Jan 2018 13:55:09 -0800 [thread overview]
Message-ID: <20180131215509.GD28275@bombadil.infradead.org> (raw)
In-Reply-To: <20180131204309.32474-1-kreijack@libero.it>
On Wed, Jan 31, 2018 at 09:43:09PM +0100, Goffredo Baroncelli wrote:
> The function inode_cmp_iversion{+raw} is counter-intuitive, because it
> returns true when the counters are different and false when these are equal.
>
> Rename it to inode_eq_iversion{+raw}, which will returns true when
> the counters are equal and false otherwise.
A lot of places use !inode_eq_iversion(). I think we should have both
inode_eq_iversion() and inode_ne_iversion().
Also, we have 'inode' in the name, why keep the 'i'? inode_eq_version()
and inode_ne_version() are shorter. We could even go so far as
iversion_eq() and iversion_ne() if keeping 'iversion' in the string
is important.
next prev parent reply other threads:[~2018-01-31 21:55 UTC|newest]
Thread overview: 4+ messages / expand[flat|nested] mbox.gz Atom feed top
2018-01-31 20:43 Goffredo Baroncelli
2018-01-31 21:55 ` Matthew Wilcox [this message]
2018-01-31 22:23 ` [PATCH] Rename " Goffredo Baroncelli
2018-02-01 11:59 ` [PATCH] Rename make " Jeff Layton
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=20180131215509.GD28275@bombadil.infradead.org \
--to=willy@infradead.org \
--cc=jlayton@kernel.org \
--cc=kreijack@inwind.it \
--cc=kreijack@libero.it \
--cc=linux-fsdevel@vger.kernel.org \
--cc=linux-kernel@vger.kernel.org \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
all inboxes | Powered by JetHome®