From: Andi Kleen <andi@firstfloor.org>
To: David Woodhouse <dwmw2@infradead.org>
Cc: Andi Kleen <andi@firstfloor.org>,
tglx@linutronix.de, x86@kernel.org, linux-kernel@vger.kernel.org,
bp@alien8.de, jpoimboe@redhat.com,
Andi Kleen <ak@linux.intel.com>
Subject: Re: [PATCH 2/2] x86/retpoline: Fix return buffer filling
Date: Tue, 13 Feb 2018 06:32:02 -0800 [thread overview]
Message-ID: <20180213143202.7logf7thlozro6op@two.firstfloor.org> (raw)
In-Reply-To: <1518530301.12890.66.camel@infradead.org>
> However... that was supposed to be a 'clear RSB' operation, with 32
> CALLs in sequence. And Boris changed it to 16 by calling __fill_rsb()
> instead of __clear_rsb():
True. That's even worse.
>
> - asm volatile (ANNOTATE_NOSPEC_ALTERNATIVE
> - ALTERNATIVE("jmp 910f",
> - __stringify(__FILL_RETURN_BUFFER(%0, RSB_CLEAR_LOOPS, %1)),
> - X86_FEATURE_RETPOLINE)
> - "910:"
> - : "=r" (loops), ASM_CALL_CONSTRAINT
> - : : "memory" );
> + alternative_input("",
> + "call __fill_rsb",
> + X86_FEATURE_RETPOLINE,
> + ASM_NO_INPUT_CLOBBER(_ASM_BX, "memory"));
>
> I think we do need to revert that patch. And perhaps stop accepting any
> more similar bikeshedding.
Yes revertion would be the right way.
I already regret the time I wasted trying to fix it.
-Andi
prev parent reply other threads:[~2018-02-13 14:32 UTC|newest]
Thread overview: 7+ messages / expand[flat|nested] mbox.gz Atom feed top
2018-02-13 0:04 [PATCH 1/2] objtool: Don't warn for intra function calls in alternative Andi Kleen
2018-02-13 0:04 ` [PATCH 2/2] x86/retpoline: Fix return buffer filling Andi Kleen
2018-02-13 1:06 ` Josh Poimboeuf
2018-02-13 11:21 ` Borislav Petkov
2018-02-13 13:18 ` Borislav Petkov
2018-02-13 13:58 ` David Woodhouse
2018-02-13 14:32 ` Andi Kleen [this message]
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=20180213143202.7logf7thlozro6op@two.firstfloor.org \
--to=andi@firstfloor.org \
--cc=ak@linux.intel.com \
--cc=bp@alien8.de \
--cc=dwmw2@infradead.org \
--cc=jpoimboe@redhat.com \
--cc=linux-kernel@vger.kernel.org \
--cc=tglx@linutronix.de \
--cc=x86@kernel.org \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
all inboxes | Powered by JetHome®