From: Ingo Molnar <mingo@kernel.org>
To: Josh Poimboeuf <jpoimboe@redhat.com>
Cc: Dominik Brodowski <linux@dominikbrodowski.net>,
linux-kernel@vger.kernel.org, x86@kernel.org, brgerst@gmail.com,
luto@kernel.org, torvalds@linux-foundation.org,
ak@linux.intel.com, tglx@linutronix.de, dan.j.williams@intel.com
Subject: Re: [RFC PATCH v2 5/5] x86/entry/64: open-code switch_to_thread_stack
Date: Tue, 20 Feb 2018 08:37:12 +0100 [thread overview]
Message-ID: <20180220073712.6kfoxc4pet4o2cgx@gmail.com> (raw)
In-Reply-To: <20180219143417.jsry72fehkbvz6gs@treble>
* Josh Poimboeuf <jpoimboe@redhat.com> wrote:
> > -.macro DO_SWITCH_TO_THREAD_STACK
> > +/* 8(%rsp): ~(interrupt number) */
> > +ENTRY(interrupt_helper)
>
> "interrupt_helper" is a bit vague, how about "interrupt_entry"? That
> better describes its purpose and also makes it more analagous to
> paranoid_entry() and error_entry().
Yeah, interrupt_entry() sounds better - and the renaming should be propagated to
the other patches as well.
Thanks,
Ingo
prev parent reply other threads:[~2018-02-20 7:37 UTC|newest]
Thread overview: 8+ messages / expand[flat|nested] mbox.gz Atom feed top
2018-02-18 12:31 [RFC PATCH v2 0/5] x86/entry/64: interrupt entry size reduction Dominik Brodowski
2018-02-18 12:31 ` [RFC PATCH v2 1/5] x86/entry/64: move PUSH_AND_CLEAR_REGS from interrupt macro to helper function Dominik Brodowski
2018-02-18 12:31 ` [RFC PATCH v2 2/5] x86/entry/64: move ENTER_IRQ_STACK " Dominik Brodowski
2018-02-18 12:31 ` [RFC PATCH v2 3/5] x86/entry/64: move switch_to_thread_stack to interrupt " Dominik Brodowski
2018-02-18 12:31 ` [RFC PATCH v2 4/5] x86/entry/64: remove interrupt macro Dominik Brodowski
2018-02-18 12:31 ` [RFC PATCH v2 5/5] x86/entry/64: open-code switch_to_thread_stack Dominik Brodowski
2018-02-19 14:34 ` Josh Poimboeuf
2018-02-20 7:37 ` Ingo Molnar [this message]
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=20180220073712.6kfoxc4pet4o2cgx@gmail.com \
--to=mingo@kernel.org \
--cc=ak@linux.intel.com \
--cc=brgerst@gmail.com \
--cc=dan.j.williams@intel.com \
--cc=jpoimboe@redhat.com \
--cc=linux-kernel@vger.kernel.org \
--cc=linux@dominikbrodowski.net \
--cc=luto@kernel.org \
--cc=tglx@linutronix.de \
--cc=torvalds@linux-foundation.org \
--cc=x86@kernel.org \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
all inboxes | Powered by JetHome®