mirror of https://lore.kernel.org/lkml/
 help / color / mirror / Atom feed
From: Borislav Petkov <bp@alien8.de>
To: "Maciej S. Szmigiero" <mail@maciej.szmigiero.name>
Cc: Thomas Gleixner <tglx@linutronix.de>,
	Ingo Molnar <mingo@redhat.com>, "H. Peter Anvin" <hpa@zytor.com>,
	x86@kernel.org, linux-kernel@vger.kernel.org
Subject: Re: [PATCH v3 6/9] x86/microcode/AMD: verify patch section type for every such section
Date: Thu, 15 Mar 2018 17:31:25 +0100	[thread overview]
Message-ID: <20180315163125.GG27816@pd.tnic> (raw)
In-Reply-To: <c22d8453-e72a-4708-7aa1-3c19256881b1@maciej.szmigiero.name>

On Tue, Mar 13, 2018 at 10:07:01PM +0100, Maciej S. Szmigiero wrote:
> We should check whether the patch section currently being processed is
> actually a patch section for each of them (not just the first one) in the
> late loader verify_and_add_patch() function, just like the early loader
> already does in parse_container() function.
> 
> Signed-off-by: Maciej S. Szmigiero <mail@maciej.szmigiero.name>
> ---
>  arch/x86/kernel/cpu/microcode/amd.c | 11 +++++------
>  1 file changed, 5 insertions(+), 6 deletions(-)
> 
> diff --git a/arch/x86/kernel/cpu/microcode/amd.c b/arch/x86/kernel/cpu/microcode/amd.c
> index 0f78200f2f6c..3ad23e72c2b0 100644
> --- a/arch/x86/kernel/cpu/microcode/amd.c
> +++ b/arch/x86/kernel/cpu/microcode/amd.c
> @@ -627,6 +627,11 @@ static int verify_and_add_patch(u8 family, u8 *fw, size_t leftover)
>  	if (leftover < SECTION_HDR_SIZE + sizeof(*mc_hdr))
>  		return leftover;
>  
> +	if (*(u32 *)fw != UCODE_UCODE_TYPE) {

Store that in a local var patch_type for better readability, while
you're touching that.

Also, for all your patch subject names for your next submission, start
the patch subject sentence with a capital letter:

Subject: [PATCH v3 6/9] x86/microcode/AMD: Verify patch section type for every such section

Thx.

-- 
Regards/Gruss,
    Boris.

Good mailing practices for 400: avoid top-posting and trim the reply.

  reply	other threads:[~2018-03-15 16:32 UTC|newest]

Thread overview: 23+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
     [not found] <cover.1520973389.git.mail@maciej.szmigiero.name>
2018-03-13 21:06 ` [PATCH v3 1/9] x86/microcode/AMD: subtract SECTION_HDR_SIZE from file leftover length Maciej S. Szmigiero
2018-03-14 12:38   ` Borislav Petkov
2018-03-13 21:06 ` [PATCH v3 2/9] x86/microcode/AMD: check whether the equivalence table fits in the file Maciej S. Szmigiero
2018-03-14 17:04   ` Borislav Petkov
2018-03-14 23:34     ` Maciej S. Szmigiero
2018-03-15 10:42       ` Borislav Petkov
2018-03-13 21:06 ` [PATCH v3 3/9] x86/microcode/AMD: install_equiv_cpu_table() should not return (signed) int Maciej S. Szmigiero
2018-03-14 17:58   ` Borislav Petkov
2018-03-14 23:46     ` Maciej S. Szmigiero
2018-03-14 23:58       ` Borislav Petkov
2018-03-15  0:13         ` Maciej S. Szmigiero
2018-03-15  0:56           ` Borislav Petkov
2018-03-15  0:59             ` Maciej S. Szmigiero
2018-03-13 21:06 ` [PATCH v3 4/9] x86/microcode/AMD: automatically compute the PATCH_MAX_SIZE macro Maciej S. Szmigiero
2018-03-14 18:02   ` Borislav Petkov
2018-03-15  0:05     ` Maciej S. Szmigiero
2018-03-15  1:00       ` Borislav Petkov
2018-03-13 21:06 ` [PATCH v3 5/9] x86/microcode/AMD: check patch size in verify_and_add_patch() Maciej S. Szmigiero
2018-03-13 21:07 ` [PATCH v3 6/9] x86/microcode/AMD: verify patch section type for every such section Maciej S. Szmigiero
2018-03-15 16:31   ` Borislav Petkov [this message]
2018-03-13 21:07 ` [PATCH v3 7/9] x86/microcode/AMD: check microcode container file size before accessing it Maciej S. Szmigiero
2018-03-13 21:07 ` [PATCH v3 8/9] x86/microcode/AMD: check the equivalence table size when scanning it Maciej S. Szmigiero
2018-03-13 21:07 ` [PATCH v3 9/9] x86/microcode/AMD: be more tolerant of late parse failures in late loader Maciej S. Szmigiero

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=20180315163125.GG27816@pd.tnic \
    --to=bp@alien8.de \
    --cc=hpa@zytor.com \
    --cc=linux-kernel@vger.kernel.org \
    --cc=mail@maciej.szmigiero.name \
    --cc=mingo@redhat.com \
    --cc=tglx@linutronix.de \
    --cc=x86@kernel.org \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox

Powered by JetHome