mirror of https://lore.kernel.org/lkml/
 help / color / mirror / Atom feed
From: "Luis R. Rodriguez" <mcgrof@kernel.org>
To: Andres Rodriguez <andresx7@gmail.com>
Cc: "Luis R. Rodriguez" <mcgrof@kernel.org>,
	linux-kernel@vger.kernel.org, gregkh@linuxfoundation.org,
	alexdeucher@gmail.com, christian.koenig@amd.com,
	kvalo@codeaurora.org, arend.vanspriel@broadcom.com,
	linux-wireless@vger.kernel.org, ath10k@lists.infradead.org,
	hdegoede@redhat.com, Kees Cook <keescook@chromium.org>,
	Mimi Zohar <zohar@linux.vnet.ibm.com>
Subject: Re: [PATCH 6/9] firmware: print firmware name on fallback path
Date: Tue, 8 May 2018 00:20:55 +0000	[thread overview]
Message-ID: <20180508002055.GY27853@wotan.suse.de> (raw)
In-Reply-To: <e79fe68b-7dc5-b65a-e483-287c91d67bc2@gmail.com>

On Fri, May 04, 2018 at 10:57:26PM -0400, Andres Rodriguez wrote:
> On 2018-05-03 07:42 PM, Luis R. Rodriguez wrote:
> > On Mon, Apr 23, 2018 at 04:12:02PM -0400, Andres Rodriguez wrote:
> > > Previously, one could assume the firmware name from the preceding
> > > message: "Direct firmware load for {name} failed with error %d".
> > > 
> > > However, with the new firmware_request_nowarn() entrypoint, the message
> > > outlined above will not always be printed.
> > 
> > I though the whole point was to not print an error message. What if
> > we want later to disable this error message? This would prove a bit
> > pointless.
> > 
> > Let's discuss the exact semantics desired here. Why would only the
> > fallback be desirable here?
> > 
> > Andres, Kalle?
> > 
> > After we address this I'll address resubmitting this lat patch
> > along with the last one. For now I'll skip it.
> 
> You are correct. I initially thought it would be useful to know that the
> usermode fallback was being triggered. And for that message to be useful we
> would need a fw name.
> 
> But now that you point it out, this behaviour is inconsistent with the
> _nowarn() definition. We shouldn't have a message in the first place.
> 
> So it might be better to instead have:
> 
> if (!(opt_flags & FW_OPT_NO_WARN) )
>     dev_warn(device, "Falling back to user helper\n");
> 
> No need to add the firmware name, cause we either:
>     a) FW_OPT_NO_WARN is set and no messages are printed, or
>     b) FW_OPT_NO_WARN is not set and we get both messages.
> 
> Yay, nay?

I welcome such a new warning but not for any of the reasons stated.

It make sense if FW_OPT_NO_WARN is not set and only because the fallback
mechanism can fail for a slew of different firmware files, and just getting
informed a failure with a fallback occurred does not tell us for which file it
failed for.

I'll add such a patch to my queue and send it off soon prior to your own
new API nowarn call.

  Luis

  reply	other threads:[~2018-05-08  0:20 UTC|newest]

Thread overview: 30+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2018-04-23 20:11 [PATCH 0/9] Loading optional firmware v4 Andres Rodriguez
2018-04-23 20:11 ` [PATCH 1/9] firmware: some documentation fixes Andres Rodriguez
2018-04-25 15:25   ` Greg KH
2018-04-25 15:26     ` Greg KH
2018-04-25 16:25       ` [PATCH 1/2] " Andres Rodriguez
2018-04-25 16:25         ` [PATCH 2/2] usb: typec: fix formatting errors that cause build breakage Andres Rodriguez
2018-04-25 16:35           ` Greg KH
2018-04-25 16:36         ` [PATCH 1/2] firmware: some documentation fixes Greg KH
2018-05-03 23:31   ` [PATCH 1/9] " Luis R. Rodriguez
2018-04-23 20:11 ` [PATCH 2/9] firmware: wrap FW_OPT_* into an enum Andres Rodriguez
2018-05-03 23:35   ` Luis R. Rodriguez
2018-04-23 20:11 ` [PATCH 3/9] firmware: add kernel-doc for enum fw_opt Andres Rodriguez
2018-05-03 23:36   ` Luis R. Rodriguez
2018-04-23 20:12 ` [PATCH 4/9] firmware: use () to terminate kernel-doc function names Andres Rodriguez
2018-05-03 23:37   ` Luis R. Rodriguez
2018-04-23 20:12 ` [PATCH 5/9] firmware: add function to load firmware without warnings v5 Andres Rodriguez
2018-05-03 23:40   ` Luis R. Rodriguez
2018-05-04  0:00   ` Luis R. Rodriguez
2018-04-23 20:12 ` [PATCH 6/9] firmware: print firmware name on fallback path Andres Rodriguez
2018-05-03 23:42   ` Luis R. Rodriguez
2018-05-05  2:57     ` Andres Rodriguez
2018-05-08  0:20       ` Luis R. Rodriguez [this message]
2018-05-12  8:03     ` Kalle Valo
2018-05-12  9:06       ` Luis R. Rodriguez
2018-04-23 20:12 ` [PATCH 7/9] firmware: use rename fw_sysfs_fallback to use the firmware_ prefix Andres Rodriguez
2018-05-03 23:44   ` Luis R. Rodriguez
2018-04-23 20:12 ` [PATCH 8/9] ath10k: use request_firmware_nowarn to load firmware Andres Rodriguez
2018-04-23 20:12 ` [PATCH 9/9] ath10k: re-enable the firmware fallback mechanism for testmode Andres Rodriguez
2018-04-24  5:29   ` Kalle Valo
  -- strict thread matches above, loose matches on Subject: below --
2018-04-17 15:32 [PATCH 0/9] Loading optional firmware v3 Andres Rodriguez
2018-04-17 15:33 ` [PATCH 6/9] firmware: print firmware name on fallback path Andres Rodriguez

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=20180508002055.GY27853@wotan.suse.de \
    --to=mcgrof@kernel.org \
    --cc=alexdeucher@gmail.com \
    --cc=andresx7@gmail.com \
    --cc=arend.vanspriel@broadcom.com \
    --cc=ath10k@lists.infradead.org \
    --cc=christian.koenig@amd.com \
    --cc=gregkh@linuxfoundation.org \
    --cc=hdegoede@redhat.com \
    --cc=keescook@chromium.org \
    --cc=kvalo@codeaurora.org \
    --cc=linux-kernel@vger.kernel.org \
    --cc=linux-wireless@vger.kernel.org \
    --cc=zohar@linux.vnet.ibm.com \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox

all inboxes | Powered by JetHome®