From: Greg Kroah-Hartman <gregkh@linuxfoundation.org>
To: James Simmons <jsimmons@infradead.org>
Cc: devel@driverdev.osuosl.org,
Andreas Dilger <andreas.dilger@intel.com>,
NeilBrown <neilb@suse.com>,
Linux Kernel Mailing List <linux-kernel@vger.kernel.org>,
Oleg Drokin <oleg.drokin@intel.com>,
Jinshan Xiong <jinshan.xiong@intel.com>,
Lai Siyao <lai.siyao@intel.com>,
Dan Carpenter <dan.carpenter@oracle.com>,
Lustre Development List <lustre-devel@lists.lustre.org>
Subject: Re: [PATCH 4/4] staging: lustre: obdclass: change object lookup to no wait mode
Date: Wed, 16 May 2018 18:57:19 +0200 [thread overview]
Message-ID: <20180516165719.GA28434@kroah.com> (raw)
In-Reply-To: <alpine.LFD.2.21.1805150207500.576@casper.infradead.org>
On Tue, May 15, 2018 at 04:02:55PM +0100, James Simmons wrote:
> > > /*
> > > * Allocate new object. This may result in rather complicated
> > > * operations, including fld queries, inode loading, etc.
> > > */
> > > o = lu_object_alloc(env, dev, f, conf);
> > > - if (IS_ERR(o))
> > > + if (unlikely(IS_ERR(o)))
> > > return o;
> > >
> >
> > This is an unrelated and totally pointless. likely/unlikely annotations
> > hurt readability, and they should only be added if it's something which
> > is going to show up in benchmarking. lu_object_alloc() is already too
> > slow for the unlikely() to make a difference and anyway IS_ERR() has an
> > unlikely built in so it's duplicative...
>
> Sounds like a good checkpatch case to test for :-) Some people like to try
> and milk ever cycle they can. Personally for me I never use those
> annotations. With modern processors I'm skeptical if their benefits.
> I do cleanup up the patches to some extent to make it compliant with
> kernel standards but leave the core code in place for people to comment
> on.
>
> > Anyway, I understand that Intel has been ignoring kernel.org instead of
> > sending forwarding their patches properly so you're doing a difficult
> > and thankless job... Thanks for that. I'm sure it's frustrating to
> > look at these patches for you as well.
>
> Thank you for the complement. Also thank you for taking time to review
> these patches. Your feedback is most welcomed and benefitical to the
> health of the lustre client.
>
> Sadly its not just Intel but other vendors that don't directly contribute
> to the linux lustre client. I have spoke to the vendors about contributing
> and they all say the same thing. No working with drivers in the staging
> tree. Sadly all the parties involved are very interested in the success
> of the lustre client. No one has ever told me directly why they don't get
> involved but I suspect it has to deal with 2 reasons. One is that staging
> drivers are not normally enabled by distributions so their clients
> normally will never deal with the staging lustre client. Secondly vendors
> just lack the man power to contribute in a meanful way.
If staging is hurting you, why is it in staging at all? Why not just
drop it, go off and spend a few months to clean up all the issues in
your own tree (with none of those pesky requirements of easy-to-review
patches) and then submit a "clean" filesystem for inclusion in the
"real" part of the kernel tree?
It doesn't sound like anyone is actually using this code in the tree
as-is, so why even keep it here?
thanks,
greg k-h
_______________________________________________
devel mailing list
devel@linuxdriverproject.org
http://driverdev.linuxdriverproject.org/mailman/listinfo/driverdev-devel
next prev parent reply other threads:[~2018-05-16 16:57 UTC|newest]
Thread overview: 21+ messages / expand[flat|nested] mbox.gz Atom feed top
2018-05-02 18:21 [PATCH 0/4] staging: lustre: obdclass: missing lu_object fixes James Simmons
2018-05-02 18:21 ` [PATCH 1/4] staging: lustre: obdclass: change spinlock of key to rwlock James Simmons
2018-05-03 13:50 ` David Laight
2018-05-03 23:26 ` NeilBrown
2018-05-04 0:11 ` Dilger, Andreas
2018-05-04 0:53 ` NeilBrown
2018-05-02 18:21 ` [PATCH 2/4] staging: lustre: obdclass: hoist locking in lu_context_exit() James Simmons
2018-05-02 18:21 ` [PATCH 3/4] staging: lustre: obdclass: guarantee all keys filled James Simmons
2018-05-02 18:21 ` [PATCH 4/4] staging: lustre: obdclass: change object lookup to no wait mode James Simmons
2018-05-04 1:15 ` NeilBrown
2018-05-15 0:37 ` James Simmons
2018-05-15 1:37 ` NeilBrown
2018-05-15 2:11 ` James Simmons
2018-05-07 1:47 ` Greg Kroah-Hartman
2018-05-08 11:45 ` Dan Carpenter
2018-05-15 15:02 ` James Simmons
2018-05-16 8:00 ` Dan Carpenter
2018-05-16 9:12 ` Dilger, Andreas
2018-05-16 15:44 ` Joe Perches
2018-05-16 16:57 ` Greg Kroah-Hartman [this message]
2018-05-17 5:07 ` James Simmons
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=20180516165719.GA28434@kroah.com \
--to=gregkh@linuxfoundation.org \
--cc=andreas.dilger@intel.com \
--cc=dan.carpenter@oracle.com \
--cc=devel@driverdev.osuosl.org \
--cc=jinshan.xiong@intel.com \
--cc=jsimmons@infradead.org \
--cc=lai.siyao@intel.com \
--cc=linux-kernel@vger.kernel.org \
--cc=lustre-devel@lists.lustre.org \
--cc=neilb@suse.com \
--cc=oleg.drokin@intel.com \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
Powered by JetHome