From: Marek Vasut <marek.vasut@gmail.com>
To: linux-kernel@vger.kernel.org
Cc: Marek Vasut <marek.vasut+renesas@gmail.com>,
Geert Uytterhoeven <geert+renesas@glider.be>,
Lee Jones <lee.jones@linaro.org>, Mark Brown <broonie@kernel.org>,
Steve Twiss <stwiss.opensource@diasemi.com>,
Wolfram Sang <wsa+renesas@sang-engineering.com>,
linux-renesas-soc@vger.kernel.org
Subject: [PATCH v4 10/12] mfd: da9063: Register RTC only on DA9063L
Date: Wed, 6 Jun 2018 01:10:11 +0200 [thread overview]
Message-ID: <20180605231013.1803-10-marek.vasut+renesas@gmail.com> (raw)
In-Reply-To: <20180605231013.1803-1-marek.vasut+renesas@gmail.com>
The DA9063L does not contain RTC block, unlike the full DA9063.
Split the RTC block into separate mfd cell and register it only
on DA9063.
Signed-off-by: Marek Vasut <marek.vasut+renesas@gmail.com>
Cc: Geert Uytterhoeven <geert+renesas@glider.be>
Cc: Lee Jones <lee.jones@linaro.org>
Cc: Mark Brown <broonie@kernel.org>
Cc: Steve Twiss <stwiss.opensource@diasemi.com>
Cc: Wolfram Sang <wsa+renesas@sang-engineering.com>
Cc: linux-renesas-soc@vger.kernel.org
---
V2: No change
V3: Rework of mfd: da9063: Disallow RTC on DA9063L
V4: - Change the original failure text
- Use PLATFORM_DEVID_NONE in mfd_add_devices
---
drivers/mfd/da9063-core.c | 33 +++++++++++++++++++++++++--------
1 file changed, 25 insertions(+), 8 deletions(-)
diff --git a/drivers/mfd/da9063-core.c b/drivers/mfd/da9063-core.c
index 9aff815877c0..3443c9321c09 100644
--- a/drivers/mfd/da9063-core.c
+++ b/drivers/mfd/da9063-core.c
@@ -76,7 +76,7 @@ static struct resource da9063_hwmon_resources[] = {
};
-static const struct mfd_cell da9063_devs[] = {
+static const struct mfd_cell da9063_common_devs[] = {
{
.name = DA9063_DRVNAME_REGULATORS,
.num_resources = ARRAY_SIZE(da9063_regulators_resources),
@@ -100,15 +100,19 @@ static const struct mfd_cell da9063_devs[] = {
.resources = da9063_onkey_resources,
.of_compatible = "dlg,da9063-onkey",
},
+ {
+ .name = DA9063_DRVNAME_VIBRATION,
+ },
+};
+
+/* Only present on DA9063 , not on DA9063L */
+static const struct mfd_cell da9063_devs[] = {
{
.name = DA9063_DRVNAME_RTC,
.num_resources = ARRAY_SIZE(da9063_rtc_resources),
.resources = da9063_rtc_resources,
.of_compatible = "dlg,da9063-rtc",
},
- {
- .name = DA9063_DRVNAME_VIBRATION,
- },
};
static int da9063_clear_fault_log(struct da9063 *da9063)
@@ -225,16 +229,29 @@ int da9063_device_init(struct da9063 *da9063, unsigned int irq)
da9063->irq_base = regmap_irq_chip_get_base(da9063->regmap_irq);
- ret = mfd_add_devices(da9063->dev, PLATFORM_DEVID_NONE, da9063_devs,
- ARRAY_SIZE(da9063_devs), NULL, da9063->irq_base,
- NULL);
+ ret = mfd_add_devices(da9063->dev, PLATFORM_DEVID_NONE,
+ da9063_common_devs,
+ ARRAY_SIZE(da9063_common_devs),
+ NULL, da9063->irq_base, NULL);
if (ret) {
- dev_err(da9063->dev, "Cannot add MFD cells\n");
+ dev_err(da9063->dev, "Failed to add child devices\n");
goto err_irq_exit;
}
+ if (da9063->type == PMIC_TYPE_DA9063) {
+ ret = mfd_add_devices(da9063->dev, PLATFORM_DEVID_NONE,
+ da9063_devs, ARRAY_SIZE(da9063_devs),
+ NULL, da9063->irq_base, NULL);
+ if (ret) {
+ dev_err(da9063->dev, "Failed to add child devices\n");
+ goto err_mfd_cleanup;
+ }
+ }
+
return ret;
+err_mfd_cleanup:
+ mfd_remove_devices(da9063->dev);
err_irq_exit:
da9063_irq_exit(da9063);
return ret;
--
2.16.2
next prev parent reply other threads:[~2018-06-05 23:11 UTC|newest]
Thread overview: 23+ messages / expand[flat|nested] mbox.gz Atom feed top
2018-06-05 23:10 [PATCH v4 01/12] mfd: da9063: Fix failpath in core Marek Vasut
2018-06-05 23:10 ` [PATCH v4 02/12] mfd: da9063: Use REGMAP_IRQ_REG Marek Vasut
2018-06-05 23:10 ` [PATCH v4 03/12] mfd: da9063: Use PLATFORM_DEVID_NONE Marek Vasut
2018-06-06 6:25 ` Geert Uytterhoeven
2018-06-06 6:34 ` Lee Jones
2018-06-05 23:10 ` [PATCH v4 04/12] mfd: da9063: Replace DA9063_NUM_IRQ with ARRAY_SIZE Marek Vasut
2018-06-06 6:28 ` Geert Uytterhoeven
2018-06-06 6:36 ` Lee Jones
2018-06-05 23:10 ` [PATCH v4 05/12] mfd: da9063: Rename PMIC_DA9063 to PMIC_CHIP_ID_DA9063 Marek Vasut
2018-06-05 23:10 ` [PATCH v4 06/12] mfd: da9063: Replace model with type Marek Vasut
2018-06-06 14:04 ` kbuild test robot
2018-06-05 23:10 ` [PATCH v4 07/12] mfd: da9063: Add DA9063L type Marek Vasut
2018-06-05 23:10 ` [PATCH v4 08/12] mfd: da9063: Add custom regmap for DA9063L Marek Vasut
2018-06-06 6:39 ` Lee Jones
2018-06-06 9:47 ` Marek Vasut
2018-06-05 23:10 ` [PATCH v4 09/12] mfd: da9063: Add custom IRQ map " Marek Vasut
2018-06-06 6:40 ` Lee Jones
2018-06-05 23:10 ` Marek Vasut [this message]
2018-06-06 6:41 ` [PATCH v4 10/12] mfd: da9063: Register RTC only on DA9063L Lee Jones
2018-06-05 23:10 ` [PATCH v4 11/12] regulator: da9063: Handle less LDOs " Marek Vasut
2018-06-05 23:10 ` [PATCH v4 12/12] mfd: da9063: Add DA9063L support Marek Vasut
2018-06-06 6:24 ` [PATCH v4 01/12] mfd: da9063: Fix failpath in core Geert Uytterhoeven
2018-06-06 6:35 ` Lee Jones
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=20180605231013.1803-10-marek.vasut+renesas@gmail.com \
--to=marek.vasut@gmail.com \
--cc=broonie@kernel.org \
--cc=geert+renesas@glider.be \
--cc=lee.jones@linaro.org \
--cc=linux-kernel@vger.kernel.org \
--cc=linux-renesas-soc@vger.kernel.org \
--cc=marek.vasut+renesas@gmail.com \
--cc=stwiss.opensource@diasemi.com \
--cc=wsa+renesas@sang-engineering.com \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
all inboxes | Powered by JetHome®