From: Marek Vasut <marek.vasut@gmail.com>
To: linux-kernel@vger.kernel.org
Cc: Marek Vasut <marek.vasut+renesas@gmail.com>,
Geert Uytterhoeven <geert+renesas@glider.be>,
Lee Jones <lee.jones@linaro.org>, Mark Brown <broonie@kernel.org>,
Steve Twiss <stwiss.opensource@diasemi.com>,
Wolfram Sang <wsa+renesas@sang-engineering.com>,
linux-renesas-soc@vger.kernel.org
Subject: [PATCH v6 01/14] mfd: da9063: Replace regmap_add_irq_chip with devm counterpart
Date: Mon, 11 Jun 2018 13:58:38 +0200 [thread overview]
Message-ID: <20180611115851.1987-1-marek.vasut+renesas@gmail.com> (raw)
Use devm_regmap_add_irq_chip() instead of plain regmap_add_irq_chip(),
which removes the need for da9063_irq_exit() altogether and also
fixes a bug in da9063_device_init() where the da9063_irq_exit() was
not called in a failpath.
Signed-off-by: Marek Vasut <marek.vasut+renesas@gmail.com>
Cc: Geert Uytterhoeven <geert+renesas@glider.be>
Cc: Lee Jones <lee.jones@linaro.org>
Cc: Mark Brown <broonie@kernel.org>
Cc: Steve Twiss <stwiss.opensource@diasemi.com>
Cc: Wolfram Sang <wsa+renesas@sang-engineering.com>
Cc: linux-renesas-soc@vger.kernel.org
Acked-for-MFD-by: Lee Jones <lee.jones@linaro.org>
---
V5: New patch
V6: No change
---
drivers/mfd/da9063-core.c | 1 -
drivers/mfd/da9063-irq.c | 8 ++------
include/linux/mfd/da9063/core.h | 1 -
3 files changed, 2 insertions(+), 8 deletions(-)
diff --git a/drivers/mfd/da9063-core.c b/drivers/mfd/da9063-core.c
index 6c2870d4e754..2647bb371d86 100644
--- a/drivers/mfd/da9063-core.c
+++ b/drivers/mfd/da9063-core.c
@@ -238,7 +238,6 @@ int da9063_device_init(struct da9063 *da9063, unsigned int irq)
void da9063_device_exit(struct da9063 *da9063)
{
mfd_remove_devices(da9063->dev);
- da9063_irq_exit(da9063);
}
MODULE_DESCRIPTION("PMIC driver for Dialog DA9063");
diff --git a/drivers/mfd/da9063-irq.c b/drivers/mfd/da9063-irq.c
index 207bbfe55449..da6ceb41f0d1 100644
--- a/drivers/mfd/da9063-irq.c
+++ b/drivers/mfd/da9063-irq.c
@@ -170,7 +170,8 @@ int da9063_irq_init(struct da9063 *da9063)
return -EINVAL;
}
- ret = regmap_add_irq_chip(da9063->regmap, da9063->chip_irq,
+ ret = devm_regmap_add_irq_chip(da9063->dev, da9063->regmap,
+ da9063->chip_irq,
IRQF_TRIGGER_LOW | IRQF_ONESHOT | IRQF_SHARED,
da9063->irq_base, &da9063_irq_chip,
&da9063->regmap_irq);
@@ -182,8 +183,3 @@ int da9063_irq_init(struct da9063 *da9063)
return 0;
}
-
-void da9063_irq_exit(struct da9063 *da9063)
-{
- regmap_del_irq_chip(da9063->chip_irq, da9063->regmap_irq);
-}
diff --git a/include/linux/mfd/da9063/core.h b/include/linux/mfd/da9063/core.h
index f3ae65db4c86..9ab7049977aa 100644
--- a/include/linux/mfd/da9063/core.h
+++ b/include/linux/mfd/da9063/core.h
@@ -95,6 +95,5 @@ int da9063_device_init(struct da9063 *da9063, unsigned int irq);
int da9063_irq_init(struct da9063 *da9063);
void da9063_device_exit(struct da9063 *da9063);
-void da9063_irq_exit(struct da9063 *da9063);
#endif /* __MFD_DA9063_CORE_H__ */
--
2.16.2
next reply other threads:[~2018-06-11 12:01 UTC|newest]
Thread overview: 15+ messages / expand[flat|nested] mbox.gz Atom feed top
2018-06-11 11:58 Marek Vasut [this message]
2018-06-11 11:58 ` [PATCH v6 02/14] mfd: da9063: Replace mfd_add_devices " Marek Vasut
2018-06-11 11:58 ` [PATCH v6 03/14] mfd: da9063: Use regmap_reg_range Marek Vasut
2018-06-11 11:58 ` [PATCH v6 04/14] mfd: da9063: Use REGMAP_IRQ_REG Marek Vasut
2018-06-11 11:58 ` [PATCH v6 05/14] mfd: da9063: Use PLATFORM_DEVID_NONE Marek Vasut
2018-06-11 11:58 ` [PATCH v6 06/14] mfd: da9063: Replace DA9063_NUM_IRQ with ARRAY_SIZE Marek Vasut
2018-06-11 11:58 ` [PATCH v6 07/14] mfd: da9063: Rename PMIC_DA9063 to PMIC_CHIP_ID_DA9063 Marek Vasut
2018-06-11 11:58 ` [PATCH v6 08/14] mfd: da9063: Replace model with type Marek Vasut
2018-06-11 11:58 ` [PATCH v6 09/14] mfd: da9063: Add DA9063L type Marek Vasut
2018-06-11 11:58 ` [PATCH v6 10/14] mfd: da9063: Add custom regmap for DA9063L Marek Vasut
2018-06-11 11:58 ` [PATCH v6 11/14] mfd: da9063: Add custom IRQ map " Marek Vasut
2018-06-11 11:58 ` [PATCH v6 12/14] mfd: da9063: Register RTC only on DA9063L Marek Vasut
2018-06-11 11:58 ` [PATCH v6 13/14] regulator: da9063: Handle less LDOs " Marek Vasut
2018-06-11 11:58 ` [PATCH v6 14/14] mfd: da9063: Add DA9063L support Marek Vasut
2018-07-04 6:19 ` [GIT PULL] Immutable branch between MFD and Regulator due for the v4.19 merge window Lee Jones
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=20180611115851.1987-1-marek.vasut+renesas@gmail.com \
--to=marek.vasut@gmail.com \
--cc=broonie@kernel.org \
--cc=geert+renesas@glider.be \
--cc=lee.jones@linaro.org \
--cc=linux-kernel@vger.kernel.org \
--cc=linux-renesas-soc@vger.kernel.org \
--cc=marek.vasut+renesas@gmail.com \
--cc=stwiss.opensource@diasemi.com \
--cc=wsa+renesas@sang-engineering.com \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
all inboxes | Powered by JetHome®