From: "Darrick J. Wong" <darrick.wong@oracle.com>
To: "Gustavo A. R. Silva" <gustavo@embeddedor.com>
Cc: linux-xfs@vger.kernel.org, linux-kernel@vger.kernel.org
Subject: Re: [PATCH] xfs_bmap_util: use swap macro
Date: Mon, 9 Jul 2018 09:39:39 -0700 [thread overview]
Message-ID: <20180709163939.GX32415@magnolia> (raw)
In-Reply-To: <20180709140539.GA17517@embeddedor.com>
On Mon, Jul 09, 2018 at 09:05:39AM -0500, Gustavo A. R. Silva wrote:
> Make use of the swap macro and remove some unnecessary variables.
> This makes the code easier to read and maintain. Also, reduces the
> stack usage.
>
> This code was detected with the help of Coccinelle.
>
> Signed-off-by: Gustavo A. R. Silva <gustavo@embeddedor.com>
> ---
> fs/xfs/xfs_bmap_util.c | 13 ++-----------
> 1 file changed, 2 insertions(+), 11 deletions(-)
>
> diff --git a/fs/xfs/xfs_bmap_util.c b/fs/xfs/xfs_bmap_util.c
> index 83b1e8c..4b0b16f 100644
> --- a/fs/xfs/xfs_bmap_util.c
> +++ b/fs/xfs/xfs_bmap_util.c
> @@ -1691,7 +1691,6 @@ xfs_swap_extent_forks(
> int *src_log_flags,
> int *target_log_flags)
> {
> - struct xfs_ifork tempifp, *ifp, *tifp;
> xfs_filblks_t aforkblks = 0;
> xfs_filblks_t taforkblks = 0;
> xfs_extnum_t junk;
> @@ -1733,11 +1732,7 @@ xfs_swap_extent_forks(
> /*
> * Swap the data forks of the inodes
> */
> - ifp = &ip->i_df;
> - tifp = &tip->i_df;
> - tempifp = *ifp; /* struct copy */
> - *ifp = *tifp; /* struct copy */
> - *tifp = tempifp; /* struct copy */
> + swap(ip->i_df, tip->i_df);
>
> /*
> * Fix the on-disk inode values
Why not use swap() on the di_nextents and di_format exchange below here
too?
> @@ -1987,14 +1982,10 @@ xfs_swap_extents(
>
> /* Swap the cow forks. */
> if (xfs_sb_version_hasreflink(&mp->m_sb)) {
> - xfs_extnum_t extnum;
> -
> ASSERT(ip->i_cformat == XFS_DINODE_FMT_EXTENTS);
> ASSERT(tip->i_cformat == XFS_DINODE_FMT_EXTENTS);
>
> - extnum = ip->i_cnextents;
> - ip->i_cnextents = tip->i_cnextents;
> - tip->i_cnextents = extnum;
> + swap(ip->i_cnextents, tip->i_cnextents);
>
> cowfp = ip->i_cowfp;
> ip->i_cowfp = tip->i_cowfp;
Same here -- why not use swap on {ip,tip}->i_cowfp?
--D
> --
> 2.7.4
>
> --
> To unsubscribe from this list: send the line "unsubscribe linux-xfs" in
> the body of a message to majordomo@vger.kernel.org
> More majordomo info at http://vger.kernel.org/majordomo-info.html
next prev parent reply other threads:[~2018-07-09 16:40 UTC|newest]
Thread overview: 3+ messages / expand[flat|nested] mbox.gz Atom feed top
2018-07-09 14:05 Gustavo A. R. Silva
2018-07-09 16:39 ` Darrick J. Wong [this message]
2018-07-09 16:42 ` Gustavo A. R. Silva
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=20180709163939.GX32415@magnolia \
--to=darrick.wong@oracle.com \
--cc=gustavo@embeddedor.com \
--cc=linux-kernel@vger.kernel.org \
--cc=linux-xfs@vger.kernel.org \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
all inboxes | Powered by JetHome®