From: Al Viro <viro@ZenIV.linux.org.uk>
To: Linus Torvalds <torvalds@linux-foundation.org>
Cc: linux-fsdevel@vger.kernel.org, linux-kernel@vger.kernel.org,
Miklos Szeredi <mszeredi@redhat.com>
Subject: [RFC][PATCH 25/42] document ->atomic_open() changes
Date: Wed, 11 Jul 2018 03:21:49 +0100 [thread overview]
Message-ID: <20180711022206.12571-25-viro@ZenIV.linux.org.uk> (raw)
In-Reply-To: <20180711022206.12571-1-viro@ZenIV.linux.org.uk>
From: Al Viro <viro@zeniv.linux.org.uk>
Signed-off-by: Al Viro <viro@zeniv.linux.org.uk>
---
Documentation/filesystems/Locking | 2 +-
Documentation/filesystems/porting | 8 ++++++++
Documentation/filesystems/vfs.txt | 18 ++++++++++--------
3 files changed, 19 insertions(+), 9 deletions(-)
diff --git a/Documentation/filesystems/Locking b/Documentation/filesystems/Locking
index 2c391338c675..04c867981375 100644
--- a/Documentation/filesystems/Locking
+++ b/Documentation/filesystems/Locking
@@ -64,7 +64,7 @@ prototypes:
void (*update_time)(struct inode *, struct timespec *, int);
int (*atomic_open)(struct inode *, struct dentry *,
struct file *, unsigned open_flag,
- umode_t create_mode, int *opened);
+ umode_t create_mode);
int (*tmpfile) (struct inode *, struct dentry *, umode_t);
locking rules:
diff --git a/Documentation/filesystems/porting b/Documentation/filesystems/porting
index 17bb4dc28fae..c68ea9294b5f 100644
--- a/Documentation/filesystems/porting
+++ b/Documentation/filesystems/porting
@@ -602,3 +602,11 @@ in your dentry operations instead.
dentry separately, and it now has request_mask and query_flags arguments
to specify the fields and sync type requested by statx. Filesystems not
supporting any statx-specific features may ignore the new arguments.
+--
+[mandatory]
+ ->atomic_open() calling conventions have changed. Gone is int *opened,
+ along with FILE_OPENED/FILE_CREATED. In place of those we have
+ FMODE_OPENED/FMODE_CREATED, set in file->f_mode. Additionally, return
+ value for 'called finish_no_open(), open it yourself' case has become
+ 0, not 1. Since finish_no_open() itself is returning 0 now, that part
+ does not need any changes in ->atomic_open() instances.
diff --git a/Documentation/filesystems/vfs.txt b/Documentation/filesystems/vfs.txt
index 829a7b7857a4..d564cc44397e 100644
--- a/Documentation/filesystems/vfs.txt
+++ b/Documentation/filesystems/vfs.txt
@@ -386,7 +386,7 @@ struct inode_operations {
ssize_t (*listxattr) (struct dentry *, char *, size_t);
void (*update_time)(struct inode *, struct timespec *, int);
int (*atomic_open)(struct inode *, struct dentry *, struct file *,
- unsigned open_flag, umode_t create_mode, int *opened);
+ unsigned open_flag, umode_t create_mode);
int (*tmpfile) (struct inode *, struct dentry *, umode_t);
};
@@ -496,13 +496,15 @@ otherwise noted.
atomic_open: called on the last component of an open. Using this optional
method the filesystem can look up, possibly create and open the file in
- one atomic operation. If it cannot perform this (e.g. the file type
- turned out to be wrong) it may signal this by returning 1 instead of
- usual 0 or -ve . This method is only called if the last component is
- negative or needs lookup. Cached positive dentries are still handled by
- f_op->open(). If the file was created, the FILE_CREATED flag should be
- set in "opened". In case of O_EXCL the method must only succeed if the
- file didn't exist and hence FILE_CREATED shall always be set on success.
+ one atomic operation. If it wants to leave actual opening to the
+ caller (e.g. if the file turned out to be a symlink, device, or just
+ something filesystem won't do atomic open for), it may signal this by
+ returning finish_no_open(file, dentry). This method is only called if
+ the last component is negative or needs lookup. Cached positive dentries
+ are still handled by f_op->open(). If the file was created,
+ FMODE_CREATED flag should be set in file->f_mode. In case of O_EXCL
+ the method must only succeed if the file didn't exist and hence FMODE_CREATED
+ shall always be set on success.
tmpfile: called in the end of O_TMPFILE open(). Optional, equivalent to
atomically creating, opening and unlinking a file in given directory.
--
2.11.0
next prev parent reply other threads:[~2018-07-11 2:24 UTC|newest]
Thread overview: 79+ messages / expand[flat|nested] mbox.gz Atom feed top
2018-07-10 0:17 linux-next: manual merge of the vfs tree with the overlayfs tree Stephen Rothwell
2018-07-10 15:04 ` Al Viro
2018-07-11 2:11 ` Al Viro
2018-07-11 2:21 ` [RFC][PATCH 01/42] drm_mode_create_lease_ioctl(): fix open-coded filp_clone_open() Al Viro
2018-07-11 2:21 ` [RFC][PATCH 02/42] cxl_getfile(): fix double-iput() on alloc_file() failures Al Viro
2018-07-11 2:21 ` [RFC][PATCH 03/42] ocxlflash_getfile(): " Al Viro
2018-07-11 2:21 ` [RFC][PATCH 04/42] make get_empty_filp() to call file_free_rcu() directly Al Viro
2018-07-11 2:35 ` Linus Torvalds
2018-07-11 2:43 ` Al Viro
2018-07-11 2:21 ` [RFC][PATCH 05/42] fold security_file_free() into file_free() Al Viro
2018-07-11 2:21 ` [RFC][PATCH 06/42] turn filp_clone_open() into inline wrapper for dentry_open() Al Viro
2018-07-11 2:21 ` [RFC][PATCH 07/42] create_pipe_files(): use fput() if allocation of the second file fails Al Viro
2018-07-11 2:21 ` [RFC][PATCH 08/42] make sure do_dentry_open() won't return positive as an error Al Viro
2018-07-11 2:39 ` Linus Torvalds
2018-07-11 2:41 ` Al Viro
2018-07-11 2:21 ` [RFC][PATCH 09/42] pass creds to get_empty_filp(), make sure dentry_open() passes the right creds Al Viro
2018-07-11 2:21 ` [RFC][PATCH 10/42] get rid of cred argument of vfs_open() and do_dentry_open() Al Viro
2018-07-11 2:21 ` [RFC][PATCH 11/42] security_file_open(): lose cred argument Al Viro
2018-07-11 2:21 ` [RFC][PATCH 12/42] ->file_open(): " Al Viro
2018-07-11 2:21 ` [RFC][PATCH 13/42] introduce FMODE_OPENED Al Viro
2018-07-11 2:21 ` [RFC][PATCH 14/42] fold put_filp() into fput() Al Viro
2018-07-11 2:21 ` [RFC][PATCH 15/42] lift fput() on late failures into path_openat() Al Viro
2018-07-11 5:43 ` Amir Goldstein
2018-07-11 2:21 ` [RFC][PATCH 16/42] now we can fold open_check_o_direct() into do_dentry_open() Al Viro
2018-07-11 2:44 ` Linus Torvalds
2018-07-11 2:59 ` Al Viro
2018-07-11 3:13 ` Linus Torvalds
2018-07-11 2:21 ` [RFC][PATCH 17/42] switch all remaining checks for FILE_OPENED to FMODE_OPENED Al Viro
2018-07-11 2:21 ` [RFC][PATCH 18/42] introduce FMODE_CREATED and switch to it Al Viro
2018-07-11 2:21 ` [RFC][PATCH 19/42] IMA: don't propagate opened through the entire thing Al Viro
2018-07-11 2:21 ` [RFC][PATCH 20/42] getting rid of 'opened' argument of ->atomic_open() - step 1 Al Viro
2018-07-11 2:21 ` [RFC][PATCH 21/42] getting rid of 'opened' argument of ->atomic_open() - part 2 Al Viro
2018-07-11 2:21 ` [RFC][PATCH 22/42] get rid of 'opened' argument of ->atomic_open() - part 3 Al Viro
2018-07-11 2:21 ` [RFC][PATCH 23/42] get rid of 'opened' in path_openat() and the helpers downstream Al Viro
2018-07-11 2:21 ` [RFC][PATCH 24/42] ->atomic_open(): return 0 in all success cases Al Viro
2018-07-11 2:21 ` Al Viro [this message]
2018-07-11 2:21 ` [RFC][PATCH 26/42] switch atomic_open() and lookup_open() to returning " Al Viro
2018-07-11 2:21 ` [RFC][PATCH 27/42] kill FILE_{CREATED,OPENED} Al Viro
2018-07-11 2:21 ` [RFC][PATCH 28/42] new wrapper: alloc_file_pseudo() Al Viro
2018-07-11 2:21 ` [RFC][PATCH 29/42] __shmem_file_setup(): reorder allocations Al Viro
2018-07-11 2:21 ` [RFC][PATCH 30/42] ... and switch shmem_file_setup() to alloc_file_pseudo() Al Viro
2018-07-11 2:21 ` [RFC][PATCH 31/42] cxl_getfile(): switch " Al Viro
2018-07-11 2:21 ` [RFC][PATCH 32/42] ocxlflash_getfile(): " Al Viro
2018-07-11 2:21 ` [RFC][PATCH 33/42] hugetlb_file_setup(): " Al Viro
2018-07-11 2:21 ` [RFC][PATCH 34/42] anon_inode_getfile(): " Al Viro
2018-07-11 2:21 ` [RFC][PATCH 35/42] create_pipe_files(): switch the first allocation " Al Viro
2018-07-11 2:22 ` [RFC][PATCH 36/42] new helper: alloc_file_clone() Al Viro
2018-07-11 2:22 ` [RFC][PATCH 37/42] do_shmat(): grab shp->shm_file earlier, switch to alloc_file_clone() Al Viro
2018-07-11 2:22 ` [RFC][PATCH 38/42] make alloc_file() static Al Viro
2018-07-11 2:22 ` [RFC][PATCH 39/42] document alloc_file() changes Al Viro
2018-07-11 2:22 ` [RFC][PATCH 40/42] make path_init() unconditionally paired with terminate_walk() Al Viro
2018-07-11 2:22 ` [RFC][PATCH 41/42] allow link_path_walk() to take ERR_PTR() Al Viro
2018-07-11 2:22 ` [RFC][PATCH 42/42] few more cleanups of link_path_walk() callers Al Viro
2018-07-11 2:56 ` [RFC][PATCH 01/42] drm_mode_create_lease_ioctl(): fix open-coded filp_clone_open() Linus Torvalds
2018-07-11 15:25 ` Al Viro
2018-07-11 16:15 ` Al Viro
2018-07-12 12:43 ` Al Viro
2018-07-12 15:05 ` Linus Torvalds
2018-07-12 15:53 ` vfs / overlayfs conflict resolution for linux-next Al Viro
2018-07-18 2:56 ` Al Viro
2018-07-18 3:29 ` Stephen Rothwell
2018-07-18 7:25 ` Miklos Szeredi
2018-07-18 12:10 ` Miklos Szeredi
2018-07-18 12:43 ` Al Viro
2018-07-18 13:46 ` Al Viro
2018-07-18 15:46 ` Miklos Szeredi
2018-07-18 18:12 ` [RFC] call_with_creds() Al Viro
2018-07-18 18:19 ` Linus Torvalds
2018-07-18 19:46 ` Al Viro
2018-07-18 19:53 ` Linus Torvalds
2018-07-18 20:04 ` Al Viro
2018-07-18 20:15 ` Al Viro
2018-07-18 20:43 ` Linus Torvalds
2018-07-18 21:22 ` Al Viro
2018-07-18 23:06 ` Linus Torvalds
2018-07-18 21:27 ` David Howells
2018-07-18 23:16 ` Linus Torvalds
2018-07-18 21:28 ` David Howells
2018-07-18 23:13 ` Linus Torvalds
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=20180711022206.12571-25-viro@ZenIV.linux.org.uk \
--to=viro@zeniv.linux.org.uk \
--cc=linux-fsdevel@vger.kernel.org \
--cc=linux-kernel@vger.kernel.org \
--cc=mszeredi@redhat.com \
--cc=torvalds@linux-foundation.org \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
Powered by JetHome