From: Alexei Colin <acolin@isi.edu>
To: Russell King - ARM Linux <linux@armlinux.org.uk>
Cc: Alex Bounine <alex.bou9@gmail.com>,
Catalin Marinas <catalin.marinas@arm.com>,
Will Deacon <will.deacon@arm.com>,
linux-kernel@vger.kernel.org,
John Paul Walters <jwalters@isi.edu>,
Andrew Morton <akpm@linux-foundation.org>,
linux-arm-kernel@lists.infradead.org
Subject: Re: [PATCH 6/6] arm64: enable RapidIO menu in Kconfig
Date: Wed, 1 Aug 2018 09:54:41 -0400 [thread overview]
Message-ID: <20180801135441.GD38497@guest228.east.isi.edu> (raw)
In-Reply-To: <20180801103855.GD30658@n2100.armlinux.org.uk>
> > Why we cannot use "select HAS_RAPIDIO" HW-specific Kconfig file
> > (mach-*/Kconfig)? And have on-chip port selection in the same board-specific
> > place.
>
> As I've already explained, HAS_RAPIDIO has the expectation that it
> controls the availability of the RAPIDIO option, not of drivers.
> It is HAS_*RAPIDIO*, the clue is in the name. Using it as you are
> (basically, to mean that on-SoC rapidio hardware is present) and
> allowing such configurations as HAS_RAPIDIO=n RAPIDIO=y PCI=y is
> completely counter-intuitive.
The intention in the patch was for HAS_RAPIDIO to mean exactly "on-SoC
RapidIO hardware is present". Since the name does not reflect that well,
I'll change it in the next version: would HAS_RAPIDIO_ONCHIP reflect the
meaning well?
HAS_RAPIDIO=n RAPIDIO=y PCI=y should be an intuitive configuration,
for example for MIPS until last week it effectively was the only option
https://www.linux-mips.org/archives/linux-mips/2018-07/msg00584.html
If we have to rename to make this configuration intuitive again, then
I'll rename and resubmit.
There was never the intention to assign any other meaning to
HAS_RAPIDIO, specifically that it controls the availability of the
RAPIDIO menu option. I think interpreting it this way is is behind a lot
of the issues raised. The intention is that availability of the menu
options is controlled by (1) whether the architecture sources the
rapidio/Kconfig and (2) whether dependencies of RapidIO are satisfied
(either having a PCI bus and enabling it, or having the on-SoC RapidIO
hardware.
The patch does not indend to change the current meaning and usage of the
config options and behavior for X86, PPC, MIPS -- the patch only
refactors there (because it was requested). For ARM and ARM64, we are
adding the same behavior in same way as for those three architectures. I
assume there is nothing that sets ARM and ARM64 apart from the others in
this narrow context. This is the indended scope of this patch. Are we
now discussing a change in the current meaning/usage/behavior? If so,
could we do one piece at a time -- first, add ARM and ARM64 in the way
consistent with the way other architectures currently do it?
next prev parent reply other threads:[~2018-08-01 13:54 UTC|newest]
Thread overview: 31+ messages / expand[flat|nested] mbox.gz Atom feed top
2018-07-30 22:50 [PATCH 0/6] rapidio: move Kconfig menu definition to subsystem Alexei Colin
2018-07-30 22:50 ` [PATCH 1/6] rapidio: define top Kconfig menu in driver subtree Alexei Colin
2018-07-30 22:50 ` [PATCH 2/6] x86: factor out RapidIO Kconfig menu Alexei Colin
2018-07-30 22:55 ` [PATCH 2/6] x86: factor out RapidIO Kconfig menu; Thomas Gleixner
2018-07-31 14:30 ` Alex Bounine
2018-07-30 22:50 ` [PATCH 3/6] powerpc: factor out RapidIO Kconfig menu entry Alexei Colin
2018-07-31 9:45 ` Michael Ellerman
2018-07-30 22:50 ` [PATCH 4/6] mips: factor out RapidIO Kconfig entry Alexei Colin
2018-07-31 8:13 ` Alexander Sverdlin
2018-07-30 22:50 ` [PATCH 5/6] arm: enable RapidIO menu in Kconfig Alexei Colin
2018-07-31 12:04 ` Christoph Hellwig
2018-07-31 12:43 ` Alex Bounine
2018-07-31 12:48 ` Russell King - ARM Linux
2018-07-31 13:15 ` Alex Bounine
2018-07-30 22:50 ` [PATCH 6/6] arm64: " Alexei Colin
2018-07-31 8:41 ` Will Deacon
2018-07-31 12:54 ` Alex Bounine
2018-07-31 15:52 ` Russell King - ARM Linux
2018-07-31 17:59 ` Alex Bounine
2018-07-31 18:18 ` Russell King - ARM Linux
2018-07-31 20:01 ` Alex Bounine
2018-08-01 10:38 ` Russell King - ARM Linux
2018-08-01 13:54 ` Alexei Colin [this message]
2018-08-01 15:14 ` Alex Bounine
2018-07-31 20:29 ` Alex Bounine
2018-07-31 20:46 ` Alexei Colin
2018-08-01 13:57 ` Alex Bounine
2018-08-01 9:10 ` Will Deacon
2018-07-30 22:59 ` [PATCH 0/6] rapidio: move Kconfig menu definition to subsystem Russell King - ARM Linux
2018-07-31 1:08 ` Randy Dunlap
2018-07-31 14:26 ` Alex Bounine
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=20180801135441.GD38497@guest228.east.isi.edu \
--to=acolin@isi.edu \
--cc=akpm@linux-foundation.org \
--cc=alex.bou9@gmail.com \
--cc=catalin.marinas@arm.com \
--cc=jwalters@isi.edu \
--cc=linux-arm-kernel@lists.infradead.org \
--cc=linux-kernel@vger.kernel.org \
--cc=linux@armlinux.org.uk \
--cc=will.deacon@arm.com \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
all inboxes | Powered by JetHome®