From mboxrd@z Thu Jan 1 00:00:00 1970 Return-Path: X-Spam-Checker-Version: SpamAssassin 3.4.0 (2014-02-07) on aws-us-west-2-korg-lkml-1.web.codeaurora.org X-Spam-Level: X-Spam-Status: No, score=-1.0 required=3.0 tests=HEADER_FROM_DIFFERENT_DOMAINS, MAILING_LIST_MULTI,SPF_PASS autolearn=ham autolearn_force=no version=3.4.0 Received: from mail.kernel.org (mail.kernel.org [198.145.29.99]) by smtp.lore.kernel.org (Postfix) with ESMTP id CD6F9C28CF6 for ; Wed, 1 Aug 2018 21:55:36 +0000 (UTC) Received: from vger.kernel.org (vger.kernel.org [209.132.180.67]) by mail.kernel.org (Postfix) with ESMTP id 913E1208B2 for ; Wed, 1 Aug 2018 21:55:36 +0000 (UTC) DMARC-Filter: OpenDMARC Filter v1.3.2 mail.kernel.org 913E1208B2 Authentication-Results: mail.kernel.org; dmarc=none (p=none dis=none) header.from=linux-foundation.org Authentication-Results: mail.kernel.org; spf=none smtp.mailfrom=linux-kernel-owner@vger.kernel.org Received: (majordomo@vger.kernel.org) by vger.kernel.org via listexpand id S1732577AbeHAXn0 (ORCPT ); Wed, 1 Aug 2018 19:43:26 -0400 Received: from mail.linuxfoundation.org ([140.211.169.12]:57088 "EHLO mail.linuxfoundation.org" rhost-flags-OK-OK-OK-OK) by vger.kernel.org with ESMTP id S1726174AbeHAXnY (ORCPT ); Wed, 1 Aug 2018 19:43:24 -0400 Received: from akpm3.svl.corp.google.com (unknown [104.133.9.92]) by mail.linuxfoundation.org (Postfix) with ESMTPSA id DDFA7D3C; Wed, 1 Aug 2018 21:55:31 +0000 (UTC) Date: Wed, 1 Aug 2018 14:55:30 -0700 From: Andrew Morton To: Nick Desaulniers Cc: ysato@users.sourceforge.jp, dalias@libc.org, linux-sh@vger.kernel.org, linux-kernel@vger.kernel.org Subject: Re: [PATCH v2] sh: prefer _THIS_IP_ to current_text_addr Message-Id: <20180801145530.185dab6b47a61842923fc02d@linux-foundation.org> In-Reply-To: <20180801185331.39535-1-ndesaulniers@google.com> References: <20180801185331.39535-1-ndesaulniers@google.com> X-Mailer: Sylpheed 3.6.0 (GTK+ 2.24.31; x86_64-pc-linux-gnu) Mime-Version: 1.0 Content-Type: text/plain; charset=US-ASCII Content-Transfer-Encoding: 7bit Sender: linux-kernel-owner@vger.kernel.org Precedence: bulk List-ID: X-Mailing-List: linux-kernel@vger.kernel.org On Wed, 1 Aug 2018 11:53:31 -0700 Nick Desaulniers wrote: > As part of the effort to reduce the code duplication between _THIS_IP_ > and current_text_addr(), let's consolidate callers of > current_text_addr() to use _THIS_IP_. Why not switch everything to current_text_addr()? _THIS_IP_ is ugly ;) Several architectures (s390, sparc, sh, ...) do funky things in their current_text_addr(). Does the generic kernel.h implementation of current_text_addr() work OK on those architectures?