On Wed, Aug 01, 2018 at 12:57:20PM +0200, Jerome Brunet wrote: > Current clock name looks like this: > /soc/bus@ffd00000/pwm@1b000#mux0 > > This is bad because CCF uses the clock to create a directory in clk debugfs. > With such name, the directory creation (silently) fails and the debugfs > entry end up being created at the debugfs root. > > With this change, the clock name will now be: > ffd1b000.pwm#mux0 > > This matches the clock naming scheme used in the ethernet and mmc driver. > It also fixes the problem with debugfs. > > Fixes: 36af66a79056 ("pwm: Convert to using %pOF instead of full_name") > Signed-off-by: Jerome Brunet > --- > drivers/pwm/pwm-meson.c | 3 +-- > 1 file changed, 1 insertion(+), 2 deletions(-) Applied, thanks. Thierry