From mboxrd@z Thu Jan 1 00:00:00 1970 Return-Path: X-Spam-Checker-Version: SpamAssassin 3.4.0 (2014-02-07) on aws-us-west-2-korg-lkml-1.web.codeaurora.org X-Spam-Level: X-Spam-Status: No, score=-8.2 required=3.0 tests=HEADER_FROM_DIFFERENT_DOMAINS, INCLUDES_PATCH,MAILING_LIST_MULTI,SIGNED_OFF_BY,SPF_PASS,URIBL_BLOCKED, USER_AGENT_MUTT autolearn=ham autolearn_force=no version=3.4.0 Received: from mail.kernel.org (mail.kernel.org [198.145.29.99]) by smtp.lore.kernel.org (Postfix) with ESMTP id BE732C43441 for ; Wed, 10 Oct 2018 15:03:38 +0000 (UTC) Received: from vger.kernel.org (vger.kernel.org [209.132.180.67]) by mail.kernel.org (Postfix) with ESMTP id 90175214DA for ; Wed, 10 Oct 2018 15:03:38 +0000 (UTC) DMARC-Filter: OpenDMARC Filter v1.3.2 mail.kernel.org 90175214DA Authentication-Results: mail.kernel.org; dmarc=none (p=none dis=none) header.from=arm.com Authentication-Results: mail.kernel.org; spf=none smtp.mailfrom=linux-kernel-owner@vger.kernel.org Received: (majordomo@vger.kernel.org) by vger.kernel.org via listexpand id S1727439AbeJJW0L (ORCPT ); Wed, 10 Oct 2018 18:26:11 -0400 Received: from usa-sjc-mx-foss1.foss.arm.com ([217.140.101.70]:53612 "EHLO foss.arm.com" rhost-flags-OK-OK-OK-OK) by vger.kernel.org with ESMTP id S1727033AbeJJW0L (ORCPT ); Wed, 10 Oct 2018 18:26:11 -0400 Received: from usa-sjc-imap-foss1.foss.arm.com (unknown [10.72.51.249]) by usa-sjc-mx-foss1.foss.arm.com (Postfix) with ESMTP id 94BCB1596; Wed, 10 Oct 2018 08:03:36 -0700 (PDT) Received: from e107155-lin (e107155-lin.cambridge.arm.com [10.1.196.42]) by usa-sjc-imap-foss1.foss.arm.com (Postfix) with ESMTPSA id A65573F5B3; Wed, 10 Oct 2018 08:03:33 -0700 (PDT) Date: Wed, 10 Oct 2018 16:03:31 +0100 From: Sudeep Holla To: Ulf Hansson Cc: "Rafael J . Wysocki" , Lorenzo Pieralisi , Mark Rutland , Daniel Lezcano , linux-pm@vger.kernel.org, Tony Lindgren , Kevin Hilman , Lina Iyer , Rob Herring , Viresh Kumar , Vincent Guittot , Geert Uytterhoeven , linux-arm-kernel@lists.infradead.org, linux-arm-msm@vger.kernel.org, linux-kernel@vger.kernel.org, devicetree@vger.kernel.org, Sudeep Holla Subject: Re: [PATCH v9 05/11] of: base: Add of_get_cpu_state_node() to get idle states for a CPU node Message-ID: <20181010150331.GB4844@e107155-lin> References: <20181003143824.13059-1-ulf.hansson@linaro.org> <20181003143824.13059-6-ulf.hansson@linaro.org> MIME-Version: 1.0 Content-Type: text/plain; charset=us-ascii Content-Disposition: inline In-Reply-To: <20181003143824.13059-6-ulf.hansson@linaro.org> User-Agent: Mutt/1.9.4 (2018-02-28) Sender: linux-kernel-owner@vger.kernel.org Precedence: bulk List-ID: X-Mailing-List: linux-kernel@vger.kernel.org On Wed, Oct 03, 2018 at 04:38:18PM +0200, Ulf Hansson wrote: > The CPU's idle state nodes are currently parsed at the common cpuidle DT > library, but also when initializing back-end data for the arch specific CPU > operations, as in the PSCI driver case. > > To avoid open-coding, let's introduce of_get_cpu_state_node(), which takes > the device node for the CPU and the index to the requested idle state node, > as in-parameters. In case a corresponding idle state node is found, it > returns the node with the refcount incremented for it, else it returns > NULL. > > Moreover, for ARM, there are two generic methods, to describe the CPU's > idle states, either via the flattened description through the > "cpu-idle-states" binding [1] or via the hierarchical layout, using the > "power-domains" and the "domain-idle-states" bindings [2]. Hence, let's > take both options into account. > > [1] > Documentation/devicetree/bindings/arm/idle-states.txt > [2] > Documentation/devicetree/bindings/arm/psci.txt > > Cc: Rob Herring > Cc: devicetree@vger.kernel.org > Cc: Lina Iyer > Suggested-by: Sudeep Holla > Co-developed-by: Lina Iyer > Signed-off-by: Ulf Hansson > Reviewed-by: Rob Herring > --- > drivers/of/base.c | 35 +++++++++++++++++++++++++++++++++++ > include/linux/of.h | 8 ++++++++ > 2 files changed, 43 insertions(+) > > diff --git a/drivers/of/base.c b/drivers/of/base.c > index 74eaedd5b860..bf1d5fa34899 100644 > --- a/drivers/of/base.c > +++ b/drivers/of/base.c > @@ -424,6 +424,41 @@ int of_cpu_node_to_id(struct device_node *cpu_node) > } > EXPORT_SYMBOL(of_cpu_node_to_id); > > +/** > + * of_get_cpu_state_node - Get CPU's idle state node at the given index > + * > + * @cpu_node: The device node for the CPU > + * @index: The index in the list of the idle states > + * > + * Two generic methods can be used to describe a CPU's idle states, either via > + * a flattened description through the "cpu-idle-states" binding or via the > + * hierarchical layout, using the "power-domains" and the "domain-idle-states" > + * bindings. This function check for both and returns the idle state node for > + * the requested index. > + * > + * In case and idle state node is found at index, the refcount incremented for > + * it, so call of_node_put() on it when done. Returns NULL if not found. > + */ > +struct device_node *of_get_cpu_state_node(struct device_node *cpu_node, No strong opinion but I am wondering if it makes sense to get cpu logical index and fetch the cpu of_node here to contain the refcount on it within this function while we are trying to consolidate. I do see that may not be so useful in psci.c but keeping refcount for cpu of_node here keeps the user free from that. I am fine as it is if there are reasons not to do that. -- Regards, Sudeep