From: Konrad Rzeszutek Wilk <konrad.wilk@oracle.com>
To: Christoph Hellwig <hch@lst.de>
Cc: Robin Murphy <robin.murphy@arm.com>,
Will Deacon <will.deacon@arm.com>,
Catalin Marinas <catalin.marinas@arm.com>,
linux-arm-kernel@lists.infradead.org,
iommu@lists.linux-foundation.org, linux-kernel@vger.kernel.org
Subject: Re: [PATCH 07/10] swiotlb: refactor swiotlb_map_page
Date: Fri, 19 Oct 2018 09:46:30 -0400 [thread overview]
Message-ID: <20181019134629.GE54336@Konrads-MacBook-Pro.local> (raw)
In-Reply-To: <20181019065258.GA29249@lst.de>
On Fri, Oct 19, 2018 at 08:52:58AM +0200, Christoph Hellwig wrote:
> On Thu, Oct 18, 2018 at 08:37:15PM -0400, Konrad Rzeszutek Wilk wrote:
> > > > + if (!dma_capable(dev, dma_addr, size) ||
> > > > + swiotlb_force == SWIOTLB_FORCE) {
> > > > + trace_swiotlb_bounced(dev, dma_addr, size, swiotlb_force);
> > > > + dma_addr = swiotlb_bounce_page(dev, &phys, size, dir, attrs);
> > > > + }
> > >
> > > FWIW I prefer the inverse condition and early return of the original code
> > > here, which also then allows a tail-call to swiotlb_bounce_page() (and saves
> > > a couple of lines), but it's no biggie.
> > >
> > > Reviewed-by: Robin Murphy <robin.murphy@arm.com>
> >
> > I agree with Robin - it certainly makes it easier to read.
> >
> > With that small change:
> > Reviewed-by: Konrad Rzeszutek Wilk <konrad.wilk@oracle.com>
>
> So I did this edit, and in this patch it does indeed look much cleaner.
> But in patch 9 we introduce the cache maintainance, and have to invert
> the condition again if we don't want a goto mess:
Right. In which case please leave this patch as it is. And please
plaster the Reviewed-by on the patch. Thank you!
next prev parent reply other threads:[~2018-10-19 13:47 UTC|newest]
Thread overview: 57+ messages / expand[flat|nested] mbox.gz Atom feed top
2018-10-08 8:02 move swiotlb noncoherent dma support from arm64 to generic code V2 Christoph Hellwig
2018-10-08 8:02 ` [PATCH 01/10] swiotlb: remove a pointless comment Christoph Hellwig
2018-10-11 17:49 ` Robin Murphy
2018-10-19 0:09 ` Konrad Rzeszutek Wilk
2018-10-08 8:02 ` [PATCH 02/10] swiotlb: mark is_swiotlb_buffer static Christoph Hellwig
2018-10-11 17:54 ` Robin Murphy
2018-10-19 0:12 ` Konrad Rzeszutek Wilk
2018-10-08 8:02 ` [PATCH 03/10] swiotlb: do not panic on mapping failures Christoph Hellwig
2018-10-11 18:06 ` Robin Murphy
2018-10-19 0:18 ` Konrad Rzeszutek Wilk
2018-10-19 0:17 ` Konrad Rzeszutek Wilk
2018-10-19 6:04 ` Christoph Hellwig
2018-10-19 13:45 ` Konrad Rzeszutek Wilk
2018-10-08 8:02 ` [PATCH 04/10] swiotlb: remove the overflow buffer Christoph Hellwig
2018-10-11 18:19 ` Robin Murphy
2018-10-12 17:04 ` Catalin Marinas
2018-10-19 0:23 ` Konrad Rzeszutek Wilk
2018-10-08 8:02 ` [PATCH 05/10] swiotlb: merge swiotlb_unmap_page and unmap_single Christoph Hellwig
2018-10-18 17:44 ` Robin Murphy
2018-10-19 0:25 ` Konrad Rzeszutek Wilk
2018-10-08 8:02 ` [PATCH 06/10] swiotlb: use swiotlb_map_page in swiotlb_map_sg_attrs Christoph Hellwig
2018-10-18 17:53 ` Robin Murphy
2018-10-19 0:33 ` Konrad Rzeszutek Wilk
2018-11-07 1:27 ` John Stultz
2018-11-09 7:49 ` Christoph Hellwig
2018-11-09 16:37 ` Robin Murphy
2018-11-19 19:36 ` Robin Murphy
2018-11-20 9:22 ` Christoph Hellwig
2018-11-13 0:07 ` John Stultz
2018-11-13 0:26 ` John Stultz
2018-11-14 14:13 ` Christoph Hellwig
2018-11-14 16:12 ` Christoph Hellwig
2018-11-19 23:22 ` John Stultz
2018-11-20 9:25 ` Christoph Hellwig
2018-11-23 18:27 ` Will Deacon
2018-11-23 19:34 ` Robin Murphy
2018-11-26 19:31 ` Will Deacon
2018-10-08 8:02 ` [PATCH 07/10] swiotlb: refactor swiotlb_map_page Christoph Hellwig
2018-10-18 18:09 ` Robin Murphy
2018-10-19 0:37 ` Konrad Rzeszutek Wilk
2018-10-19 6:52 ` Christoph Hellwig
2018-10-19 13:46 ` Konrad Rzeszutek Wilk [this message]
2018-10-08 8:02 ` [PATCH 08/10] swiotlb: don't dip into swiotlb pool for coherent allocations Christoph Hellwig
2018-10-12 17:04 ` Catalin Marinas
2018-10-19 0:40 ` Konrad Rzeszutek Wilk
2018-10-19 16:45 ` Robin Murphy
2018-10-08 8:02 ` [PATCH 09/10] swiotlb: add support for non-coherent DMA Christoph Hellwig
2018-10-19 0:49 ` Konrad Rzeszutek Wilk
2018-10-22 17:11 ` Robin Murphy
2018-10-26 8:04 ` Christoph Hellwig
2018-10-26 9:59 ` Robin Murphy
2018-10-08 8:02 ` [PATCH 10/10] arm64: use the generic swiotlb_dma_ops Christoph Hellwig
2018-10-12 13:01 ` Robin Murphy
2018-10-12 14:40 ` Christoph Hellwig
2018-10-12 17:05 ` Catalin Marinas
2018-10-22 17:52 ` Robin Murphy
2018-10-26 12:44 ` Christoph Hellwig
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=20181019134629.GE54336@Konrads-MacBook-Pro.local \
--to=konrad.wilk@oracle.com \
--cc=catalin.marinas@arm.com \
--cc=hch@lst.de \
--cc=iommu@lists.linux-foundation.org \
--cc=linux-arm-kernel@lists.infradead.org \
--cc=linux-kernel@vger.kernel.org \
--cc=robin.murphy@arm.com \
--cc=will.deacon@arm.com \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
all inboxes | Powered by JetHome®