From: "Moger, Babu" <Babu.Moger@amd.com>
To: "tglx@linutronix.de" <tglx@linutronix.de>,
"mingo@redhat.com" <mingo@redhat.com>,
"bp@alien8.de" <bp@alien8.de>, "corbet@lwn.net" <corbet@lwn.net>,
"fenghua.yu@intel.com" <fenghua.yu@intel.com>,
"reinette.chatre@intel.com" <reinette.chatre@intel.com>,
"peterz@infradead.org" <peterz@infradead.org>,
"gregkh@linuxfoundation.org" <gregkh@linuxfoundation.org>,
"davem@davemloft.net" <davem@davemloft.net>,
"akpm@linux-foundation.org" <akpm@linux-foundation.org>
Cc: "hpa@zytor.com" <hpa@zytor.com>,
"x86@kernel.org" <x86@kernel.org>,
"mchehab+samsung@kernel.org" <mchehab+samsung@kernel.org>,
"arnd@arndb.de" <arnd@arndb.de>,
"kstewart@linuxfoundation.org" <kstewart@linuxfoundation.org>,
"pombredanne@nexb.com" <pombredanne@nexb.com>,
"rafael@kernel.org" <rafael@kernel.org>,
"kirill.shutemov@linux.intel.com"
<kirill.shutemov@linux.intel.com>,
"tony.luck@intel.com" <tony.luck@intel.com>,
"qianyue.zj@alibaba-inc.com" <qianyue.zj@alibaba-inc.com>,
"xiaochen.shen@intel.com" <xiaochen.shen@intel.com>,
"pbonzini@redhat.com" <pbonzini@redhat.com>,
"Singh, Brijesh" <brijesh.singh@amd.com>,
"Hurwitz, Sherry" <sherry.hurwitz@amd.com>,
"dwmw2@infradead.org" <dwmw2@infradead.org>,
"Lendacky, Thomas" <Thomas.Lendacky@amd.com>,
"luto@kernel.org" <luto@kernel.org>,
"joro@8bytes.org" <joro@8bytes.org>,
"jannh@google.com" <jannh@google.com>,
"vkuznets@redhat.com" <vkuznets@redhat.com>,
"rian@alum.mit.edu" <rian@alum.mit.edu>,
"jpoimboe@redhat.com" <jpoimboe@redhat.com>,
"Moger, Babu" <Babu.Moger@amd.com>,
"linux-kernel@vger.kernel.org" <linux-kernel@vger.kernel.org>,
"linux-doc@vger.kernel.org" <linux-doc@vger.kernel.org>
Subject: [PATCH v7 12/13] Documentation/x86: Rename and update intel_rdt_ui.txt
Date: Fri, 9 Nov 2018 20:52:47 +0000 [thread overview]
Message-ID: <20181109205153.14811-13-babu.moger@amd.com> (raw)
In-Reply-To: <20181109205153.14811-1-babu.moger@amd.com>
Rename intel_rdt_ui.txt to generic resctrl_ui.txt and update the
documentation for AMD.
Signed-off-by: Babu Moger <babu.moger@amd.com>
---
Documentation/x86/{intel_rdt_ui.txt => resctrl_ui.txt} | 9 ++++++---
1 file changed, 6 insertions(+), 3 deletions(-)
rename Documentation/x86/{intel_rdt_ui.txt => resctrl_ui.txt} (99%)
diff --git a/Documentation/x86/intel_rdt_ui.txt b/Documentation/x86/resctrl_ui.txt
similarity index 99%
rename from Documentation/x86/intel_rdt_ui.txt
rename to Documentation/x86/resctrl_ui.txt
index 52b10945ff75..d9aed8303984 100644
--- a/Documentation/x86/intel_rdt_ui.txt
+++ b/Documentation/x86/resctrl_ui.txt
@@ -1,4 +1,7 @@
-User Interface for Resource Allocation in Intel Resource Director Technology
+User Interface for Resource Control feature
+
+Intel refers to this feature as Intel Resource Director Technology(Intel(R) RDT).
+AMD refers to this feature as AMD Platform Quality of Service(AMD QoS).
Copyright (C) 2016 Intel Corporation
@@ -6,8 +9,8 @@ Fenghua Yu <fenghua.yu@intel.com>
Tony Luck <tony.luck@intel.com>
Vikas Shivappa <vikas.shivappa@intel.com>
-This feature is enabled by the CONFIG_INTEL_RDT Kconfig and the
-X86 /proc/cpuinfo flag bits:
+This feature is enabled by the CONFIG_RESCTRL and the X86 /proc/cpuinfo
+flag bits:
RDT (Resource Director Technology) Allocation - "rdt_a"
CAT (Cache Allocation Technology) - "cat_l3", "cat_l2"
CDP (Code and Data Prioritization ) - "cdp_l3", "cdp_l2"
--
2.17.1
next prev parent reply other threads:[~2018-11-09 20:53 UTC|newest]
Thread overview: 31+ messages / expand[flat|nested] mbox.gz Atom feed top
2018-11-09 20:52 [PATCH v7 00/13] arch/x86: AMD QoS support Moger, Babu
2018-11-09 20:52 ` [PATCH v7 01/13] arch/x86: Start renaming the rdt files to more generic names Moger, Babu
2018-11-12 17:16 ` Borislav Petkov
2018-11-12 19:16 ` Moger, Babu
2018-11-13 21:35 ` Yu, Fenghua
2018-11-13 21:40 ` Borislav Petkov
2018-11-09 20:52 ` [PATCH v7 02/13] arch/x86: Rename the RDT functions and definitions Moger, Babu
2018-11-12 17:56 ` Borislav Petkov
2018-11-12 19:25 ` Moger, Babu
2018-11-12 19:46 ` Borislav Petkov
2018-11-12 20:51 ` Moger, Babu
2018-11-09 20:52 ` [PATCH v7 03/13] arch/x86: Re-arrange RDT init code Moger, Babu
2018-11-14 19:05 ` Borislav Petkov
2018-11-14 20:07 ` Moger, Babu
2018-11-09 20:52 ` [PATCH v7 04/13] arch/x86: Bring all the macros to resctrl.h Moger, Babu
2018-11-09 20:52 ` [PATCH v7 05/13] arch/x86: Rename config parameter INTEL_RDT to RESCTRL Moger, Babu
2018-11-09 20:52 ` [PATCH v7 06/13] arch/x86: Initialize the resource functions that are different Moger, Babu
2018-11-09 20:52 ` [PATCH v7 07/13] arch/x86: Bring cbm_validate function into the resource structure Moger, Babu
2018-11-09 20:52 ` [PATCH v7 08/13] arch/x86: Add vendor check for MBA software controller Moger, Babu
2018-11-09 20:52 ` [PATCH v7 09/13] arch/x86: Update the RESCTRL config parameter Moger, Babu
2018-11-09 20:52 ` [PATCH v7 10/13] arch/x86: Add AMD feature bit X86_FEATURE_MBA in cpuid bits array Moger, Babu
2018-11-09 20:52 ` [PATCH v7 11/13] arch/x86: Introduce QOS feature for AMD Moger, Babu
2018-11-13 21:49 ` Yu, Fenghua
2018-11-14 16:38 ` Moger, Babu
2018-11-14 18:17 ` Moger, Babu
2018-11-14 19:31 ` Yu, Fenghua
2018-11-09 20:52 ` Moger, Babu [this message]
2018-11-09 20:52 ` [PATCH v7 13/13] MAINTAINERS: Update the file and documentation names in arch/x86 Moger, Babu
2018-11-19 23:58 ` [PATCH v7 00/13] arch/x86: AMD QoS support Pavel Machek
2018-11-20 2:20 ` Yu, Fenghua
2018-11-20 9:13 ` Pavel Machek
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=20181109205153.14811-13-babu.moger@amd.com \
--to=babu.moger@amd.com \
--cc=Thomas.Lendacky@amd.com \
--cc=akpm@linux-foundation.org \
--cc=arnd@arndb.de \
--cc=bp@alien8.de \
--cc=brijesh.singh@amd.com \
--cc=corbet@lwn.net \
--cc=davem@davemloft.net \
--cc=dwmw2@infradead.org \
--cc=fenghua.yu@intel.com \
--cc=gregkh@linuxfoundation.org \
--cc=hpa@zytor.com \
--cc=jannh@google.com \
--cc=joro@8bytes.org \
--cc=jpoimboe@redhat.com \
--cc=kirill.shutemov@linux.intel.com \
--cc=kstewart@linuxfoundation.org \
--cc=linux-doc@vger.kernel.org \
--cc=linux-kernel@vger.kernel.org \
--cc=luto@kernel.org \
--cc=mchehab+samsung@kernel.org \
--cc=mingo@redhat.com \
--cc=pbonzini@redhat.com \
--cc=peterz@infradead.org \
--cc=pombredanne@nexb.com \
--cc=qianyue.zj@alibaba-inc.com \
--cc=rafael@kernel.org \
--cc=reinette.chatre@intel.com \
--cc=rian@alum.mit.edu \
--cc=sherry.hurwitz@amd.com \
--cc=tglx@linutronix.de \
--cc=tony.luck@intel.com \
--cc=vkuznets@redhat.com \
--cc=x86@kernel.org \
--cc=xiaochen.shen@intel.com \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
all inboxes | Powered by JetHome®