From: Namhyung Kim <namhyung@kernel.org>
To: Tom Zanussi <zanussi@kernel.org>
Cc: rostedt@goodmis.org, tglx@linutronix.de, mhiramat@kernel.org,
vedang.patel@intel.com, bigeasy@linutronix.de,
joel@joelfernandes.org, mathieu.desnoyers@efficios.com,
julia@ni.com, linux-kernel@vger.kernel.org,
linux-rt-users@vger.kernel.org, kernel-team@lge.com
Subject: Re: [PATCH 0/7] tracing: Hist trigger var-ref cleanup and comments
Date: Wed, 19 Dec 2018 20:45:17 +0900 [thread overview]
Message-ID: <20181219114517.GA19177@danjae.aot.lge.com> (raw)
In-Reply-To: <cover.1545161087.git.tom.zanussi@linux.intel.com>
Hi Tom,
On Tue, Dec 18, 2018 at 02:33:19PM -0600, Tom Zanussi wrote:
> From: Tom Zanussi <tom.zanussi@linux.intel.com>
>
> Hi,
>
> This patchset is a standalone series broken out of the v8 version of
> the 'tracing: Hist trigger snapshot and onchange additions' patchset.
>
> It's a series of changes resulting from some suggestions from Namhyung
> for making the variable-reference handling code more understandable
> through some refactoring and comments.
>
> It also added a new patch changing all strlen() to sizeof() for string
> constants, in trace_events_hist.c
>
> Also, in the 'tracing: Remove open-coding of hist trigger var_ref
> management' patch, in create_var_ref(), moved the saving of ref_field
> and update of ref_field->var_ref_idx into the 'if' as pointed out by
> Dan Carpenter/smatch 0-day robot.
>
> It doesn't introduce any functional changes and can be applied
> independently of the other patchset.
Acked-by: Namhyung Kim <namhyung@kernel.org>
Thanks,
Namhyung
>
> The following changes since commit 5d6ddf6acce68d1290112cb08b12fd78b201e7d5:
>
> arm64: Use ftrace_graph_get_ret_stack() instead of curr_ret_stack (2018-12-08 22:21:31 -0500)
>
> are available in the git repository at:
>
> git://git.kernel.org/pub/scm/linux/kernel/git/zanussi/linux-trace.git ftrace/hist-var-ref-cleanup-v1
>
> Tom Zanussi (7):
> tracing: Remove unnecessary hist trigger struct field
> tracing: Change strlen to sizeof for hist trigger static strings
> tracing: Use var_refs[] for hist trigger reference checking
> tracing: Remove open-coding of hist trigger var_ref management
> tracing: Use hist trigger's var_ref array to destroy var_refs
> tracing: Remove hist trigger synth_var_refs
> tracing: Add hist trigger comments for variable-related fields
>
> kernel/trace/trace_events_hist.c | 267 +++++++++++++++++++++++----------------
> 1 file changed, 156 insertions(+), 111 deletions(-)
>
> --
> 2.14.1
>
next prev parent reply other threads:[~2018-12-19 11:45 UTC|newest]
Thread overview: 31+ messages / expand[flat|nested] mbox.gz Atom feed top
2018-12-18 20:33 Tom Zanussi
2018-12-18 20:33 ` [PATCH 1/7] tracing: Remove unnecessary hist trigger struct field Tom Zanussi
2018-12-18 20:33 ` [PATCH 2/7] tracing: Change strlen to sizeof for hist trigger static strings Tom Zanussi
2018-12-19 19:40 ` Steven Rostedt
2018-12-19 19:46 ` Tom Zanussi
2018-12-19 20:16 ` Tom Zanussi
2018-12-19 20:22 ` Joe Perches
2018-12-19 20:34 ` Steven Rostedt
2018-12-19 20:51 ` Joe Perches
2018-12-19 21:03 ` Steven Rostedt
2018-12-19 20:28 ` Steven Rostedt
2018-12-19 20:20 ` Joe Perches
2018-12-19 20:30 ` Steven Rostedt
2018-12-19 20:38 ` Tom Zanussi
2018-12-19 21:01 ` Steven Rostedt
2018-12-19 21:08 ` Joe Perches
2018-12-19 20:27 ` Steven Rostedt
2018-12-18 20:33 ` [PATCH 3/7] tracing: Use var_refs[] for hist trigger reference checking Tom Zanussi
2018-12-19 12:22 ` Masami Hiramatsu
2018-12-19 15:01 ` Tom Zanussi
2018-12-19 15:36 ` Steven Rostedt
2018-12-19 19:08 ` Tom Zanussi
2018-12-19 19:09 ` [PATCH v2 " Tom Zanussi
2018-12-18 20:33 ` [PATCH 4/7] tracing: Remove open-coding of hist trigger var_ref management Tom Zanussi
2018-12-18 20:33 ` [PATCH 5/7] tracing: Use hist trigger's var_ref array to destroy var_refs Tom Zanussi
2018-12-18 20:33 ` [PATCH 6/7] tracing: Remove hist trigger synth_var_refs Tom Zanussi
2018-12-18 20:33 ` [PATCH 7/7] tracing: Add hist trigger comments for variable-related fields Tom Zanussi
2018-12-19 11:45 ` Namhyung Kim [this message]
2018-12-19 15:00 ` [PATCH 0/7] tracing: Hist trigger var-ref cleanup and comments Tom Zanussi
2018-12-19 12:27 ` Masami Hiramatsu
2018-12-19 15:02 ` Tom Zanussi
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=20181219114517.GA19177@danjae.aot.lge.com \
--to=namhyung@kernel.org \
--cc=bigeasy@linutronix.de \
--cc=joel@joelfernandes.org \
--cc=julia@ni.com \
--cc=kernel-team@lge.com \
--cc=linux-kernel@vger.kernel.org \
--cc=linux-rt-users@vger.kernel.org \
--cc=mathieu.desnoyers@efficios.com \
--cc=mhiramat@kernel.org \
--cc=rostedt@goodmis.org \
--cc=tglx@linutronix.de \
--cc=vedang.patel@intel.com \
--cc=zanussi@kernel.org \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
all inboxes | Powered by JetHome®