mirror of https://lore.kernel.org/lkml/
 help / color / mirror / Atom feed
From: Heikki Krogerus <heikki.krogerus@linux.intel.com>
To: Jun Li <jun.li@nxp.com>
Cc: Greg Kroah-Hartman <gregkh@linuxfoundation.org>,
	Andy Shevchenko <andy.shevchenko@gmail.com>,
	Chen Yu <chenyu56@huawei.com>,
	Hans de Goede <hdegoede@redhat.com>,
	"linux-usb@vger.kernel.org" <linux-usb@vger.kernel.org>,
	"linux-kernel@vger.kernel.org" <linux-kernel@vger.kernel.org>
Subject: Re: [PATCH v2 6/9] usb: roles: Find the muxes by also matching against the device node
Date: Tue, 12 Feb 2019 10:50:33 +0200	[thread overview]
Message-ID: <20190212085033.GB32070@kuha.fi.intel.com> (raw)
In-Reply-To: <VI1PR04MB4558F4F7BC10D82FC1BE71B489650@VI1PR04MB4558.eurprd04.prod.outlook.com>

Hi,

On Tue, Feb 12, 2019 at 06:03:42AM +0000, Jun Li wrote:
> > > return dev_fwnode(dev->parent) == fwnode;
> > 
> > That's actually not the case. struct usb_role_switch_desc has a member for fwnode,
> > and that's what we use with the actual mux device. Check
> > usb_role_switch_register():
> > 
> >         ...
> >         sw->dev.fwnode = desc->fwnode;
> >         ...
> > 
> > Sorry for not realizing it before.
> 
> So desc->fwnode should be initialized before do usb_role_switch_register()?
> But seems usb_role_switch_desc is a read-only object so can't be set at runtime.

It can. Even though usb_role_switch_register() takes read-only
parameter, nothing's preventing you from passing data even from the
stack (the content of the descriptor is copied in any case).

Expecting the descriptor to be read-only just means it can be
read-only, but it does not have to be.

> usb_controller_node {
> 	...
> 	usb-role-switch;
> 
> 	port {
> 		sw_provider_node: endpoint {
> 			remote-endpoint = <&sw_consumer_node>;
> 		};
> 	};
> };
> 
> typec_node {
> 	...
> 	port {
> 		sw_consumer_node: endpoint {
> 			remote-endpoint = <&sw_provider_node>;
> 		};
> 	};
> };

That looks roughly correct to me.


thanks,

-- 
heikki

  reply	other threads:[~2019-02-12  8:50 UTC|newest]

Thread overview: 25+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2019-01-30 16:02 [PATCH v2 0/9] device connection: Add support for device graphs Heikki Krogerus
2019-01-30 16:02 ` [PATCH v2 1/9] platform/x86: intel_cht_int33fe: Prepare for better mux naming scheme Heikki Krogerus
2019-01-30 16:02 ` [PATCH v2 2/9] usb: typec: Rationalize the API for the muxes Heikki Krogerus
2019-01-30 16:02 ` [PATCH v2 3/9] platform/x86: intel_cht_int33fe: Remove old style mux connections Heikki Krogerus
2019-01-30 16:02 ` [PATCH v2 4/9] device connection: Add fwnode member to struct device_connection Heikki Krogerus
2019-01-30 16:02 ` [PATCH v2 5/9] usb: typec: mux: Find the muxes by also matching against the device node Heikki Krogerus
2019-01-30 16:02 ` [PATCH v2 6/9] usb: roles: " Heikki Krogerus
2019-02-11  9:58   ` Jun Li
2019-02-11 10:46     ` Heikki Krogerus
2019-02-11 12:40       ` Heikki Krogerus
2019-02-12  6:03       ` Jun Li
2019-02-12  8:50         ` Heikki Krogerus [this message]
2019-02-12 10:41           ` Jun Li
2019-02-12 11:24             ` Heikki Krogerus
2019-01-30 16:02 ` [PATCH v2 7/9] usb: typec: Find the ports " Heikki Krogerus
2019-01-30 16:51   ` Andy Shevchenko
2019-01-31 13:35     ` Heikki Krogerus
2019-02-11  8:39       ` Heikki Krogerus
2019-02-11 11:52         ` Andy Shevchenko
2019-01-30 16:02 ` [PATCH v2 8/9] device connection: Prepare support for firmware described connections Heikki Krogerus
2019-01-30 16:02 ` [PATCH v2 9/9] device connection: Find device connections also from device graphs Heikki Krogerus
2019-01-31 10:06 ` [PATCH v2 0/9] device connection: Add support for " Hans de Goede
2019-01-31 13:36   ` Heikki Krogerus
2019-02-12 10:44 ` Jun Li
2019-02-12 11:31   ` Heikki Krogerus

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=20190212085033.GB32070@kuha.fi.intel.com \
    --to=heikki.krogerus@linux.intel.com \
    --cc=andy.shevchenko@gmail.com \
    --cc=chenyu56@huawei.com \
    --cc=gregkh@linuxfoundation.org \
    --cc=hdegoede@redhat.com \
    --cc=jun.li@nxp.com \
    --cc=linux-kernel@vger.kernel.org \
    --cc=linux-usb@vger.kernel.org \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox

Powered by JetHome