From: Peter Zijlstra <peterz@infradead.org>
To: Waiman Long <longman@redhat.com>
Cc: Ingo Molnar <mingo@redhat.com>, Will Deacon <will.deacon@arm.com>,
Thomas Gleixner <tglx@linutronix.de>,
linux-kernel@vger.kernel.org, x86@kernel.org,
Arnd Bergmann <arnd@arndb.de>, Borislav Petkov <bp@alien8.de>,
"H. Peter Anvin" <hpa@zytor.com>,
Davidlohr Bueso <dave@stgolabs.net>,
Linus Torvalds <torvalds@linux-foundation.org>,
Andrew Morton <akpm@linux-foundation.org>,
Tim Chen <tim.c.chen@linux.intel.com>
Subject: Re: [PATCH 03/10] locking/rwsem: Rename kernel/locking/rwsem.h
Date: Wed, 13 Feb 2019 16:54:23 +0100 [thread overview]
Message-ID: <20190213155423.GZ32494@hirez.programming.kicks-ass.net> (raw)
In-Reply-To: <31e47c29-fdb4-6fcb-64a9-36ce70226af5@redhat.com>
On Wed, Feb 13, 2019 at 10:47:11AM -0500, Waiman Long wrote:
> On 02/13/2019 04:19 AM, Peter Zijlstra wrote:
> > On Tue, Feb 12, 2019 at 07:27:00PM -0500, Waiman Long wrote:
> >> The content of kernel/locking/rwsem.h is now specific to rwsem-xadd only.
> >> Rename it to rwsem-xadd.h to indicate that it is specific to rwsem-xadd
> >> and include it only when CONFIG_RWSEM_XCHGADD_ALGORITHM is set. As a result,
> >> the CONFIG_RWSEM_XCHGADD_ALGORITHM conditional compilation directives can
> >> be removed. There is no functional change.
> > Since all of rwsem-xadd is now generic code; how about we delete the
> > spinlock thing and keep everything rwsem ?
> >
> > We don't carry a special spinlock mutex implementation either. And
> > arguably any arch that uses spinlock based atomics (afaict the only case
> > where rwsem-spinlock makes any sense anyway) suck anyway.
>
> I don't mind removing the rwsem-spinlock code and have just one
> implementation for all as long as there is no objection from others. I
> don't know the history of why we have 2 implementations of rwsem and so
> I didn't plan to do that.
It is from before my time too; but I think rwsem-spinlock is generic and
didn't require arch asm helpers, where rwsem-xadd did, but we just fixed
that :-)
next prev parent reply other threads:[~2019-02-13 15:54 UTC|newest]
Thread overview: 19+ messages / expand[flat|nested] mbox.gz Atom feed top
2019-02-13 0:26 [PATCH 00/10] locking/rwsem: Rwsem rearchitecture part 1 Waiman Long
2019-02-13 0:26 ` [PATCH 01/10] locking/rwsem: Relocate rwsem_down_read_failed() Waiman Long
2019-02-13 0:26 ` [PATCH 02/10] locking/rwsem: Move owner setting code from rwsem.c to rwsem.h Waiman Long
2019-02-13 0:27 ` [PATCH 03/10] locking/rwsem: Rename kernel/locking/rwsem.h Waiman Long
2019-02-13 9:19 ` Peter Zijlstra
2019-02-13 15:47 ` Waiman Long
2019-02-13 15:54 ` Peter Zijlstra [this message]
2019-02-13 16:16 ` Waiman Long
2019-02-13 16:16 ` Waiman Long
2019-02-13 16:20 ` Waiman Long
2019-02-13 0:27 ` [PATCH 04/10] locking/rwsem: Move rwsem internal function declarations to rwsem-xadd.h Waiman Long
2019-02-13 0:27 ` [PATCH 05/10] locking/rwsem: Add debug check for __down_read*() Waiman Long
2019-02-13 0:27 ` [PATCH 06/10] locking/rwsem: Enhance DEBUG_RWSEMS_WARN_ON() macro Waiman Long
2019-02-13 0:27 ` [PATCH 07/10] locking/qspinlock_stat: Introduce a generic lockevent counting APIs Waiman Long
2019-02-13 0:27 ` [PATCH 08/10] locking/lock_events: Make lock_events available for all archs & other locks Waiman Long
2019-02-13 0:27 ` [PATCH 09/10] locking/lock_events: Don't show pvqspinlock events on bare metal Waiman Long
2019-02-13 0:27 ` [PATCH 10/10] locking/rwsem: Enable lock event counting Waiman Long
2019-02-15 18:49 ` [PATCH 00/10] locking/rwsem: Rwsem rearchitecture part 1 Will Deacon
2019-02-15 18:55 ` Waiman Long
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=20190213155423.GZ32494@hirez.programming.kicks-ass.net \
--to=peterz@infradead.org \
--cc=akpm@linux-foundation.org \
--cc=arnd@arndb.de \
--cc=bp@alien8.de \
--cc=dave@stgolabs.net \
--cc=hpa@zytor.com \
--cc=linux-kernel@vger.kernel.org \
--cc=longman@redhat.com \
--cc=mingo@redhat.com \
--cc=tglx@linutronix.de \
--cc=tim.c.chen@linux.intel.com \
--cc=torvalds@linux-foundation.org \
--cc=will.deacon@arm.com \
--cc=x86@kernel.org \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
all inboxes | Powered by JetHome®