From: Morten Rasmussen <morten.rasmussen@arm.com>
To: Peter Zijlstra <peterz@infradead.org>
Cc: Len Brown <lenb@kernel.org>,
x86@kernel.org, linux-kernel@vger.kernel.org
Subject: Re: [PATCH 0/14] v2 multi-die/package topology support
Date: Thu, 7 Mar 2019 14:59:25 +0000 [thread overview]
Message-ID: <20190307145925.GD19434@e105550-lin.cambridge.arm.com> (raw)
In-Reply-To: <20190226185358.GQ2861@worktop.programming.kicks-ass.net>
On Tue, Feb 26, 2019 at 07:53:58PM +0100, Peter Zijlstra wrote:
> On Tue, Feb 26, 2019 at 01:19:58AM -0500, Len Brown wrote:
> > Added sysfs package_threads, package_threads_list
> >
> > Added this attribute to show threads siblings in a package.
> > Exactly same as "core_siblings above", a name now deprecated.
> > This attribute name and definition is immune to future
> > topology changes.
> >
> > Suggested by Brice.
> >
> > Added sysfs die_threads, die_threads_list
> >
> > Added this attribute to show which threads siblings in a die.
> > V1 had proposed putting this info into "core_siblings", but we
> > decided to leave that legacy attribute alone.
> > This attribute name and definition is immune to future
> > topology changes.
> >
> > On a single die-package system this attribute has same contents
> > as "package_threads".
> >
> > Suggested by Brice.
> >
> > Added sysfs core_threads, core_threads_list
> >
> > Added this attribute to show which threads siblings in a core.
> > Exactly same as "thread_siblings", a name now deprecated.
> > This attribute name and definition is immune to future
> > topology changes.
> >
> > Suggested by Brice.
>
> I think I prefer 's/threads/cpus/g' on that. Threads makes me think SMT,
> and I don't think there's any guarantee the part in question will have
> SMT on.
I think 'threads' is a bit confusing as well. We seem to be using 'cpu'
everywhere for something we can schedule tasks on, including the sysfs
/sys/devices/system/cpu/ subdirs for each SMT thread on SMT systems.
Another thing that I find confusing is that with this series we a new
die id/mask which is totally unrelated to the DIE level in the
sched_domain hierarchy. We should rename DIE level to something that
reflects what it really is. If we can agree on that ;-)
NODE level?
Morten
next prev parent reply other threads:[~2019-03-07 14:59 UTC|newest]
Thread overview: 39+ messages / expand[flat|nested] mbox.gz Atom feed top
2019-02-26 6:19 Len Brown
2019-02-26 6:19 ` [PATCH 01/14] x86 topology: Fix doc typo Len Brown
2019-02-26 6:20 ` [PATCH 02/14] topolgy: Simplify cputopology.txt formatting and wording Len Brown
2019-02-26 6:20 ` [PATCH 03/14] x86 smpboot: Rename match_die() to match_pkg() Len Brown
2019-02-26 6:20 ` [PATCH 04/14] x86 topology: Add CPUID.1F multi-die/package support Len Brown
2019-02-26 19:46 ` Dave Hansen
2019-02-28 15:43 ` Len Brown
2019-04-05 18:16 ` Thomas Gleixner
2019-02-26 6:20 ` [PATCH 05/14] cpu topology: Export die_id Len Brown
2019-03-07 14:45 ` Morten Rasmussen
2019-03-26 18:18 ` Len Brown
2019-02-26 6:20 ` [PATCH 06/14] x86 topology: Define topology_logical_die_id() Len Brown
2019-02-26 6:20 ` [PATCH 07/14] powercap/intel_rapl: Simplify rapl_find_package() Len Brown
2019-02-26 19:06 ` Peter Zijlstra
2019-03-26 18:27 ` Len Brown
2019-02-26 6:20 ` [PATCH 08/14] powercap/intel_rapl: Support multi-die/package Len Brown
2019-04-05 18:27 ` Thomas Gleixner
2019-04-08 1:35 ` Zhang Rui
2019-02-26 6:20 ` [PATCH 09/14] thermal/x86_pkg_temp_thermal: " Len Brown
2019-04-05 18:29 ` Thomas Gleixner
2019-04-05 18:39 ` Brown, Len
2019-04-05 18:50 ` Thomas Gleixner
2019-02-26 6:20 ` [PATCH 10/14] powercap/intel_rapl: update rapl domain name and debug messages Len Brown
2019-02-26 6:20 ` [PATCH 11/14] hwmon/coretemp: Support multi-die/package Len Brown
2019-02-26 6:20 ` [PATCH 12/14] topology: Create package_threads sysfs attribute Len Brown
2019-02-26 6:20 ` [PATCH 13/14] topology: Create core_threads " Len Brown
2019-02-26 6:20 ` [PATCH 14/14] topology: Create die_threads " Len Brown
2019-02-26 18:51 ` [PATCH 0/14] v2 multi-die/package topology support Peter Zijlstra
2019-04-12 19:32 ` Len Brown
2019-02-26 18:53 ` Peter Zijlstra
2019-03-07 14:59 ` Morten Rasmussen [this message]
2019-04-05 18:33 ` Thomas Gleixner
2019-04-12 19:52 ` Len Brown
2019-04-12 20:40 ` Brice Goglin
2019-02-26 19:05 ` Peter Zijlstra
2019-04-30 6:50 ` Len Brown
2019-04-30 9:33 ` Borislav Petkov
2019-04-30 18:46 ` Len Brown
2019-04-05 18:33 ` Thomas Gleixner
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=20190307145925.GD19434@e105550-lin.cambridge.arm.com \
--to=morten.rasmussen@arm.com \
--cc=lenb@kernel.org \
--cc=linux-kernel@vger.kernel.org \
--cc=peterz@infradead.org \
--cc=x86@kernel.org \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
all inboxes | Powered by JetHome®