From: Andrew Morton <akpm@linux-foundation.org>
To: Yury Norov <yury.norov@gmail.com>
Cc: Andy Shevchenko <andriy.shevchenko@linux.intel.com>,
Rasmus Villemoes <linux@rasmusvillemoes.dk>,
Arnd Bergmann <arnd@arndb.de>, Kees Cook <keescook@chromium.org>,
Matthew Wilcox <willy@infradead.org>,
Tetsuo Handa <penguin-kernel@I-love.SAKURA.ne.jp>,
Yury Norov <ynorov@marvell.com>,
linux-kernel@vger.kernel.org
Subject: Re: [PATCH 2/6] bitmap_parselist: move non-parser logic to helpers
Date: Mon, 25 Mar 2019 14:54:28 -0700 [thread overview]
Message-ID: <20190325145428.b826c281daa7f5cd1f110efe@linux-foundation.org> (raw)
In-Reply-To: <20190325210748.6571-3-ynorov@marvell.com>
On Tue, 26 Mar 2019 00:07:44 +0300 Yury Norov <yury.norov@gmail.com> wrote:
> --- a/lib/bitmap.c
> +++ b/lib/bitmap.c
> @@ -477,6 +477,42 @@ int bitmap_print_to_pagebuf(bool list, char *buf, const unsigned long *maskp,
> }
> EXPORT_SYMBOL(bitmap_print_to_pagebuf);
>
> +/*
> + * Region 9-38:4/10 describes the following bitmap structure:
> + * 0 9 12 18 38
> + * .........****......****......****......
> + * ^ ^ ^ ^
> + * start off grlen end
> + */
> +struct region {
> + unsigned int start;
> + unsigned int off;
> + unsigned int grlen;
> + unsigned int end;
> +};
grlen means... group_len, I think?
Perhaps it should be called group_len ;)
next prev parent reply other threads:[~2019-03-25 21:54 UTC|newest]
Thread overview: 14+ messages / expand[flat|nested] mbox.gz Atom feed top
2019-03-25 21:07 [PATCH v2 RESEND 0/6] lib: rework bitmap_parselist and tests Yury Norov
2019-03-25 21:07 ` [PATCH 1/6] bitmap_parselist: don't calculate length of the input string Yury Norov
2019-03-26 10:09 ` Andy Shevchenko
2019-03-25 21:07 ` [PATCH 2/6] bitmap_parselist: move non-parser logic to helpers Yury Norov
2019-03-25 21:54 ` Andrew Morton [this message]
2019-03-25 21:07 ` [PATCH 3/6] bitmap_parselist: rework input string parser Yury Norov
2019-03-26 10:10 ` Andy Shevchenko
2019-03-26 21:09 ` Yuri Norov
2019-03-26 21:58 ` Mike Travis
2019-03-25 21:07 ` [PATCH 4/6] lib/test_bitmap: switch test_bitmap_parselist to ktime_get() Yury Norov
2019-03-25 21:07 ` [PATCH 5/6] lib/test_bitmap: add testcases for bitmap_parselist Yury Norov
2019-03-25 21:07 ` [PATCH 6/6] lib/test_bitmap: add tests for bitmap_parselist_user Yury Norov
2019-03-26 10:12 ` Andy Shevchenko
-- strict thread matches above, loose matches on Subject: below --
2019-02-20 8:36 [PATCH v2 0/5] lib: rework bitmap_parselist and tests Yury Norov
2019-02-20 8:37 ` [PATCH 2/6] bitmap_parselist: move non-parser logic to helpers Yury Norov
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=20190325145428.b826c281daa7f5cd1f110efe@linux-foundation.org \
--to=akpm@linux-foundation.org \
--cc=andriy.shevchenko@linux.intel.com \
--cc=arnd@arndb.de \
--cc=keescook@chromium.org \
--cc=linux-kernel@vger.kernel.org \
--cc=linux@rasmusvillemoes.dk \
--cc=penguin-kernel@I-love.SAKURA.ne.jp \
--cc=willy@infradead.org \
--cc=ynorov@marvell.com \
--cc=yury.norov@gmail.com \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
Powered by JetHome