From: helgaas@kernel.org
To: "Rafael J. Wysocki" <rjw@rjwysocki.net>,
Len Brown <lenb@kernel.org>,
linux-acpi@vger.kernel.org, linux-kernel@vger.kernel.org
Cc: Bjorn Helgaas <bhelgaas@google.com>
Subject: [PATCH 4/4] ACPI / scan: Add labels for PNP button devices
Date: Mon, 25 Mar 2019 13:34:03 -0500 [thread overview]
Message-ID: <20190325183403.251473-5-helgaas@kernel.org> (raw)
In-Reply-To: <20190325183403.251473-1-helgaas@kernel.org>
From: Bjorn Helgaas <bhelgaas@google.com>
Subsequent code treats button_device_ids[] entries differently, and it's
hard to follow without a hint as to which is which. Add comments to
identify the power button, lid, and sleep button devices.
The "PNP" prefix is owned by Microsoft, so they distribute the canonical
list of "PNP" IDs.
Link: https://uefi.org/PNP_ACPI_Registry
Link: https://download.microsoft.com/download/1/6/1/161ba512-40e2-4cc9-843a-923143f3456c/devids.txt
Signed-off-by: Bjorn Helgaas <bhelgaas@google.com>
---
drivers/acpi/scan.c | 6 +++---
1 file changed, 3 insertions(+), 3 deletions(-)
diff --git a/drivers/acpi/scan.c b/drivers/acpi/scan.c
index f3b40299a641..814a02568d68 100644
--- a/drivers/acpi/scan.c
+++ b/drivers/acpi/scan.c
@@ -846,9 +846,9 @@ static int acpi_bus_extract_wakeup_device_power_package(struct acpi_device *dev)
static bool acpi_wakeup_gpe_init(struct acpi_device *device)
{
static const struct acpi_device_id button_device_ids[] = {
- {"PNP0C0C", 0},
- {"PNP0C0D", 0},
- {"PNP0C0E", 0},
+ {"PNP0C0C", 0}, /* Power button */
+ {"PNP0C0D", 0}, /* Lid */
+ {"PNP0C0E", 0}, /* Sleep button */
{"", 0},
};
struct acpi_device_wakeup *wakeup = &device->wakeup;
--
2.21.0.392.gf8f6787159e-goog
prev parent reply other threads:[~2019-03-25 18:34 UTC|newest]
Thread overview: 5+ messages / expand[flat|nested] mbox.gz Atom feed top
2019-03-25 18:33 [PATCH 0/4] ACPI: Trivial cleanups helgaas
2019-03-25 18:34 ` [PATCH 1/4] ACPI: Fix comment typos helgaas
2019-03-25 18:34 ` [PATCH 2/4] ACPI / tables: Cleanup whitespace helgaas
2019-03-25 18:34 ` [PATCH 3/4] ACPI / scan: Simplify acpi_bus_extract_wakeup_device_power_package() helgaas
2019-03-25 18:34 ` helgaas [this message]
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=20190325183403.251473-5-helgaas@kernel.org \
--to=helgaas@kernel.org \
--cc=bhelgaas@google.com \
--cc=lenb@kernel.org \
--cc=linux-acpi@vger.kernel.org \
--cc=linux-kernel@vger.kernel.org \
--cc=rjw@rjwysocki.net \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
all inboxes | Powered by JetHome®