From mboxrd@z Thu Jan 1 00:00:00 1970 Return-Path: X-Spam-Checker-Version: SpamAssassin 3.4.0 (2014-02-07) on aws-us-west-2-korg-lkml-1.web.codeaurora.org X-Spam-Level: X-Spam-Status: No, score=-2.5 required=3.0 tests=HEADER_FROM_DIFFERENT_DOMAINS, MAILING_LIST_MULTI,SPF_PASS,USER_AGENT_MUTT autolearn=ham autolearn_force=no version=3.4.0 Received: from mail.kernel.org (mail.kernel.org [198.145.29.99]) by smtp.lore.kernel.org (Postfix) with ESMTP id 4B68EC10F13 for ; Tue, 9 Apr 2019 02:05:44 +0000 (UTC) Received: from vger.kernel.org (vger.kernel.org [209.132.180.67]) by mail.kernel.org (Postfix) with ESMTP id 2278521473 for ; Tue, 9 Apr 2019 02:05:44 +0000 (UTC) Received: (majordomo@vger.kernel.org) by vger.kernel.org via listexpand id S1726913AbfDICFm (ORCPT ); Mon, 8 Apr 2019 22:05:42 -0400 Received: from mga05.intel.com ([192.55.52.43]:2179 "EHLO mga05.intel.com" rhost-flags-OK-OK-OK-OK) by vger.kernel.org with ESMTP id S1726133AbfDICFm (ORCPT ); Mon, 8 Apr 2019 22:05:42 -0400 X-Amp-Result: UNKNOWN X-Amp-Original-Verdict: FILE UNKNOWN X-Amp-File-Uploaded: False Received: from orsmga001.jf.intel.com ([10.7.209.18]) by fmsmga105.fm.intel.com with ESMTP/TLS/DHE-RSA-AES256-GCM-SHA384; 08 Apr 2019 19:05:42 -0700 X-ExtLoop1: 1 X-IronPort-AV: E=Sophos;i="5.60,327,1549958400"; d="scan'208";a="221741995" Received: from ranerica-svr.sc.intel.com ([172.25.110.23]) by orsmga001.jf.intel.com with ESMTP; 08 Apr 2019 19:05:41 -0700 Date: Mon, 8 Apr 2019 19:04:32 -0700 From: Ricardo Neri To: Thomas Gleixner Cc: Ingo Molnar , Borislav Petkov , Ashok Raj , Andi Kleen , Peter Zijlstra , "Ravi V. Shankar" , x86@kernel.org, linux-kernel@vger.kernel.org, Ricardo Neri , "H. Peter Anvin" , Tony Luck , Clemens Ladisch , Arnd Bergmann , Philippe Ombredanne , Kate Stewart , "Rafael J. Wysocki" Subject: Re: [RFC PATCH v2 05/14] x86/hpet: Relocate flag definitions to a header file Message-ID: <20190409020432.GA7102@ranerica-svr.sc.intel.com> References: <1551283518-18922-1-git-send-email-ricardo.neri-calderon@linux.intel.com> <1551283518-18922-6-git-send-email-ricardo.neri-calderon@linux.intel.com> MIME-Version: 1.0 Content-Type: text/plain; charset=us-ascii Content-Disposition: inline In-Reply-To: User-Agent: Mutt/1.9.4 (2018-02-28) Sender: linux-kernel-owner@vger.kernel.org Precedence: bulk List-ID: X-Mailing-List: linux-kernel@vger.kernel.org On Tue, Mar 26, 2019 at 10:11:16PM +0100, Thomas Gleixner wrote: > On Wed, 27 Feb 2019, Ricardo Neri wrote: > > > Users of HPET timers (such as the hardlockup detector) need the definitions > > of these flags to interpret the configuration of a timer as passed by > > platform code. > > Which platform code? Sorry, it is not platform code. Shall I call it the HPET-enabling code? > > > +#define HPET_DEV_USED_BIT 2 > > +#define HPET_DEV_USED (1 << HPET_DEV_USED_BIT) > > +#define HPET_DEV_VALID 0x8 > > +#define HPET_DEV_FSB_CAP 0x1000 > > +#define HPET_DEV_PERI_CAP 0x2000 > > I'm not seing why you would need any of those in the watchdog code. > > The only function related to the watchdog which needs these is > hpet_hardlockup_detector_assign_timer() and that is located in hpet.c > itself. Yes, I see now that it is not needed. This patch can be removed. Thanks and BR, Ricardo