From: Ingo Molnar <mingo@kernel.org>
To: Len Brown <lenb@kernel.org>
Cc: X86 ML <x86@kernel.org>,
linux-kernel@vger.kernel.org,
Kan Liang <kan.liang@linux.intel.com>,
Peter Zijlstra <peterz@infradead.org>,
Len Brown <len.brown@intel.com>,
Thomas Gleixner <tglx@linutronix.de>
Subject: Re: [PATCH 17/18] perf/x86/intel/rapl: Support multi-die/package
Date: Mon, 6 May 2019 21:49:36 +0200 [thread overview]
Message-ID: <20190506194936.GA23707@gmail.com> (raw)
In-Reply-To: <CAJvTdKnZhyk_aWjQP_dtnNjvV75MvXBEmXUjH=K0hu2Kb77pYQ@mail.gmail.com>
* Len Brown <lenb@kernel.org> wrote:
> On Mon, May 6, 2019 at 7:48 AM Ingo Molnar <mingo@kernel.org> wrote:
>
> > > - unsigned int pkgid = topology_logical_package_id(cpu);
> > > + unsigned int pkgid = topology_logical_die_id(cpu);
>
> > There's many such instances left in this series, please review the whole
> > patchset for such problems.
>
> I agree, the legacy names make the code read as if it were a bug, even
> when it is correct.
> I'll refresh the series with some re-names to make the end result ready clearly.
Thanks a lot!
Ingo
next prev parent reply other threads:[~2019-05-06 19:49 UTC|newest]
Thread overview: 23+ messages / expand[flat|nested] mbox.gz Atom feed top
2019-05-01 4:24 [PATCH 0/18] v4 multi-die/package topology support Len Brown
2019-05-01 4:24 ` [PATCH 01/18] x86 topology: Fix doc typo Len Brown
2019-05-01 4:24 ` [PATCH 02/18] topology: Simplify cputopology.txt formatting and wording Len Brown
2019-05-01 4:24 ` [PATCH 03/18] x86 smpboot: Rename match_die() to match_pkg() Len Brown
2019-05-01 4:24 ` [PATCH 04/18] x86 topology: Add CPUID.1F multi-die/package support Len Brown
2019-05-01 4:24 ` [PATCH 05/18] x86 topology: Create topology_max_die_per_package() Len Brown
2019-05-01 4:24 ` [PATCH 06/18] cpu topology: Export die_id Len Brown
2019-05-01 4:24 ` [PATCH 07/18] x86 topology: Define topology_die_id() Len Brown
2019-05-01 4:24 ` [PATCH 08/18] x86 topology: Define topology_logical_die_id() Len Brown
2019-05-01 4:24 ` [PATCH 09/18] powercap/intel_rapl: Simplify rapl_find_package() Len Brown
2019-05-01 4:24 ` [PATCH 10/18] powercap/intel_rapl: Support multi-die/package Len Brown
2019-05-01 4:24 ` [PATCH 11/18] thermal/x86_pkg_temp_thermal: " Len Brown
2019-05-01 4:24 ` [PATCH 12/18] powercap/intel_rapl: update rapl domain name and debug messages Len Brown
2019-05-01 4:24 ` [PATCH 13/18] hwmon/coretemp: Support multi-die/package Len Brown
2019-05-04 2:58 ` Len Brown
2019-05-01 4:24 ` [PATCH 14/18] topology: Create package_cpus sysfs attribute Len Brown
2019-05-01 4:24 ` [PATCH 15/18] topology: Create core_cpus and die_cpus sysfs attributes Len Brown
2019-05-01 4:24 ` [PATCH 16/18] perf/x86/intel/uncore: Support multi-die/package Len Brown
2019-05-01 4:24 ` [PATCH 17/18] perf/x86/intel/rapl: " Len Brown
2019-05-06 11:48 ` Ingo Molnar
2019-05-06 17:28 ` Len Brown
2019-05-06 19:49 ` Ingo Molnar [this message]
2019-05-01 4:24 ` [PATCH 18/18] perf/x86/intel/cstate: " Len Brown
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=20190506194936.GA23707@gmail.com \
--to=mingo@kernel.org \
--cc=kan.liang@linux.intel.com \
--cc=len.brown@intel.com \
--cc=lenb@kernel.org \
--cc=linux-kernel@vger.kernel.org \
--cc=peterz@infradead.org \
--cc=tglx@linutronix.de \
--cc=x86@kernel.org \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
Powered by JetHome