From: Andrew Morton <akpm@linux-foundation.org>
To: Matteo Croce <mcroce@redhat.com>
Cc: Alexey Dobriyan <adobriyan@gmail.com>,
LKML <linux-kernel@vger.kernel.org>,
Kees Cook <keescook@chromium.org>,
Aaron Tomlin <atomlin@redhat.com>
Subject: Re: [PATCH] proc/sysctl: add shared variables for range check
Date: Tue, 2 Jul 2019 13:13:48 -0700 [thread overview]
Message-ID: <20190702131348.9004db6da7e1cbeb7db5ca9f@linux-foundation.org> (raw)
In-Reply-To: <CAGnkfhxPhHxmNFCMHj8QTYKtLi08O8C5-6Qua8zRz4FX=8g+pw@mail.gmail.com>
On Tue, 2 Jul 2019 19:21:33 +0200 Matteo Croce <mcroce@redhat.com> wrote:
> On Tue, Jul 2, 2019 at 7:13 PM Alexey Dobriyan <adobriyan@gmail.com> wrote:
> >
> > > -static long zero;
> > > static long long_max = LONG_MAX;
> > >
> > > struct ctl_table epoll_table[] = {
> > > @@ -301,7 +300,7 @@ struct ctl_table epoll_table[] = {
> > > .maxlen = sizeof(max_user_watches),
> > > .mode = 0644,
> > > .proc_handler = proc_doulongvec_minmax,
> > > - .extra1 = &zero,
> > > + .extra1 = SYSCTL_ZERO,
> > > .extra2 = &long_max,
> >
> > This looks wrong: proc_doulongvec_minmax() expects "long"s.
> > The whole patch needs rechecking.
> >
> > > +/* shared constants to be used in various sysctls */
> > > +const =======>int<========== sysctl_vals[] = { 0, 1, INT_MAX };
> > > +EXPORT_SYMBOL(sysctl_vals);
>
> Yes, you're right, that chunk must be dropped.
> Anyway I've checked the patch, this was the only long field touched.
Yup.
akpm3:/usr/src/25> find . -name "*.c" | xargs grep -C4 SYSCTL_ZERO|grep long
./fs/eventpoll.c- .proc_handler = proc_doulongvec_minmax,
./fs/eventpoll.c- .extra2 = &long_max,
I did this:
--- a/fs/eventpoll.c~proc-sysctl-add-shared-variables-for-range-check-fix-4
+++ a/fs/eventpoll.c
@@ -291,6 +291,7 @@ static LIST_HEAD(tfile_check_list);
#include <linux/sysctl.h>
+static long long_zero;
static long long_max = LONG_MAX;
struct ctl_table epoll_table[] = {
@@ -300,7 +301,7 @@ struct ctl_table epoll_table[] = {
.maxlen = sizeof(max_user_watches),
.mode = 0644,
.proc_handler = proc_doulongvec_minmax,
- .extra1 = SYSCTL_ZERO,
+ .extra1 = &long_zero,
.extra2 = &long_max,
},
{ }
I renamed it to avoid using "&zero," in this situation.
prev parent reply other threads:[~2019-07-03 1:03 UTC|newest]
Thread overview: 3+ messages / expand[flat|nested] mbox.gz Atom feed top
2019-07-02 17:12 Alexey Dobriyan
2019-07-02 17:21 ` Matteo Croce
2019-07-02 20:13 ` Andrew Morton [this message]
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=20190702131348.9004db6da7e1cbeb7db5ca9f@linux-foundation.org \
--to=akpm@linux-foundation.org \
--cc=adobriyan@gmail.com \
--cc=atomlin@redhat.com \
--cc=keescook@chromium.org \
--cc=linux-kernel@vger.kernel.org \
--cc=mcroce@redhat.com \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
all inboxes | Powered by JetHome®