mirror of https://lore.kernel.org/lkml/
 help / color / mirror / Atom feed
From: Mark Brown <broonie@kernel.org>
To: "Michał Mirosław" <mirq-linux@rere.qmqm.pl>
Cc: linux-kernel@vger.kernel.org, Liam Girdwood <lgirdwood@gmail.com>
Subject: Re: [PATCH] regulator: act8865: support regulator-pull-down property
Date: Tue, 23 Jul 2019 15:39:52 +0100	[thread overview]
Message-ID: <20190723143952.GG5365@sirena.org.uk> (raw)
In-Reply-To: <20190723120938.GC14036@qmqm.qmqm.pl>

[-- Attachment #1: Type: text/plain, Size: 1180 bytes --]

On Tue, Jul 23, 2019 at 02:09:38PM +0200, Michał Mirosław wrote:
> On Tue, Jul 23, 2019 at 11:54:32AM +0100, Mark Brown wrote:
> > On Mon, Jul 22, 2019 at 08:13:29PM +0200, Michał Mirosław wrote:
> > > AC8865 has internal 1.5k pull-down resistor that can be enabled when LDO
> > > is shut down.

> > This changelog...

> > >  static const struct regulator_ops act8865_ldo_ops = {
> > > +	.list_voltage		= regulator_list_voltage_linear_range,
> > > +	.map_voltage		= regulator_map_voltage_linear_range,
> > > +	.get_voltage_sel	= regulator_get_voltage_sel_regmap,
> > > +	.set_voltage_sel	= regulator_set_voltage_sel_regmap,

> > ...doesn't obviously match this code change which looks to be
> > implementing voltage setting (as well as the pull down stuff but still).

> It's just an diff-artifact of changing act8865_ldo_ops meaning. It's
> now a copy of act8865_ops with .set_pull_down added. Previous
> act8865_ldo_ops is act8865_fixed_ldo_ops now.

If there's that big a refactoring it probably warrants a separate patch,
and it definitely should be called out in the changelog.  Like I say the
changbelog does not describe the change at all well.

[-- Attachment #2: signature.asc --]
[-- Type: application/pgp-signature, Size: 488 bytes --]

      reply	other threads:[~2019-07-23 14:39 UTC|newest]

Thread overview: 4+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2019-07-22 18:13 Michał Mirosław
2019-07-23 10:54 ` Mark Brown
2019-07-23 12:09   ` Michał Mirosław
2019-07-23 14:39     ` Mark Brown [this message]

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=20190723143952.GG5365@sirena.org.uk \
    --to=broonie@kernel.org \
    --cc=lgirdwood@gmail.com \
    --cc=linux-kernel@vger.kernel.org \
    --cc=mirq-linux@rere.qmqm.pl \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox

all inboxes | Powered by JetHome®