From: "Paul E. McKenney" <paulmck@linux.ibm.com>
To: rcu@vger.kernel.org
Cc: linux-kernel@vger.kernel.org, mingo@kernel.org,
jiangshanlai@gmail.com, dipankar@in.ibm.com,
akpm@linux-foundation.org, mathieu.desnoyers@efficios.com,
josh@joshtriplett.org, tglx@linutronix.de, peterz@infradead.org,
rostedt@goodmis.org, dhowells@redhat.com, edumazet@google.com,
fweisbec@gmail.com, oleg@redhat.com, joel@joelfernandes.org
Subject: [PATCH tip/core/rcu 0/8] RCU list-traversal lockdep updates for v5.4
Date: Thu, 1 Aug 2019 15:42:40 -0700 [thread overview]
Message-ID: <20190801224240.GA16092@linux.ibm.com> (raw)
Hello!
This series provides enhancements to RCU pointer and list macros, all
courtesy of Joel Fernandes:
1. Rename rcu_dereference_raw_notrace() to _check().
2. Remove redundant debug_locks check in rcu_read_lock_sched_held().
3. Add support for consolidated-RCU reader checking.
4. Remove custom check for RCU readers.
5. Add lockdep condition to fix for_each_entry().
6. Convert to use built-in RCU list checking.
7. Pass lockdep condition to pcm_mmcfg_list iterator.
8. Use built-in RCU list checking for acpi_ioremaps list.
Thanx, Paul
------------------------------------------------------------------------
Documentation/RCU/Design/Requirements/Requirements.html | 2
arch/powerpc/include/asm/kvm_book3s_64.h | 2
arch/x86/pci/mmconfig-shared.c | 5 -
drivers/acpi/osl.c | 6 -
drivers/base/base.h | 1
drivers/base/core.c | 10 ++
drivers/base/power/runtime.c | 15 ++-
include/linux/rcu_sync.h | 4
include/linux/rculist.h | 38 +++++++--
include/linux/rcupdate.h | 9 +-
kernel/rcu/Kconfig.debug | 11 ++
kernel/rcu/update.c | 67 ++++++++++------
kernel/trace/ftrace_internal.h | 8 -
kernel/trace/trace.c | 4
net/ipv4/fib_frontend.c | 3
15 files changed, 132 insertions(+), 53 deletions(-)
next reply other threads:[~2019-08-01 22:43 UTC|newest]
Thread overview: 9+ messages / expand[flat|nested] mbox.gz Atom feed top
2019-08-01 22:42 Paul E. McKenney [this message]
2019-08-01 22:42 ` [PATCH tip/core/rcu 1/8] treewide: Rename rcu_dereference_raw_notrace() to _check() Paul E. McKenney
2019-08-01 22:42 ` [PATCH tip/core/rcu 2/8] rcu: Remove redundant debug_locks check in rcu_read_lock_sched_held() Paul E. McKenney
2019-08-01 22:42 ` [PATCH tip/core/rcu 3/8] rcu: Add support for consolidated-RCU reader checking Paul E. McKenney
2019-08-01 22:42 ` [PATCH tip/core/rcu 4/8] rcu/sync: Remove custom check for RCU readers Paul E. McKenney
2019-08-01 22:42 ` [PATCH tip/core/rcu 5/8] ipv4: Add lockdep condition to fix for_each_entry() Paul E. McKenney
2019-08-01 22:42 ` [PATCH tip/core/rcu 6/8] driver/core: Convert to use built-in RCU list checking Paul E. McKenney
2019-08-01 22:42 ` [PATCH tip/core/rcu 7/8] x86/pci: Pass lockdep condition to pcm_mmcfg_list iterator Paul E. McKenney
2019-08-01 22:42 ` [PATCH tip/core/rcu 8/8] acpi: Use built-in RCU list checking for acpi_ioremaps list Paul E. McKenney
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=20190801224240.GA16092@linux.ibm.com \
--to=paulmck@linux.ibm.com \
--cc=akpm@linux-foundation.org \
--cc=dhowells@redhat.com \
--cc=dipankar@in.ibm.com \
--cc=edumazet@google.com \
--cc=fweisbec@gmail.com \
--cc=jiangshanlai@gmail.com \
--cc=joel@joelfernandes.org \
--cc=josh@joshtriplett.org \
--cc=linux-kernel@vger.kernel.org \
--cc=mathieu.desnoyers@efficios.com \
--cc=mingo@kernel.org \
--cc=oleg@redhat.com \
--cc=peterz@infradead.org \
--cc=rcu@vger.kernel.org \
--cc=rostedt@goodmis.org \
--cc=tglx@linutronix.de \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
Powered by JetHome