mirror of https://lore.kernel.org/lkml/
 help / color / mirror / Atom feed
From: Dmitry Torokhov <dmitry.torokhov@gmail.com>
To: "Rafael J. Wysocki" <rafael@kernel.org>,
	Heikki Krogerus <heikki.krogerus@linux.intel.com>
Cc: Andy Shevchenko <andriy.shevchenko@linux.intel.com>,
	Linus Walleij <linus.walleij@linaro.org>,
	linux-kernel@vger.kernel.org,
	platform-driver-x86@vger.kernel.org
Subject: [PATCH v3 00/13] software node: add support for reference properties
Date: Mon,  9 Sep 2019 01:15:44 -0700	[thread overview]
Message-ID: <20190909081557.93766-1-dmitry.torokhov@gmail.com> (raw)

These series implement "references" properties for software nodes as true
properties, instead of managing them completely separately.

The first 10 patches are generic cleanups and consolidation and unification
of the existing code; patch #11 implements PROPERTY_EMTRY_REF() and friends;
patch #12 converts the user of references to the property syntax, and patch
#13 removes the remains of references as entities that are managed
separately.

Changes in v3:
- added various cleanups before implementing reference properties

Changes in v2:
- reworked code so that even single-entry reference properties are
  stored as arrays (i.e. the software_node_ref_args instances are
  not part of property_entry structure) to avoid size increase.
  From user's POV nothing is changed, one can still use PROPERTY_ENTRY_REF
  macro to define reference "inline".
- dropped unused DEV_PROP_MAX
- rebased on linux-next

Dmitry Torokhov (13):
  software node: remove DEV_PROP_MAX
  software node: clean up property_copy_string_array()
  software node: get rid of property_set_pointer()
  software node: simplify property_get_pointer()
  software node: remove property_entry_read_uNN_array functions
  software node: unify PROPERTY_ENTRY_XXX macros
  software node: simplify property_entry_read_string_array()
  software node: introduce PROPERTY_ENTRY_ARRAY_XXX_LEN()
  efi/apple-properties: use PROPERTY_ENTRY_U8_ARRAY_LEN
  software node: rename is_array to is_inline
  software node: implement reference properties
  platform/x86: intel_cht_int33fe: use inline reference properties
  software node: remove separate handling of references

 drivers/base/swnode.c                    | 243 +++++++----------------
 drivers/firmware/efi/apple-properties.c  |   8 +-
 drivers/platform/x86/intel_cht_int33fe.c |  81 ++++----
 include/linux/property.h                 | 154 +++++++-------
 4 files changed, 198 insertions(+), 288 deletions(-)

-- 
2.23.0.187.g17f5b7556c-goog


             reply	other threads:[~2019-09-09  8:16 UTC|newest]

Thread overview: 20+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2019-09-09  8:15 Dmitry Torokhov [this message]
2019-09-09  8:15 ` [PATCH v3 01/13] software node: remove DEV_PROP_MAX Dmitry Torokhov
2019-09-09  9:46   ` Andy Shevchenko
2019-09-09  8:15 ` [PATCH v3 02/13] software node: clean up property_copy_string_array() Dmitry Torokhov
2019-09-09  8:15 ` [PATCH v3 03/13] software node: get rid of property_set_pointer() Dmitry Torokhov
2019-09-09  9:55   ` Andy Shevchenko
2019-09-09 10:15     ` Dmitry Torokhov
2019-09-09 11:36       ` Andy Shevchenko
2019-09-09 13:48         ` Dmitry Torokhov
2019-09-09  8:15 ` [PATCH v3 04/13] software node: simplify property_get_pointer() Dmitry Torokhov
2019-09-09  8:15 ` [PATCH v3 05/13] software node: remove property_entry_read_uNN_array functions Dmitry Torokhov
2019-09-09  8:15 ` [PATCH v3 06/13] software node: unify PROPERTY_ENTRY_XXX macros Dmitry Torokhov
2019-09-09  8:15 ` [PATCH v3 07/13] software node: simplify property_entry_read_string_array() Dmitry Torokhov
2019-09-09  8:15 ` [PATCH v3 08/13] software node: introduce PROPERTY_ENTRY_ARRAY_XXX_LEN() Dmitry Torokhov
2019-09-09  8:15 ` [PATCH v3 09/13] efi/apple-properties: use PROPERTY_ENTRY_U8_ARRAY_LEN Dmitry Torokhov
2019-09-09  8:15 ` [PATCH v3 10/13] software node: rename is_array to is_inline Dmitry Torokhov
2019-09-09  8:15 ` [PATCH v3 11/13] software node: implement reference properties Dmitry Torokhov
2019-09-09  8:15 ` [PATCH v3 12/13] platform/x86: intel_cht_int33fe: use inline " Dmitry Torokhov
2019-09-09  8:15 ` [PATCH v3 13/13] software node: remove separate handling of references Dmitry Torokhov
2019-10-11  9:20 ` [PATCH v3 00/13] software node: add support for reference properties Rafael J. Wysocki

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=20190909081557.93766-1-dmitry.torokhov@gmail.com \
    --to=dmitry.torokhov@gmail.com \
    --cc=andriy.shevchenko@linux.intel.com \
    --cc=heikki.krogerus@linux.intel.com \
    --cc=linus.walleij@linaro.org \
    --cc=linux-kernel@vger.kernel.org \
    --cc=platform-driver-x86@vger.kernel.org \
    --cc=rafael@kernel.org \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox

Powered by JetHome