mirror of https://lore.kernel.org/lkml/
 help / color / mirror / Atom feed
From: Vinod Koul <vkoul@kernel.org>
To: Elliot Berman <eberman@codeaurora.org>
Cc: bjorn.andersson@linaro.org, saiprakash.ranjan@codeaurora.org,
	agross@kernel.org, tsoni@codeaurora.org, sidgup@codeaurora.org,
	psodagud@codeaurora.org, linux-arm-msm@vger.kernel.org,
	linux-kernel@vger.kernel.org
Subject: Re: [PATCH 01/17] firmware: qcom_scm: Rename macros and structures
Date: Thu, 7 Nov 2019 21:52:24 +0530	[thread overview]
Message-ID: <20191107162224.GN952516@vkoul-mobl> (raw)
In-Reply-To: <1572917256-24205-2-git-send-email-eberman@codeaurora.org>

On 04-11-19, 17:27, Elliot Berman wrote:
> - Rename legacy-specific structures and macros with "legacy_" prefix.
> - Rename smccc-specific structures and macros with "smccc_" prefix.
> - Flip calculation of SMCCC_N_EXT_ARGS to be a function of N_REG_ARGS
>   (not the other way around). N_REG_ARGS is fixed based off the SMC
>   instruction and shouldn't be computed from the SCM abstraction.
> - Move SMCCC_FUNCNUM closer to other smccc-specific macros.
> - Add LEGACY_FUNCNUM macro to qcom_scm-32.c

My preference is one change per patch :) That also makes it easier to
review!

> +#define LEGACY_FUNCNUM(s, c)  (((s) << 10) | ((c) & 0x3ff))
> +
>  /**
> - * struct qcom_scm_command - one SCM command buffer
> + * struct legacy_command - one SCM command buffer

can we keep the qcom_ tag in this?

>  /**
> - * struct qcom_scm_response - one SCM response buffer
> + * struct legacy_response - one SCM response buffer
>   * @len: total available memory for response
> - * @buf_offset: start of response data relative to start of qcom_scm_response
> + * @buf_offset: start of response data relative to start of legacy_response
>   * @is_complete: indicates if the command has finished processing
>   */
> -struct qcom_scm_response {
> +struct legacy_response {

here as well

> diff --git a/drivers/firmware/qcom_scm.c b/drivers/firmware/qcom_scm.c
> index a729e05..40222b1 100644
> --- a/drivers/firmware/qcom_scm.c
> +++ b/drivers/firmware/qcom_scm.c
> @@ -1,8 +1,6 @@
>  // SPDX-License-Identifier: GPL-2.0-only
>  /*
> - * Qualcomm SCM driver
> - *
> - * Copyright (c) 2010,2015, The Linux Foundation. All rights reserved.
> + * Copyright (c) 2010,2015,2019 The Linux Foundation. All rights reserved.
>   * Copyright (C) 2015 Linaro Ltd.

I don't feel this belongs to this patch, please move it to patch
touching this file

-- 
~Vinod

  reply	other threads:[~2019-11-07 16:22 UTC|newest]

Thread overview: 34+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2019-11-05  1:27 [PATCH 00/17] Restructure, improve target support for qcom_scm driver Elliot Berman
2019-11-05  1:27 ` [PATCH 01/17] firmware: qcom_scm: Rename macros and structures Elliot Berman
2019-11-07 16:22   ` Vinod Koul [this message]
2019-11-05  1:27 ` [PATCH 02/17] firmware: qcom_scm: Apply consistent naming scheme to command IDs Elliot Berman
2019-11-06  6:02   ` Bjorn Andersson
2019-11-07 16:42   ` Vinod Koul
2019-11-05  1:27 ` [PATCH 03/17] firmware: qcom_scm: Order functions, definitions by service/command Elliot Berman
2019-11-06  6:05   ` Bjorn Andersson
2019-11-07 16:50   ` Vinod Koul
2019-11-08 22:03   ` Bjorn Andersson
2019-11-05  1:27 ` [PATCH 04/17] firmware: qcom_scm: Remove unused qcom_scm_get_version Elliot Berman
2019-11-06  6:06   ` Bjorn Andersson
2019-11-08  4:36   ` Vinod Koul
2019-11-05  1:27 ` [PATCH 05/17] firmware: qcom_scm-64: Move svc/cmd/owner into qcom_scm_desc Elliot Berman
2019-11-08  6:04   ` Vinod Koul
2019-11-05  1:27 ` [PATCH 06/17] firmware: qcom_scm-64: Add SCM results to descriptor Elliot Berman
2019-11-08  6:09   ` Vinod Koul
2019-11-05  1:27 ` [PATCH 07/17] firmware: qcom_scm-64: Remove qcom_scm_call_do_smccc Elliot Berman
2019-11-05  1:27 ` [PATCH 08/17] firmware: qcom_scm-64: Move SMC register filling to qcom_scm_call_smccc Elliot Berman
2019-11-05  1:27 ` [PATCH 09/17] firmware: qcom_scm-64: Improve SMC convention detection Elliot Berman
2019-11-07 19:18   ` Bjorn Andersson
2019-11-07 20:20     ` eberman
2019-11-07 23:44       ` Bjorn Andersson
2019-11-05  1:27 ` [PATCH 10/17] firmware: qcom_scm-32: Use SMC arch wrappers Elliot Berman
2019-11-08  0:05   ` Bjorn Andersson
2019-11-05  1:27 ` [PATCH 11/17] firmware: qcom_scm-32: Use qcom_scm_desc in non-atomic calls Elliot Berman
2019-11-05  1:27 ` [PATCH 12/17] firmware: qcom_scm-32: Move SMCCC register filling to qcom_scm_call Elliot Berman
2019-11-05  1:27 ` [PATCH 13/17] firmware: qcom_scm-32: Create common legacy atomic call Elliot Berman
2019-11-05  1:27 ` [PATCH 14/17] firmware: qcom_scm-32: Add device argument to atomic calls Elliot Berman
2019-11-05  1:27 ` [PATCH 15/17] firmware: qcom_scm: Merge legacy and SMCCC conventions Elliot Berman
2019-11-05  1:27 ` [PATCH 16/17] firmware: qcom_scm: Enable legacy calling convention in qcom_scm-64.c Elliot Berman
2019-11-05  1:27 ` [PATCH 17/17] firmware: qcom_scm: Rename -64 -> -smc, remove -32 Elliot Berman
2019-11-08  0:20   ` Bjorn Andersson
2019-11-05  2:14 ` [PATCH 00/17] Restructure, improve target support for qcom_scm driver Sai Prakash Ranjan

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=20191107162224.GN952516@vkoul-mobl \
    --to=vkoul@kernel.org \
    --cc=agross@kernel.org \
    --cc=bjorn.andersson@linaro.org \
    --cc=eberman@codeaurora.org \
    --cc=linux-arm-msm@vger.kernel.org \
    --cc=linux-kernel@vger.kernel.org \
    --cc=psodagud@codeaurora.org \
    --cc=saiprakash.ranjan@codeaurora.org \
    --cc=sidgup@codeaurora.org \
    --cc=tsoni@codeaurora.org \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox

all inboxes | Powered by JetHome®