From: Dave Chinner <david@fromorbit.com>
To: Deepa Dinamani <deepa.kernel@gmail.com>
Cc: viro@zeniv.linux.org.uk, linux-kernel@vger.kernel.org,
linux-fsdevel@vger.kernel.org, arnd@arndb.de
Subject: Re: [PATCH 7/7] fs: Do not overload update_time
Date: Mon, 2 Dec 2019 07:51:55 +1100 [thread overview]
Message-ID: <20191201205155.GA2418@dread.disaster.area> (raw)
In-Reply-To: <20191130053030.7868-8-deepa.kernel@gmail.com>
On Fri, Nov 29, 2019 at 09:30:30PM -0800, Deepa Dinamani wrote:
> update_time() also has an internal function pointer
> update_time. Even though this works correctly, it is
> confusing to the readers.
>
> Use a different name for the local variable.
>
> Suggested-by: Al Viro <viro@zeniv.linux.org.uk>
> Signed-off-by: Deepa Dinamani <deepa.kernel@gmail.com>
> ---
> fs/inode.c | 6 +++---
> 1 file changed, 3 insertions(+), 3 deletions(-)
>
> diff --git a/fs/inode.c b/fs/inode.c
> index 12c9e38529c9..0be58a680457 100644
> --- a/fs/inode.c
> +++ b/fs/inode.c
> @@ -1675,12 +1675,12 @@ EXPORT_SYMBOL(generic_update_time);
> */
> static int update_time(struct inode *inode, struct timespec64 *time, int flags)
> {
> - int (*update_time)(struct inode *, struct timespec64 *, int);
> + int (*cb)(struct inode *, struct timespec64 *, int);
>
> - update_time = inode->i_op->update_time ? inode->i_op->update_time :
> + cb = inode->i_op->update_time ? inode->i_op->update_time :
> generic_update_time;
>
> - return update_time(inode, time, flags);
> + return cb(inode, time, flags);
What's wrong with a simple if() like we use everywhere else for this
sort of thing?
if (inode->i_op->update_time)
return inode->i_op->update_time(inode, time, flags);
return generic_update_time(inode, time, flags);
-Dave.
--
Dave Chinner
david@fromorbit.com
next prev parent reply other threads:[~2019-12-01 20:52 UTC|newest]
Thread overview: 14+ messages / expand[flat|nested] mbox.gz Atom feed top
2019-11-30 5:30 [PATCH 0/7] Delete timespec64_trunc() Deepa Dinamani
2019-11-30 5:30 ` [PATCH 1/7] fs: fat: Eliminate timespec64_trunc() usage Deepa Dinamani
2019-11-30 5:30 ` [PATCH 2/7] fs: cifs: Fix atime update check vs mtime Deepa Dinamani
2019-12-01 18:23 ` Steve French
2019-11-30 5:30 ` [PATCH 3/7] fs: cifs: Delete usage of timespec64_trunc Deepa Dinamani
2019-11-30 21:25 ` Steve French
2019-12-01 5:35 ` Deepa Dinamani
2019-11-30 5:30 ` [PATCH 4/7] fs: ceph: Delete timespec64_trunc() usage Deepa Dinamani
2019-11-30 5:30 ` [PATCH 5/7] fs: ubifs: Eliminate " Deepa Dinamani
2019-11-30 5:30 ` [PATCH 6/7] fs: Delete timespec64_trunc() Deepa Dinamani
2019-11-30 5:30 ` [PATCH 7/7] fs: Do not overload update_time Deepa Dinamani
2019-12-01 20:51 ` Dave Chinner [this message]
2019-12-02 17:48 ` Christoph Hellwig
2019-12-02 23:13 ` Deepa Dinamani
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=20191201205155.GA2418@dread.disaster.area \
--to=david@fromorbit.com \
--cc=arnd@arndb.de \
--cc=deepa.kernel@gmail.com \
--cc=linux-fsdevel@vger.kernel.org \
--cc=linux-kernel@vger.kernel.org \
--cc=viro@zeniv.linux.org.uk \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
Powered by JetHome