From mboxrd@z Thu Jan 1 00:00:00 1970 Return-Path: X-Spam-Checker-Version: SpamAssassin 3.4.0 (2014-02-07) on aws-us-west-2-korg-lkml-1.web.codeaurora.org X-Spam-Level: X-Spam-Status: No, score=-2.2 required=3.0 tests=HEADER_FROM_DIFFERENT_DOMAINS, MAILING_LIST_MULTI,SPF_HELO_NONE,SPF_PASS,USER_AGENT_SANE_1 autolearn=no autolearn_force=no version=3.4.0 Received: from mail.kernel.org (mail.kernel.org [198.145.29.99]) by smtp.lore.kernel.org (Postfix) with ESMTP id CD3D7C43603 for ; Thu, 5 Dec 2019 18:29:38 +0000 (UTC) Received: from vger.kernel.org (vger.kernel.org [209.132.180.67]) by mail.kernel.org (Postfix) with ESMTP id B43CC22525 for ; Thu, 5 Dec 2019 18:29:38 +0000 (UTC) Received: (majordomo@vger.kernel.org) by vger.kernel.org via listexpand id S1729804AbfLES3d (ORCPT ); Thu, 5 Dec 2019 13:29:33 -0500 Received: from asavdk4.altibox.net ([109.247.116.15]:57490 "EHLO asavdk4.altibox.net" rhost-flags-OK-OK-OK-OK) by vger.kernel.org with ESMTP id S1726028AbfLES3d (ORCPT ); Thu, 5 Dec 2019 13:29:33 -0500 Received: from ravnborg.org (unknown [158.248.194.18]) (using TLSv1.2 with cipher ECDHE-RSA-AES256-GCM-SHA384 (256/256 bits)) (No client certificate requested) by asavdk4.altibox.net (Postfix) with ESMTPS id 8F92380697; Thu, 5 Dec 2019 19:29:29 +0100 (CET) Date: Thu, 5 Dec 2019 19:29:27 +0100 From: Sam Ravnborg To: Mihail Atanassov Cc: "dri-devel@lists.freedesktop.org" , Jernej Skrabec , Neil Armstrong , David Airlie , Daniel Vetter , Jonas Karlman , "linux-kernel@vger.kernel.org" , Laurent Pinchart , nd Subject: Re: [PATCH] drm: Rename drm_bridge->dev to drm Message-ID: <20191205182927.GA27091@ravnborg.org> References: <20191205163028.19941-1-mihail.atanassov@arm.com> MIME-Version: 1.0 Content-Type: text/plain; charset=us-ascii Content-Disposition: inline In-Reply-To: <20191205163028.19941-1-mihail.atanassov@arm.com> User-Agent: Mutt/1.10.1 (2018-07-13) X-CMAE-Score: 0 X-CMAE-Analysis: v=2.3 cv=VcLZwmh9 c=1 sm=1 tr=0 a=UWs3HLbX/2nnQ3s7vZ42gw==:117 a=UWs3HLbX/2nnQ3s7vZ42gw==:17 a=jpOVt7BSZ2e4Z31A5e1TngXxSK0=:19 a=kj9zAlcOel0A:10 a=7gkXJVJtAAAA:8 a=oBCgqzsU5Q40nlY60G0A:9 a=CjuIK1q_8ugA:10 a=E9Po1WZjFZOl8hwRPBS3:22 Sender: linux-kernel-owner@vger.kernel.org Precedence: bulk List-ID: X-Mailing-List: linux-kernel@vger.kernel.org Hi Mihail. On Thu, Dec 05, 2019 at 04:30:45PM +0000, Mihail Atanassov wrote: > The 'dev' name causes some confusion with 'struct device' [1][2], so use > 'drm' instead since this seems to be the prevalent name for 'struct > drm_device' members. Thanks for doing this - it helps readability. checkpatch complained: -:107: CHECK:PARENTHESIS_ALIGNMENT: Alignment should match open parenthesis #107: FILE: drivers/gpu/drm/bridge/nxp-ptn3460.c:251: + ret = drm_connector_init(bridge->drm, &ptn_bridge->connector, &ptn3460_connector_funcs, DRM_MODE_CONNECTOR_LVDS); -:133: CHECK:PARENTHESIS_ALIGNMENT: Alignment should match open parenthesis #133: FILE: drivers/gpu/drm/bridge/parade-ps8622.c:491: + ret = drm_connector_init(bridge->drm, &ps8622->connector, &ps8622_connector_funcs, DRM_MODE_CONNECTOR_LVDS); But this seems unrelated to your changes - so should be ignored. Browsed the patch and throw it after my build check script. All looked good. Acked-by: Sam Ravnborg Sam