mirror of https://lore.kernel.org/lkml/
 help / color / mirror / Atom feed
From: Jakub Kicinski <jakub.kicinski@netronome.com>
To: Matteo Croce <mcroce@redhat.com>
Cc: netdev@vger.kernel.org, Jay Vosburgh <j.vosburgh@gmail.com>,
	Veaceslav Falico <vfalico@gmail.com>,
	Andy Gospodarek <andy@greyhouse.net>,
	linux-kernel@vger.kernel.org
Subject: Re: [PATCH net-next] bonding: don't init workqueues on error
Date: Fri, 13 Dec 2019 18:10:51 -0800	[thread overview]
Message-ID: <20191213181051.0f949b17@cakuba.netronome.com> (raw)
In-Reply-To: <20191210152454.86247-1-mcroce@redhat.com>

On Tue, 10 Dec 2019 16:24:54 +0100, Matteo Croce wrote:
> bond_create() initialize six workqueues used later on.

Work _entries_ not _queues_ no?

> In the unlikely event that the device registration fails, these
> structures are initialized unnecessarily, so move the initialization
> out of the error path. Also, create an error label to remove some
> duplicated code.

Does the initialization of work entries matter? Is this prep for further
changes?

> Signed-off-by: Matteo Croce <mcroce@redhat.com>
> ---
>  drivers/net/bonding/bond_main.c | 11 +++++++----
>  1 file changed, 7 insertions(+), 4 deletions(-)
> 
> diff --git a/drivers/net/bonding/bond_main.c b/drivers/net/bonding/bond_main.c
> index fcb7c2f7f001..8756b6a023d7 100644
> --- a/drivers/net/bonding/bond_main.c
> +++ b/drivers/net/bonding/bond_main.c
> @@ -4889,8 +4889,8 @@ int bond_create(struct net *net, const char *name)
>  				   bond_setup, tx_queues);
>  	if (!bond_dev) {
>  		pr_err("%s: eek! can't alloc netdev!\n", name);

If this is a clean up patch I think this pr_err() could also be removed?
Memory allocation usually fail very loudly so there should be no reason
to print more errors.

> -		rtnl_unlock();
> -		return -ENOMEM;
> +		res = -ENOMEM;
> +		goto out_unlock;
>  	}
>  
>  	/*
> @@ -4905,14 +4905,17 @@ int bond_create(struct net *net, const char *name)
>  	bond_dev->rtnl_link_ops = &bond_link_ops;
>  
>  	res = register_netdevice(bond_dev);
> +	if (res < 0) {
> +		free_netdev(bond_dev);
> +		goto out_unlock;
> +	}
>  
>  	netif_carrier_off(bond_dev);
>  
>  	bond_work_init_all(bond);
>  
> +out_unlock:
>  	rtnl_unlock();
> -	if (res < 0)
> -		free_netdev(bond_dev);
>  	return res;
>  }
>  

I do appreciate that the change makes the error handling follow a more
usual kernel pattern, but IMHO it'd be even better if the error
handling was completely moved. IOW the success path should end with
return 0; and the error path should contain free_netdev(bond_dev);

-	int res;
+	int err;

	[...]

	rtnl_unlock();

	return 0;

err_free_netdev:
	free_netdev(bond_dev);
err_unlock:
	rtnl_unlock();
	return err;

I'm just not 100% sold on the improvement made by this patch being
worth the code churn, please convince me, respin or get an ack from 
one of the maintainers? :)

  reply	other threads:[~2019-12-14  2:11 UTC|newest]

Thread overview: 3+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2019-12-10 15:24 Matteo Croce
2019-12-14  2:10 ` Jakub Kicinski [this message]
2019-12-14 13:14   ` Matteo Croce

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=20191213181051.0f949b17@cakuba.netronome.com \
    --to=jakub.kicinski@netronome.com \
    --cc=andy@greyhouse.net \
    --cc=j.vosburgh@gmail.com \
    --cc=linux-kernel@vger.kernel.org \
    --cc=mcroce@redhat.com \
    --cc=netdev@vger.kernel.org \
    --cc=vfalico@gmail.com \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox

all inboxes | Powered by JetHome®