From mboxrd@z Thu Jan 1 00:00:00 1970 Return-Path: X-Spam-Checker-Version: SpamAssassin 3.4.0 (2014-02-07) on aws-us-west-2-korg-lkml-1.web.codeaurora.org X-Spam-Level: X-Spam-Status: No, score=-2.2 required=3.0 tests=HEADER_FROM_DIFFERENT_DOMAINS, MAILING_LIST_MULTI,SPF_HELO_NONE,SPF_PASS,USER_AGENT_SANE_1 autolearn=no autolearn_force=no version=3.4.0 Received: from mail.kernel.org (mail.kernel.org [198.145.29.99]) by smtp.lore.kernel.org (Postfix) with ESMTP id 13166C282DD for ; Thu, 9 Jan 2020 17:32:50 +0000 (UTC) Received: from vger.kernel.org (vger.kernel.org [209.132.180.67]) by mail.kernel.org (Postfix) with ESMTP id C8FCE206ED for ; Thu, 9 Jan 2020 17:32:49 +0000 (UTC) Received: (majordomo@vger.kernel.org) by vger.kernel.org via listexpand id S1731857AbgAIRct (ORCPT ); Thu, 9 Jan 2020 12:32:49 -0500 Received: from mga09.intel.com ([134.134.136.24]:17885 "EHLO mga09.intel.com" rhost-flags-OK-OK-OK-OK) by vger.kernel.org with ESMTP id S1725775AbgAIRcs (ORCPT ); Thu, 9 Jan 2020 12:32:48 -0500 X-Amp-Result: UNKNOWN X-Amp-Original-Verdict: FILE UNKNOWN X-Amp-File-Uploaded: False Received: from fmsmga006.fm.intel.com ([10.253.24.20]) by orsmga102.jf.intel.com with ESMTP/TLS/DHE-RSA-AES256-GCM-SHA384; 09 Jan 2020 09:32:47 -0800 X-ExtLoop1: 1 X-IronPort-AV: E=Sophos;i="5.69,414,1571727600"; d="scan'208";a="423323930" Received: from chenyu-office.sh.intel.com ([10.239.158.173]) by fmsmga006.fm.intel.com with ESMTP; 09 Jan 2020 09:32:44 -0800 Date: Fri, 10 Jan 2020 01:31:40 +0800 From: Yu Chen To: Chris Down Cc: x86@kernel.org, Thomas Gleixner , Borislav Petkov , Ingo Molnar , "H. Peter Anvin" , Alexey Dobriyan , Andrew Morton , Reinette Chatre , Fenghua Yu , Tony Luck , Michal Hocko , Linus Torvalds , linux-fsdevel@vger.kernel.org, linux-api@vger.kernel.org, linux-kernel@vger.kernel.org Subject: Re: [PATCH][RESEND v5] x86/resctrl: Add task resctrl information display Message-ID: <20200109173140.GB11490@chenyu-office.sh.intel.com> References: <20200109135001.10076-1-yu.c.chen@intel.com> <20200109145355.GC61542@chrisdown.name> MIME-Version: 1.0 Content-Type: text/plain; charset=us-ascii Content-Disposition: inline In-Reply-To: <20200109145355.GC61542@chrisdown.name> User-Agent: Mutt/1.9.4 (2018-02-28) Sender: linux-kernel-owner@vger.kernel.org Precedence: bulk List-ID: X-Mailing-List: linux-kernel@vger.kernel.org Hi Chris, Thanks for looking at this patch. On Thu, Jan 09, 2020 at 02:53:55PM +0000, Chris Down wrote: > Chen Yu writes: > > +#ifdef CONFIG_PROC_CPU_RESCTRL > > + ONE("resctrl", S_IRUGO, proc_resctrl_show), > > There was already some discussion about "resctrl" by itself being a > misleading name, hence why the CONFIG option eventually became > CONFIG_X86_CPU_RESCTRL. Can you please rethink the name of this /proc file, > and have it at least be "cpu_resctrl" or "x86_resctrl" or similar? :-) Ok, I'll change the name from "resctrl" to "cpu_resctrl", because: 1. it is a CPU feature so a 'cpu' prefixed seems to be more obvious, 2. other CPUs than x86 could also use this file in the future. Thanks, Chenyu