From: Steven Rostedt <rostedt@goodmis.org>
To: linux-kernel@vger.kernel.org
Cc: Ingo Molnar <mingo@kernel.org>,
Andrew Morton <akpm@linux-foundation.org>,
Masami Hiramatsu <mhiramat@kernel.org>,
Tom Zanussi <zanussi@kernel.org>
Subject: [for-next][PATCH 1/6] tracing: Change trace_boot to use synth_event interface
Date: Sat, 01 Feb 2020 13:12:11 -0500 [thread overview]
Message-ID: <20200201181232.804196729@goodmis.org> (raw)
In-Reply-To: <20200201181210.203806308@goodmis.org>
From: Tom Zanussi <zanussi@kernel.org>
Have trace_boot_add_synth_event() use the synth_event interface.
Also, rename synth_event_run_cmd() to synth_event_run_command() now
that trace_boot's version is gone.
Link: http://lkml.kernel.org/r/94f1fa0e31846d0bddca916b8663404b20559e34.1580323897.git.zanussi@kernel.org
Acked-by: Masami Hiramatsu <mhiramat@kernel.org>
Signed-off-by: Tom Zanussi <zanussi@kernel.org>
Signed-off-by: Steven Rostedt (VMware) <rostedt@goodmis.org>
---
kernel/trace/trace_boot.c | 31 ++++++++++++-------------------
kernel/trace/trace_events_hist.c | 9 ++-------
2 files changed, 14 insertions(+), 26 deletions(-)
diff --git a/kernel/trace/trace_boot.c b/kernel/trace/trace_boot.c
index 2298a70cdda6..06d7feb5255f 100644
--- a/kernel/trace/trace_boot.c
+++ b/kernel/trace/trace_boot.c
@@ -125,38 +125,31 @@ trace_boot_add_kprobe_event(struct xbc_node *node, const char *event)
#endif
#ifdef CONFIG_HIST_TRIGGERS
-extern int synth_event_run_command(const char *command);
-
static int __init
trace_boot_add_synth_event(struct xbc_node *node, const char *event)
{
+ struct dynevent_cmd cmd;
struct xbc_node *anode;
- char buf[MAX_BUF_LEN], *q;
+ char buf[MAX_BUF_LEN];
const char *p;
- int len, delta, ret;
+ int ret;
- len = ARRAY_SIZE(buf);
- delta = snprintf(buf, len, "%s", event);
- if (delta >= len) {
- pr_err("Event name is too long: %s\n", event);
- return -E2BIG;
- }
- len -= delta; q = buf + delta;
+ synth_event_cmd_init(&cmd, buf, MAX_BUF_LEN);
+
+ ret = synth_event_gen_cmd_start(&cmd, event, NULL);
+ if (ret)
+ return ret;
xbc_node_for_each_array_value(node, "fields", anode, p) {
- delta = snprintf(q, len, " %s;", p);
- if (delta >= len) {
- pr_err("fields string is too long: %s\n", p);
- return -E2BIG;
- }
- len -= delta; q += delta;
+ ret = synth_event_add_field_str(&cmd, p);
+ if (ret)
+ return ret;
}
- ret = synth_event_run_command(buf);
+ ret = synth_event_gen_cmd_end(&cmd);
if (ret < 0)
pr_err("Failed to add synthetic event: %s\n", buf);
-
return ret;
}
#else
diff --git a/kernel/trace/trace_events_hist.c b/kernel/trace/trace_events_hist.c
index 4d56a4f0310d..2e88c9805f4b 100644
--- a/kernel/trace/trace_events_hist.c
+++ b/kernel/trace/trace_events_hist.c
@@ -1755,12 +1755,7 @@ static int create_or_delete_synth_event(int argc, char **argv)
return ret == -ECANCELED ? -EINVAL : ret;
}
-int synth_event_run_command(const char *command)
-{
- return trace_run_command(command, create_or_delete_synth_event);
-}
-
-static int synth_event_run_cmd(struct dynevent_cmd *cmd)
+static int synth_event_run_command(struct dynevent_cmd *cmd)
{
struct synth_event *se;
int ret;
@@ -1790,7 +1785,7 @@ static int synth_event_run_cmd(struct dynevent_cmd *cmd)
void synth_event_cmd_init(struct dynevent_cmd *cmd, char *buf, int maxlen)
{
dynevent_cmd_init(cmd, buf, maxlen, DYNEVENT_TYPE_SYNTH,
- synth_event_run_cmd);
+ synth_event_run_command);
}
EXPORT_SYMBOL_GPL(synth_event_cmd_init);
--
2.24.1
next prev parent reply other threads:[~2020-02-01 18:12 UTC|newest]
Thread overview: 7+ messages / expand[flat|nested] mbox.gz Atom feed top
2020-02-01 18:12 [for-next][PATCH 0/6] tracing: Some last minute fixes for 5.6 Steven Rostedt
2020-02-01 18:12 ` Steven Rostedt [this message]
2020-02-01 18:12 ` [for-next][PATCH 2/6] tracing: Fix now invalid var_ref_vals assumption in trace action Steven Rostedt
2020-02-01 18:12 ` [for-next][PATCH 3/6] tracing: Consolidate some synth_event_trace code Steven Rostedt
2020-02-01 18:12 ` [for-next][PATCH 4/6] tracing: Remove check_arg() callbacks from dynevent args Steven Rostedt
2020-02-01 18:12 ` [for-next][PATCH 5/6] tracing: Remove useless code in dynevent_arg_pair_add() Steven Rostedt
2020-02-01 18:12 ` [for-next][PATCH 6/6] tracing: Use seq_buf for building dynevent_cmd string Steven Rostedt
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=20200201181232.804196729@goodmis.org \
--to=rostedt@goodmis.org \
--cc=akpm@linux-foundation.org \
--cc=linux-kernel@vger.kernel.org \
--cc=mhiramat@kernel.org \
--cc=mingo@kernel.org \
--cc=zanussi@kernel.org \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
Powered by JetHome