From: Andy Shevchenko <andriy.shevchenko@linux.intel.com>
To: Gayatri Kammela <gayatri.kammela@intel.com>
Cc: platform-driver-x86@vger.kernel.org,
linux-kernel@vger.kernel.org, vishwanath.somayaji@intel.com,
dvhart@infradead.org, mika.westerberg@intel.com,
peterz@infradead.org, charles.d.prestopine@intel.com,
Chen Zhou <chenzhou10@huawei.com>,
"David E . Box" <david.e.box@intel.com>
Subject: Re: [PATCH v3 5/5] platform/x86: intel_pmc_core: fix: Make pmc_core_lpm_display() generic for platforms that support sub-states
Date: Mon, 2 Mar 2020 14:53:43 +0200 [thread overview]
Message-ID: <20200302125343.GU1224808@smile.fi.intel.com> (raw)
In-Reply-To: <5e28f488a6cc8b7c1e08b536868844b586a1eaf1.1583093898.git.gayatri.kammela@intel.com>
On Sun, Mar 01, 2020 at 12:44:26PM -0800, Gayatri Kammela wrote:
> Currently pmc_core_lpm_display() uses array of struct pointers i.e.,
> tgl_lpm_maps for Tiger Lake directly to iterate through and to get the
> number of status/live status registers which is hardcoded and cannot
> be re-used for future platforms that support sub-states. To maintain
> readability, make pmc_core_lpm_display() generic, so that it can re-used
> for future platforms.
My comments below.
...
> +static int pmc_core_lpm_get_arr_size(const struct pmc_bit_map **maps)
> +{
> + int idx, arr_size = 0;
And why do you need arr_size variable at all?
> +
> + for (idx = 0; maps[idx]; idx++)
> + arr_size++;
> +
> + return arr_size;
> +}
...
> - int index, idx, len = 32, bit_mask;
> + int index, idx, bit_mask, len = 32;
What's the point of shuffling this?
> + int arr_size = pmc_core_lpm_get_arr_size(maps);
This would be better in a split manner, i.e.
int arr_size;
...
arr_size = ...;
...
> + lpm_regs = kmalloc_array(arr_size, sizeof(*lpm_regs), GFP_KERNEL);
> + if(!lpm_regs)
> + goto err;
There is no point to have the label. Simple return will work.
> - for (index = 0; tgl_lpm_maps[index]; index++) {
> + for (index = 0; maps[index]; index++) {
Why not to reuse arr_size here?
> lpm_regs[index] = pmc_core_reg_read(pmcdev, offset);
> offset += 4;
> }
--
With Best Regards,
Andy Shevchenko
next prev parent reply other threads:[~2020-03-02 12:53 UTC|newest]
Thread overview: 15+ messages / expand[flat|nested] mbox.gz Atom feed top
2020-03-01 20:44 [PATCH v3 0/5] platform/x86: intel_pmc_core: Add bug fixes or code Gayatri Kammela
2020-03-01 20:44 ` [PATCH v3 1/5] platform/x86: intel_pmc_core: fix: Relocate pmc_core_slps0_display() and pmc_core_lpm_display() to outside of CONFIG_DEBUG_FS Gayatri Kammela
2020-03-01 20:44 ` [PATCH v3 2/5] platform/x86: intel_pmc_core: fix: Remove the duplicate if() to create debugfs entry for substate_live_status_registers Gayatri Kammela
2020-03-01 20:44 ` [PATCH v3 3/5] platform/x86: intel_pmc_core: fix: Add slp_s0_offset attribute back to tgl_reg_map Gayatri Kammela
2020-03-01 20:44 ` [PATCH v3 4/5] platform/x86: intel_pmc_core: Make pmc_core_substate_res_show() generic Gayatri Kammela
2020-03-01 20:44 ` [PATCH v3 5/5] platform/x86: intel_pmc_core: fix: Make pmc_core_lpm_display() generic for platforms that support sub-states Gayatri Kammela
2020-03-02 12:53 ` Andy Shevchenko [this message]
2020-03-02 18:57 ` Kammela, Gayatri
2020-03-02 12:54 ` [PATCH v3 0/5] platform/x86: intel_pmc_core: Add bug fixes or code Andy Shevchenko
2020-03-02 18:29 ` Kammela, Gayatri
2020-03-19 17:57 ` Kammela, Gayatri
2020-03-19 18:06 ` Andy Shevchenko
2020-03-19 18:15 ` Kammela, Gayatri
2020-03-20 13:50 ` Andy Shevchenko
2020-03-20 17:34 ` Kammela, Gayatri
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=20200302125343.GU1224808@smile.fi.intel.com \
--to=andriy.shevchenko@linux.intel.com \
--cc=charles.d.prestopine@intel.com \
--cc=chenzhou10@huawei.com \
--cc=david.e.box@intel.com \
--cc=dvhart@infradead.org \
--cc=gayatri.kammela@intel.com \
--cc=linux-kernel@vger.kernel.org \
--cc=mika.westerberg@intel.com \
--cc=peterz@infradead.org \
--cc=platform-driver-x86@vger.kernel.org \
--cc=vishwanath.somayaji@intel.com \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
all inboxes | Powered by JetHome®